    <!doctype html>
<html lang="en-US">
    <head> <script type="text/javascript">if(!gform){document.addEventListener("gform_main_scripts_loaded",function(){gform.scriptsLoaded=!0}),window.addEventListener("DOMContentLoaded",function(){gform.domLoaded=!0});var gform={domLoaded:!1,scriptsLoaded:!1,initializeOnLoaded:function(o){gform.domLoaded&&gform.scriptsLoaded?o():!gform.domLoaded&&gform.scriptsLoaded?window.addEventListener("DOMContentLoaded",o):document.addEventListener("gform_main_scripts_loaded",o)},hooks:{action:{},filter:{}},addAction:function(o,n,r,t){gform.addHook("action",o,n,r,t)},addFilter:function(o,n,r,t){gform.addHook("filter",o,n,r,t)},doAction:function(o){gform.doHook("action",o,arguments)},applyFilters:function(o){return gform.doHook("filter",o,arguments)},removeAction:function(o,n){gform.removeHook("action",o,n)},removeFilter:function(o,n,r){gform.removeHook("filter",o,n,r)},addHook:function(o,n,r,t,i){null==gform.hooks[o][n]&&(gform.hooks[o][n]=[]);var e=gform.hooks[o][n];null==i&&(i=n+"_"+e.length),null==t&&(t=10),gform.hooks[o][n].push({tag:i,callable:r,priority:t})},doHook:function(o,n,r){if(r=Array.prototype.slice.call(r,1),null!=gform.hooks[o][n]){var t,i=gform.hooks[o][n];i.sort(function(o,n){return o.priority-n.priority});for(var e=0;e<i.length;e++)"function"!=typeof(t=i[e].callable)&&(t=window[t]),"action"==o?t.apply(null,r):r[0]=t.apply(null,r)}if("filter"==o)return r[0]},removeHook:function(o,n,r,t){if(null!=gform.hooks[o][n])for(var i=gform.hooks[o][n],e=i.length-1;0<=e;e--)null!=t&&t!=i[e].tag||null!=r&&r!=i[e].priority||i.splice(e,1)}}}</script>
        <!--        <meta name="google-site-verification" content="g2ci_6qmcvh7_y2eKOdcJ_ofJilQcjlTT4FWnCkZZ34" />-->
        <meta name="google-site-verification" content="ZnIIIt2Q8G6ql3DVglEy1NEJbkGNLvbDKyOzR1_2KxE"/>
        <meta charset="UTF-8">
        <meta name="viewport" content="width=device-width, initial-scale=1">
        <link rel="profile" href="http://gmpg.org/xfn/11">

	            <link rel="stylesheet" type="text/css" href="https://htlbid.com/v3/embedded.com/htlbid.css"/>
	    
        <!-- Google Tag Manager -->
        <script>(function (w, d, s, l, i) {
                w[l] = w[l] || [];
                w[l].push({
                    'gtm.start':
                        new Date().getTime(), event: 'gtm.js'
                });
                var f = d.getElementsByTagName(s)[0],
                    j = d.createElement(s), dl = l != 'dataLayer' ? '&l=' + l : '';
                j.async = true;
                j.src =
                    'https://www.googletagmanager.com/gtm.js?id=' + i + dl;
                f.parentNode.insertBefore(j, f);
            })(window, document, 'script', 'dataLayer', 'GTM-NMNZ3NH');</script>
        <!-- End Google Tag Manager -->

        <!-- BEGIN Krux ControlTag for "AspenCore Generic" -->
        <script class="kxct" data-id="sbnf4txm4" data-timing="async" data-version="3.0" type="text/javascript">
            window.Krux || ((Krux = function () {
                Krux.q.push(arguments)
            }).q = []);
            (function () {
                var k = document.createElement('script');
                k.type = 'text/javascript';
                k.async = true;
                k.src = (location.protocol === 'https:' ? 'https:' : 'http:') + '//cdn.krxd.net/controltag/sbnf4txm4.js';
                var s = document.getElementsByTagName('script')[0];
                s.parentNode.insertBefore(k, s);
            }());
        </script>

        <!-- END Krux ControlTag -->
        <script class="kxint" data-namespace="aspencore" type="text/javascript">
            window.Krux || ((Krux = function () {
                Krux.q.push(arguments);
            }).q = []);
            (function () {
                function retrieve(n) {
                    var k = 'kx' + 'aspencore_' + n, ls = (function () {
                        try {
                            return window.localStorage;
                        } catch (e) {
                            return null;
                        }
                    })();
                    if (ls) {
                        return ls[k] || '';
                    } else if (navigator.cookieEnabled) {
                        var m = document.cookie.match(k + '=([^;]*)');
                        return (m && unescape(m[1])) || '';
                    } else {
                        return '';
                    }
                }

                Krux.user = retrieve('user');
                Krux.segments = retrieve('segs') ? retrieve('segs').split(',') : [];
            })();
        </script>

        <script async src="https://pagead2.googlesyndication.com/pagead/js/adsbygoogle.js?client=ca-pub-7851664831175719"
                crossorigin="anonymous"></script>

		
					                <script>
                    dmpDataLayer = [{"title":"5 embedded software architecture pitfalls","section":["Blog"],"pageType":"Blog","keywords":["Design Methods","Tools &amp; Software"]}];
                </script>

					
        <script>
            dataLayer = [{
                'Author': 'Stephen Evanczuk',
                'PubDate': '20220831'
            }];
        </script>

<!--        <script async src="//js-sec.indexww.com/ht/p/191067-63147096656869.js"></script>-->

        <!-- Google Tag Manager -->
        <script>
            (function (w, d, s, l, i) {
                w[l] = w[l] || [];
                w[l].push({
                    'gtm.start':
                        new Date().getTime(), event: 'gtm.js'
                });
                var f = d.getElementsByTagName(s)[0],
                    j = d.createElement(s), dl = l != 'dataLayer' ? '&l=' + l : '';
                j.async = true;
                j.src = 'https://www.googletagmanager.com/gtm.js?id=' + i + dl;
                f.parentNode.insertBefore(j, f);
            })(window, document, 'script', 'dataLayer', 'GTM-KV6L8V7');

            var gptadslots = [];
        </script>
        <!-- End Google Tag Manager -->

<!--        <script async src='https://securepubads.g.doubleclick.net/tag/js/gpt.js'></script>-->

					        <link rel="stylesheet" href="https://olytics.omeda.com/olytics/css/v3/p/olytics.css"/>
            <script type="text/javascript">
                // olytics 3.0
                window.olytics || (window.olytics = []), window.olytics.methods = ["fire", "confirm"], window.olytics.factory = function (i) {
                    return function () {
                        var t = Array.prototype.slice.call(arguments);
                        return t.unshift(i), window.olytics.push(t), window.olytics
                    }
                };
                for (var i = 0; i < window.olytics.methods.length; i++) {
                    var method = window.olytics.methods[i];
                    window.olytics[method] = window.olytics.factory(method)
                }
                olytics.load = function (i) {
                    if (!document.getElementById("olyticsImport")) {
                        window.a = window.olytics;
                        var t = document.createElement("script");
                        t.async = !0, t.id = "olyticsImport", t.type = "text/javascript";
                        var o = "";
                        void 0 !== i && void 0 !== i.oid && (o = i.oid), t.setAttribute("data-oid", o), t.src = "https://olytics.omeda.com/olytics/js/v3/p/olytics.min.js", t.addEventListener("load", function (t) {
                            for (olytics.initialize({Olytics: i}); window.a.length > 0;) {
                                var o = window.a.shift(), s = o.shift();
                                olytics[s] && olytics[s].apply(olytics, o)
                            }
                        }, !1);
                        var s = document.getElementsByTagName("script")[0];
                        s.parentNode.insertBefore(t, s)
                    }
                }, olytics.load({oid: "eeed6a1c8d2f4363a5a1204c00fbd258"});
            </script>
		
		
            <script>
                olytics.fire(
                    {
                        behaviorId: '3904C2457689A1C',
                        category: 'Blog',
                        tag: 'Design Methods,Tools &amp; Software'
                    }
                );
            </script>
		
        <!-- Facebook Pixel Code -->
        <script>
            !function (f, b, e, v, n, t, s) {
                if (f.fbq) return;
                n = f.fbq = function () {
                    n.callMethod ?
                        n.callMethod.apply(n, arguments) : n.queue.push(arguments)
                };
                if (!f._fbq) f._fbq = n;
                n.push = n;
                n.loaded = !0;
                n.version = '2.0';
                n.queue = [];
                t = b.createElement(e);
                t.async = !0;
                t.src = v;
                s = b.getElementsByTagName(e)[0];
                s.parentNode.insertBefore(t, s)
            }(window, document, 'script',
                'https://connect.facebook.net/en_US/fbevents.js');
            fbq('init', '619567575574828');
            fbq('track', 'PageView');
        </script>

        <noscript>
            <img height="1" width="1" style="display:none"
                 src="https://www.facebook.com/tr?id=619567575574828&ev=PageView&noscript=1"/>
        </noscript>

        <script type="text/javascript">!(function (o, n, t) {
                t = o.createElement(n), o = o.getElementsByTagName(n)[0], t.async = 1, t.src = "https://caringcast.com/v2swlM_-mwBq6PLvBsojLU_mleeZ2vPBVsWnOQoC6fnCBpn_LtmPqj5w", o.parentNode.insertBefore(t, o)
            })(document, "script"), (function (o, n) {
                function t() {
                    (t.q = t.q || []).push(arguments)
                }

                t.v = 1, o.admiral = o.admiral || t
            })(window);
            !(function (o, t, n, c) {
                function e(n) {
                    (function () {
                        try {
                            return (localStorage.getItem("v4ac1eiZr0") || "").split(",")[4] > 0
                        } catch (o) {
                        }
                        return !1
                    })() && (n = o[t].pubads()) && n.setTargeting("admiral-engaged", "true")
                }

                (c = o[t] = o[t] || {}).cmd = c.cmd || [], typeof c.pubads === n ? e() : typeof c.cmd.unshift === n ? c.cmd.unshift(e) : c.cmd.push(e)
            })(window, "googletag", "function");</script>

        <!-- End Facebook Pixel Code -->
		<meta name='robots' content='index, follow, max-image-preview:large, max-snippet:-1, max-video-preview:-1' />

	<!-- This site is optimized with the Yoast SEO plugin v19.5.1 - https://yoast.com/wordpress/plugins/seo/ -->
	<title>5 embedded software architecture pitfalls - Embedded.com</title>
	<meta name="description" content="Software architecture is a critical design element that guides developers in building an embedded application successfully. Here are five pitfalls that" />
	<link rel="canonical" href="https://www.embedded.com/5-embedded-software-architecture-pitfalls/" />
	<meta property="og:locale" content="en_US" />
	<meta property="og:type" content="article" />
	<meta property="og:title" content="5 embedded software architecture pitfalls - Embedded.com" />
	<meta property="og:description" content="Software architecture is a critical design element that guides developers in building an embedded application successfully. Here are five pitfalls that" />
	<meta property="og:url" content="https://www.embedded.com/5-embedded-software-architecture-pitfalls/" />
	<meta property="og:site_name" content="Embedded.com" />
	<meta property="article:publisher" content="https://www.facebook.com/embeddedcom" />
	<meta property="article:published_time" content="2022-08-31T16:53:17+00:00" />
	<meta property="article:modified_time" content="2022-08-31T16:53:22+00:00" />
	<meta property="og:image" content="https://www.embedded.com/wp-content/uploads/2022/08/Caryatids-Greece.jpeg" />
	<meta property="og:image:width" content="698" />
	<meta property="og:image:height" content="653" />
	<meta property="og:image:type" content="image/jpeg" />
	<meta name="author" content="Stephen Evanczuk" />
	<meta name="twitter:card" content="summary_large_image" />
	<meta name="twitter:creator" content="@embedded_online" />
	<meta name="twitter:site" content="@embedded_online" />
	<meta name="twitter:label1" content="Written by" />
	<meta name="twitter:data1" content="Stephen Evanczuk" />
	<meta name="twitter:label2" content="Est. reading time" />
	<meta name="twitter:data2" content="7 minutes" />
	<script type="application/ld+json" class="yoast-schema-graph">{"@context":"https://schema.org","@graph":[{"@type":"NewsArticle","@id":"https://www.embedded.com/5-embedded-software-architecture-pitfalls/#article","isPartOf":{"@id":"https://www.embedded.com/5-embedded-software-architecture-pitfalls/"},"author":{"name":"Stephen Evanczuk","@id":"https://www.embedded.com/#/schema/person/03f73c2db7d5526dd9069ddcfbc2cf6c"},"headline":"5 embedded software architecture pitfalls","datePublished":"2022-08-31T16:53:17+00:00","dateModified":"2022-08-31T16:53:22+00:00","mainEntityOfPage":{"@id":"https://www.embedded.com/5-embedded-software-architecture-pitfalls/"},"wordCount":1320,"commentCount":0,"publisher":{"@id":"https://www.embedded.com/#organization"},"image":{"@id":"https://www.embedded.com/5-embedded-software-architecture-pitfalls/#primaryimage"},"thumbnailUrl":"https://www.embedded.com/wp-content/uploads/2022/08/Caryatids-Greece.jpeg","keywords":["Design Methods","Tools &amp; Software"],"articleSection":["Blog"],"inLanguage":"en-US","potentialAction":[{"@type":"CommentAction","name":"Comment","target":["https://www.embedded.com/5-embedded-software-architecture-pitfalls/#respond"]}]},{"@type":"WebPage","@id":"https://www.embedded.com/5-embedded-software-architecture-pitfalls/","url":"https://www.embedded.com/5-embedded-software-architecture-pitfalls/","name":"5 embedded software architecture pitfalls - Embedded.com","isPartOf":{"@id":"https://www.embedded.com/#website"},"primaryImageOfPage":{"@id":"https://www.embedded.com/5-embedded-software-architecture-pitfalls/#primaryimage"},"image":{"@id":"https://www.embedded.com/5-embedded-software-architecture-pitfalls/#primaryimage"},"thumbnailUrl":"https://www.embedded.com/wp-content/uploads/2022/08/Caryatids-Greece.jpeg","datePublished":"2022-08-31T16:53:17+00:00","dateModified":"2022-08-31T16:53:22+00:00","description":"Software architecture is a critical design element that guides developers in building an embedded application successfully. Here are five pitfalls that","breadcrumb":{"@id":"https://www.embedded.com/5-embedded-software-architecture-pitfalls/#breadcrumb"},"inLanguage":"en-US","potentialAction":[{"@type":"ReadAction","target":["https://www.embedded.com/5-embedded-software-architecture-pitfalls/"]}]},{"@type":"ImageObject","inLanguage":"en-US","@id":"https://www.embedded.com/5-embedded-software-architecture-pitfalls/#primaryimage","url":"https://www.embedded.com/wp-content/uploads/2022/08/Caryatids-Greece.jpeg","contentUrl":"https://www.embedded.com/wp-content/uploads/2022/08/Caryatids-Greece.jpeg","width":698,"height":653},{"@type":"BreadcrumbList","@id":"https://www.embedded.com/5-embedded-software-architecture-pitfalls/#breadcrumb","itemListElement":[{"@type":"ListItem","position":1,"name":"Home","item":"https://www.embedded.com/"},{"@type":"ListItem","position":2,"name":"5 embedded software architecture pitfalls"}]},{"@type":"WebSite","@id":"https://www.embedded.com/#website","url":"https://www.embedded.com/","name":"Embedded.com","description":"cracking the code to system development","publisher":{"@id":"https://www.embedded.com/#organization"},"potentialAction":[{"@type":"SearchAction","target":{"@type":"EntryPoint","urlTemplate":"https://www.embedded.com/?s={search_term_string}"},"query-input":"required name=search_term_string"}],"inLanguage":"en-US"},{"@type":"Organization","@id":"https://www.embedded.com/#organization","name":"Embedded","url":"https://www.embedded.com/","sameAs":["https://www.linkedin.com/company/embedded-com/","https://www.youtube.com/channel/UCET4UxEwQ2dZfZBSPMEJdhA","https://www.facebook.com/embeddedcom","https://twitter.com/embedded_online"],"logo":{"@type":"ImageObject","inLanguage":"en-US","@id":"https://www.embedded.com/#/schema/logo/image/","url":"https://www.embedded.com/wp-content/uploads/2020/09/Embedded-login-logo.png","contentUrl":"https://www.embedded.com/wp-content/uploads/2020/09/Embedded-login-logo.png","width":218,"height":58,"caption":"Embedded"},"image":{"@id":"https://www.embedded.com/#/schema/logo/image/"}},{"@type":"Person","@id":"https://www.embedded.com/#/schema/person/03f73c2db7d5526dd9069ddcfbc2cf6c","name":"Stephen Evanczuk","image":{"@type":"ImageObject","inLanguage":"en-US","@id":"https://www.embedded.com/#/schema/person/image/","url":"https://secure.gravatar.com/avatar/fb7076c11b0227156c0c6c579ad597ab?s=96&d=mm&r=g","contentUrl":"https://secure.gravatar.com/avatar/fb7076c11b0227156c0c6c579ad597ab?s=96&d=mm&r=g","caption":"Stephen Evanczuk"},"sameAs":["Stephen"],"url":"https://www.embedded.com/author/evanczust01/"}]}</script>
	<!-- / Yoast SEO plugin. -->


<link rel='dns-prefetch' href='//fonts.googleapis.com' />
<link rel='dns-prefetch' href='//s.w.org' />
<link rel="alternate" type="application/rss+xml" title="Embedded.com &raquo; Feed" href="https://www.embedded.com/feed/" />
<link rel="alternate" type="application/rss+xml" title="Embedded.com &raquo; Comments Feed" href="https://www.embedded.com/comments/feed/" />
        <meta name="created" content="August 31, 2022"/>
		            <meta name="author" content="Stephen Evanczuk"/>
		        <meta name="featuredimage" content="https://www.embedded.com/wp-content/uploads/2022/08/Caryatids-Greece.jpeg?w=640"/>
			
						                <meta name="section" content="embedded-design-methods"/>
							                <meta name="section" content="embedded-tools-software"/>
					
	
	<link rel="alternate" type="application/rss+xml" title="Embedded.com &raquo; 5 embedded software architecture pitfalls Comments Feed" href="https://www.embedded.com/5-embedded-software-architecture-pitfalls/feed/" />
<script type="text/javascript">
window._wpemojiSettings = {"baseUrl":"https:\/\/s.w.org\/images\/core\/emoji\/14.0.0\/72x72\/","ext":".png","svgUrl":"https:\/\/s.w.org\/images\/core\/emoji\/14.0.0\/svg\/","svgExt":".svg","source":{"concatemoji":"https:\/\/www.embedded.com\/wp-includes\/js\/wp-emoji-release.min.js?ver=6.0.2"}};
/*! This file is auto-generated */
!function(e,a,t){var n,r,o,i=a.createElement("canvas"),p=i.getContext&&i.getContext("2d");function s(e,t){var a=String.fromCharCode,e=(p.clearRect(0,0,i.width,i.height),p.fillText(a.apply(this,e),0,0),i.toDataURL());return p.clearRect(0,0,i.width,i.height),p.fillText(a.apply(this,t),0,0),e===i.toDataURL()}function c(e){var t=a.createElement("script");t.src=e,t.defer=t.type="text/javascript",a.getElementsByTagName("head")[0].appendChild(t)}for(o=Array("flag","emoji"),t.supports={everything:!0,everythingExceptFlag:!0},r=0;r<o.length;r++)t.supports[o[r]]=function(e){if(!p||!p.fillText)return!1;switch(p.textBaseline="top",p.font="600 32px Arial",e){case"flag":return s([127987,65039,8205,9895,65039],[127987,65039,8203,9895,65039])?!1:!s([55356,56826,55356,56819],[55356,56826,8203,55356,56819])&&!s([55356,57332,56128,56423,56128,56418,56128,56421,56128,56430,56128,56423,56128,56447],[55356,57332,8203,56128,56423,8203,56128,56418,8203,56128,56421,8203,56128,56430,8203,56128,56423,8203,56128,56447]);case"emoji":return!s([129777,127995,8205,129778,127999],[129777,127995,8203,129778,127999])}return!1}(o[r]),t.supports.everything=t.supports.everything&&t.supports[o[r]],"flag"!==o[r]&&(t.supports.everythingExceptFlag=t.supports.everythingExceptFlag&&t.supports[o[r]]);t.supports.everythingExceptFlag=t.supports.everythingExceptFlag&&!t.supports.flag,t.DOMReady=!1,t.readyCallback=function(){t.DOMReady=!0},t.supports.everything||(n=function(){t.readyCallback()},a.addEventListener?(a.addEventListener("DOMContentLoaded",n,!1),e.addEventListener("load",n,!1)):(e.attachEvent("onload",n),a.attachEvent("onreadystatechange",function(){"complete"===a.readyState&&t.readyCallback()})),(e=t.source||{}).concatemoji?c(e.concatemoji):e.wpemoji&&e.twemoji&&(c(e.twemoji),c(e.wpemoji)))}(window,document,window._wpemojiSettings);
</script>
<style type="text/css">
img.wp-smiley,
img.emoji {
	display: inline !important;
	border: none !important;
	box-shadow: none !important;
	height: 1em !important;
	width: 1em !important;
	margin: 0 0.07em !important;
	vertical-align: -0.1em !important;
	background: none !important;
	padding: 0 !important;
}
</style>
	<link rel='stylesheet' id='all-css-0' href='https://www.embedded.com/_static/??-eJyNy0EKgCAQheELZUNE1iY6i+kQU6OFY4S3z01Qu5Y/731wHYqC5dOhgBUBR5Jg5t1uimmOJmaQlBlrT6EuhwreYhXw6Mggo8eQPnGwyRgV42Js/sfL9u4HTX5stG6GQbd9dwOHwEG0' type='text/css' media='all' />
<style id='wp-block-library-inline-css'>
.has-text-align-justify{text-align:justify;}
</style>
<style id='global-styles-inline-css'>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</style>
<link rel='stylesheet' id='all-css-2' href='https://www.embedded.com/_static/??-eJylj00SgjAMhS9kqTqCbhzPUkvAStvEpsh4e6GCC1l13OX95Jt5ciCh0UfwUZLtW+NZasTOgLBqEMY3KKm/WqOl5lUkPlExRhv5H6mtKaw48QYOpu4TgoeBBQWUihkiy2bsCDUAowPxLBN08hZLWVs447OYV8TIMShKtK/K5vC4skuMdOX/mzqk9/ujh/AqJl3UKnRZFKdabxqjBSH19CNz99QQkjOPmuWy7OLOu6ra7k/V4Vi+AdQ44Qw=' type='text/css' media='all' />
<link rel='stylesheet' id='covernews-google-fonts-css'  href='https://fonts.googleapis.com/css?family=Source%20Sans%20Pro:400,400i,700,700i|Source%20Sans%20Pro:400,400i,700,700i&#038;subset=latin,latin-ext' media='all' />
<link rel='stylesheet' id='all-css-4' href='https://www.embedded.com/_static/??-eJyNjcsKwjAURH/I9BqhgS7Eb6nJoNXmQefG4t9bRdwUpIvZDOfMyFyMz0mRVPSKCAriGSEgCPU5ovHkTtaUzw9MCTNNmfJ/dNvgj+pJ6HLAJZWa48qI1ZSxXoZEuUFL7+/G2ubwUb7F2znFo3XOdq7dd+0LOs1ViA==' type='text/css' media='all' />
<style id='covernews-style-inline-css'>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</style>
<script id='cookie-law-info-js-extra'>
var Cli_Data = {"nn_cookie_ids":[],"cookielist":[],"non_necessary_cookies":[],"ccpaEnabled":"","ccpaRegionBased":"","ccpaBarEnabled":"","strictlyEnabled":["necessary","obligatoire"],"ccpaType":"gdpr","js_blocking":"1","custom_integration":"","triggerDomRefresh":"","secure_cookies":""};
var cli_cookiebar_settings = {"animate_speed_hide":"500","animate_speed_show":"500","background":"#FFF","border":"#b1a6a6c2","border_on":"","button_1_button_colour":"#61a229","button_1_button_hover":"#4e8221","button_1_link_colour":"#fff","button_1_as_button":"1","button_1_new_win":"","button_2_button_colour":"#333","button_2_button_hover":"#292929","button_2_link_colour":"#444","button_2_as_button":"","button_2_hidebar":"","button_3_button_colour":"#dedfe0","button_3_button_hover":"#b2b2b3","button_3_link_colour":"#333333","button_3_as_button":"1","button_3_new_win":"","button_4_button_colour":"#dedfe0","button_4_button_hover":"#b2b2b3","button_4_link_colour":"#333333","button_4_as_button":"1","button_7_button_colour":"#61a229","button_7_button_hover":"#4e8221","button_7_link_colour":"#fff","button_7_as_button":"1","button_7_new_win":"","font_family":"inherit","header_fix":"","notify_animate_hide":"1","notify_animate_show":"","notify_div_id":"#cookie-law-info-bar","notify_position_horizontal":"right","notify_position_vertical":"bottom","scroll_close":"","scroll_close_reload":"","accept_close_reload":"","reject_close_reload":"","showagain_tab":"","showagain_background":"#fff","showagain_border":"#000","showagain_div_id":"#cookie-law-info-again","showagain_x_position":"100px","text":"#333333","show_once_yn":"","show_once":"10000","logging_on":"","as_popup":"","popup_overlay":"1","bar_heading_text":"","cookie_bar_as":"banner","popup_showagain_position":"bottom-right","widget_position":"left"};
var log_object = {"ajax_url":"https:\/\/www.embedded.com\/wp-admin\/admin-ajax.php"};
</script>
<script type="text/javascript" src="https://www.embedded.com/_static/??-eJx9jsEOwiAQRH9I2LQq9mL8lhbWusgCFkjj30vTJpoeTCaZw0zeDMxRkNeuGExgq14Fp/dmkslLmw7wrySYxqnP+FvWwWf0GaIrI/kEOoQnoXD9XDn3ALEMjvSC2iViTfac/ECu08gDGoPm+0G0spWnbfrG10appuvU8XK2H/6VTw4=" ></script><link rel="https://api.w.org/" href="https://www.embedded.com/wp-json/" /><link rel="alternate" type="application/json" href="https://www.embedded.com/wp-json/wp/v2/posts/4476093" /><link rel="EditURI" type="application/rsd+xml" title="RSD" href="https://www.embedded.com/xmlrpc.php?rsd" />
<link rel="wlwmanifest" type="application/wlwmanifest+xml" href="https://www.embedded.com/wp-includes/wlwmanifest.xml" /> 
<meta name="generator" content="WordPress 6.0.2" />
<link rel='shortlink' href='https://www.embedded.com/?p=4476093' />
<link rel="alternate" type="application/json+oembed" href="https://www.embedded.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fwww.embedded.com%2F5-embedded-software-architecture-pitfalls%2F" />
<link rel="alternate" type="text/xml+oembed" href="https://www.embedded.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fwww.embedded.com%2F5-embedded-software-architecture-pitfalls%2F&#038;format=xml" />
<style>img#wpstats{display:none}</style>
	<link rel="pingback" href="https://www.embedded.com/xmlrpc.php">        <style type="text/css">
                        .site-title,
            .site-description {
                position: absolute;
                clip: rect(1px, 1px, 1px, 1px);
                display: none;
            }

            

        </style>
        <link rel="icon" href="https://www.embedded.com/wp-content/uploads/2019/10/favicon1.ico?w=16" sizes="32x32" />
<link rel="icon" href="https://www.embedded.com/wp-content/uploads/2019/10/favicon1.ico?w=16" sizes="192x192" />
<link rel="apple-touch-icon" href="https://www.embedded.com/wp-content/uploads/2019/10/favicon1.ico?w=16" />
<meta name="msapplication-TileImage" content="https://www.embedded.com/wp-content/uploads/2019/10/favicon1.ico?w=16" />
		<style type="text/css" id="wp-custom-css">
			.home div#div-gpt-ad-1643812467243-0 {
	display: none;
}		</style>
		
	    
    <script async src="https://htlbid.com/v3/embedded.com/htlbid.js"></script>

<script>
    console.log('category string: ' + 'Blog');
    console.log('tag string: ' + 'Design Methods,Tools &amp; Software');
    console.log('ksg: ' + Krux.segments);
    console.log('kuid: ' + Krux.user);

    var cat_array = [];
                    cat_array.push('Blog');
        
    var tag_array = [];
	                tag_array.push('Design Methods');
                    tag_array.push('Tools &amp; Software');
        
    window.htlbid = window.htlbid || {};
    htlbid.cmd = htlbid.cmd || [];
    var sectionMeta = document.querySelector("meta[name='section']");
    console.log(sectionMeta);

    htlbid.cmd.push(function () {
        htlbid.layout('universal');
	    
		        htlbid.setTargeting('post_id', 4476093);
        htlbid.setTargeting('kw', ['DesignMethods', 'Tools&amp;Software']);
        htlbid.setTargeting('author', ['StephenEvanczuk']);
        htlbid.setTargeting('aid', ['4476093']);
		
		        htlbid.setTargeting('is_home', 'no');
		
        if (sectionMeta) {
            htlbid.setTargeting('section', sectionMeta.content);
            console.log('[TARGETING]', googletag.pubads().getTargeting('section'));
        }

        htlbid.setTargeting('category', cat_array);
        htlbid.setTargeting('tag', tag_array);

		        htlbid.setTargeting('ksg', Krux.segments);
        htlbid.setTargeting('kuid', Krux.user);
    });
</script>


    </head>

<body class="post-template-default single single-post postid-4476093 single-format-standard wp-custom-logo single-post-skin default-content-layout align-content-left">
    <!-- Google Tag Manager (noscript) -->
    <noscript>
        <iframe src="https://www.googletagmanager.com/ns.html?id=GTM-NMNZ3NH"
                height="0" width="0" style="display:none;visibility:hidden"></iframe>
    </noscript>

<div class="htlad-Embedded_Catfisher"></div>
<div class="htlad-Embedded_Interstitial"></div>


<div id="page" class="site">
    <a class="skip-link screen-reader-text" href="#content">Skip to content</a>

    <div class="header-layout-2">

                    <div class="top-masthead">
                <div class="container">
                    <div class="row">
                                                    <div class="col-xs-12 col-sm-12 col-md-4 pull-right">
                                <div class="social-navigation"><ul id="social-menu" class="menu"><li id="menu-item-4475720" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-4475720"><a target="_blank" rel="noopener" href="https://www.facebook.com/embeddedcom"><span class="screen-reader-text">Facebook</span></a></li>
<li id="menu-item-4475721" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-4475721"><a target="_blank" rel="noopener" href="https://twitter.com/embedded_online"><span class="screen-reader-text">Twitter</span></a></li>
<li id="menu-item-4475722" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-4475722"><a target="_blank" rel="noopener" href="https://www.linkedin.com/company/embedded-com/"><span class="screen-reader-text">Linkedin</span></a></li>
<li id="menu-item-4475723" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-4475723"><a target="_blank" rel="noopener" href="https://www.youtube.com/channel/UCET4UxEwQ2dZfZBSPMEJdhA"><span class="screen-reader-text">Youtube</span></a></li>
<li id="menu-item-4475724" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-4475724"><a target="_blank" rel="noopener" href="https://news.google.com/publications/CAAqBwgKMJONnAswq5e0Aw?ceid=US:en&#038;oc=3"><span class="screen-reader-text">Google News</span></a></li>
<li class ="jan-button"><div class="openid-connect-login-button"><a href="https://login.aspencore.com/d045a02d-767d-4f3f-80d7-695dce25d142/login/authorize?response_type=code&scope=profile%20email%20openid&client_id=216002e0-47e9-4d0c-8915-4dfcbabd2e56&state=bcd9adff62093034fa4cce161aafad24&redirect_uri=https%3A%2F%2Fwww.embedded.com%2Fopenid-connect-authorize">Login/Register</a></div></li></ul></div>                            </div>
                        
                        

                    </div>
                </div>

            </div> <!--    Topbar Ends-->

        
        <header id="masthead" class="site-header">
            
            <div class="masthead-banner " data-background="">
                <div class="container">
                    <div class="row">
                                             <div class="banner-promotions-wrapper">
                    <div class="promotion-section">
                        <div id="block-9" class="widget covernews-widget widget_block"><p><div class='code-block code-block-9' style='margin: 8px 0; clear: both;'>
<!-- Top Billboard -->
<div class='htlad-Embedded_Top_Billboard'></div>
<p class="ad-caption">Advertisement</p></div>
</p>
</div>                    </div>
                </div>
                                    </div>
                </div>
            </div>

            <nav id="site-navigation" class="main-navigation">
                <div class="container">
                    <div class="row">
                        <div class="navigation-container">
                            <div class="site-branding col-md-2 col-sm-2">
                                <a href="https://www.embedded.com/" class="custom-logo-link" rel="home"><img width="208" height="31" src="https://www.embedded.com/wp-content/uploads/2019/10/embedded-white-1.png" class="custom-logo" alt="Embedded.com" /></a>                                    <p class="site-title font-family-1">
                                        <a href="https://www.embedded.com/"
                                           rel="home">Embedded.com</a>
                                    </p>
                                                            </div>
                            <!-- </div> -->
                            <span class="toggle-menu" aria-controls="primary-menu" aria-expanded="false">
                                <span class="screen-reader-text">Primary Menu</span>
                                 <i class="ham"></i>
                            </span>
                            <div class="menu main-menu"><ul id="primary-menu" class="menu"><li id="menu-item-4462429" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children menu-item-4462429"><a href="#">Embedded Focus</a>
<ul class="sub-menu">
	<li id="menu-item-4462430" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children menu-item-4462430"><a href="#">Hardware</a>
	<ul class="sub-menu">
		<li id="menu-item-4462431" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-4462431"><a href="/tag/boards-modules/">Boards &#038; Modules</a></li>
		<li id="menu-item-4462432" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-4462432"><a href="/tag/chips-components/">Chips &#038; Components</a></li>
		<li id="menu-item-4462433" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-4462433"><a href="/tag/components/">Components</a></li>
		<li id="menu-item-4462434" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-4462434"><a href="/tag/connectivity/">Connectivity</a></li>
		<li id="menu-item-4462435" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-4462435"><a href="/tag/coprocessors/">Coprocessors</a></li>
		<li id="menu-item-4462436" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-4462436"><a href="/tag/displays/">Displays</a></li>
		<li id="menu-item-4462437" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-4462437"><a href="/tag/electromechanical/">Electromechanical</a></li>
		<li id="menu-item-4462438" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-4462438"><a href="/tag/memory-storage/">Memory / Storage</a></li>
		<li id="menu-item-4462439" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-4462439"><a href="/tag/motors/">Motors</a></li>
		<li id="menu-item-4462440" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-4462440"><a href="/tag/optoelectronics/">Optoelectronics</a></li>
		<li id="menu-item-4462441" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-4462441"><a href="/tag/sensors/">Sensors</a></li>
	</ul>
</li>
	<li id="menu-item-4462446" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children menu-item-4462446"><a href="#">Software</a>
	<ul class="sub-menu">
		<li id="menu-item-4462447" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-4462447"><a href="/tag/eda/">EDA</a></li>
		<li id="menu-item-4462448" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-4462448"><a href="/tag/operating-systems/">Operating Systems</a></li>
		<li id="menu-item-4462450" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-4462450"><a href="/tag/source-code/">Source Code</a></li>
	</ul>
</li>
	<li id="menu-item-4462411" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children menu-item-4462411"><a href="#">Design</a>
	<ul class="sub-menu">
		<li id="menu-item-4462412" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-4462412"><a href="/tag/integration/">Integration</a></li>
		<li id="menu-item-4462413" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-4462413"><a href="/tag/iot/">IoT</a></li>
		<li id="menu-item-4462414" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-4462414"><a href="/tag/performance/">Performance</a></li>
		<li id="menu-item-4462415" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-4462415"><a href="/tag/security/">Security</a></li>
	</ul>
</li>
	<li id="menu-item-4462418" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children menu-item-4462418"><a href="#">Development</a>
	<ul class="sub-menu">
		<li id="menu-item-4462420" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-4462420"><a href="/tag/design-methods/">Design Methods</a></li>
		<li id="menu-item-4462421" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-4462421"><a href="/tag/solutions/">Solutions</a></li>
		<li id="menu-item-4462423" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-4462423"><a href="/tag/manufacturing/">Manufacturing</a></li>
		<li id="menu-item-4462424" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-4462424"><a href="/tag/supply-chain/">Supply Chain</a></li>
		<li id="menu-item-4462425" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-4462425"><a href="/tag/test-measurement/">Test &#038; Measurement</a></li>
		<li id="menu-item-4462427" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-4462427"><a href="/tag/tools/">Tools</a></li>
		<li id="menu-item-4462428" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-4462428"><a href="/tag/tools-software/">Tools &#038; Software</a></li>
	</ul>
</li>
	<li id="menu-item-4462442" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children menu-item-4462442"><a href="#">Industry</a>
	<ul class="sub-menu">
		<li id="menu-item-4462443" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-4462443"><a href="/tag/automotive/">Automotive</a></li>
		<li id="menu-item-4462444" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-4462444"><a href="/tag/Consumer/">Consumer</a></li>
		<li id="menu-item-4462445" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-4462445"><a href="/tag/medical/">Medical</a></li>
	</ul>
</li>
	<li id="menu-item-4462801" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children menu-item-4462801"><a href="#">Trends</a>
	<ul class="sub-menu">
		<li id="menu-item-4462802" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-4462802"><a href="/tag/advanced-technology/">Advanced Technology</a></li>
		<li id="menu-item-4462803" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-4462803"><a href="/tag/applications/">Applications</a></li>
		<li id="menu-item-4462804" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-4462804"><a href="/tag/industry/">Industry</a></li>
		<li id="menu-item-4462805" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-4462805"><a href="/tag/profession/">Profession</a></li>
	</ul>
</li>
	<li id="menu-item-4462970" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-4462970"><a href="/tag/communications/">Communications</a></li>
</ul>
</li>
<li id="menu-item-4462385" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-4462385"><a href="https://www.embedded.com/category/news/">News</a></li>
<li id="menu-item-4475566" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-4475566"><a href="/category/technical-article/">Technical Articles</a></li>
<li id="menu-item-4462455" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-has-children menu-item-4462455"><a href="https://www.embedded.com/about-us/">About us</a>
<ul class="sub-menu">
	<li id="menu-item-4462721" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-4462721"><a href="https://www.embedded.com/contact-us/">Contact Us</a></li>
	<li id="menu-item-4462456" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-4462456"><a href="https://www.embedded.com/editorial-contributions/">Editorial Contributions Guide</a></li>
</ul>
</li>
<li id="menu-item-4469764" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-4469764"><a target="_blank" rel="noopener" href="https://aspencore.dragonforms.com/EmbeddedSubscribe">Subscribe</a></li>
<li class ="jan-button"><div class="openid-connect-login-button"><a href="https://login.aspencore.com/d045a02d-767d-4f3f-80d7-695dce25d142/login/authorize?response_type=code&scope=profile%20email%20openid&client_id=216002e0-47e9-4d0c-8915-4dfcbabd2e56&state=ae0b688d71be37ae57e6924097fa3f3a&redirect_uri=https%3A%2F%2Fwww.embedded.com%2Fopenid-connect-authorize">Login/Register</a></div></li></ul></div>                            <div class="cart-search">

                                <span class="af-search-click icon-search">
                                <i class="fa fa-search"></i>
                            </span>
                            </div>
                        </div>
                    </div>
                </div>
            </nav>
        </header>

        <div id="af-search-wrap">
            <div class="af-search-box table-block">
                <div class="table-block-child v-center text-center">
                    <form role="search" method="get" class="search-form" action="https://www.embedded.com/">
				<label>
					<span class="screen-reader-text">Search for:</span>
					<input type="search" class="search-field" placeholder="Search &hellip;" value="" name="s" />
				</label>
				<input type="submit" class="search-submit" value="Search" />
			</form>                </div>
            </div>
            <div class="af-search-close af-search-click">
                <span></span>
                <span></span>
            </div>
        </div>
    </div>





    <!-- Login Button -->

    <!--
                <div class='loginlinks'>

                    <a href="https://login.aspencore.com/d045a02d-767d-4f3f-80d7-695dce25d142/login/authorize?response_type=code&scope=profile%20email%20openid&client_id=216002e0-47e9-4d0c-8915-4dfcbabd2e56&state=3444e2a33558ef07d635ccb717f04525&redirect_uri=https%3A%2F%2Fwww.embedded.com%2Fopenid-connect-authorize" class='login' style='font-weight: 600;'>Sign in</a>

					or

                    <a href="https://login.aspencore.com/d045a02d-767d-4f3f-80d7-695dce25d142/login/authorize?response_type=code&scope=profile%20email%20openid&client_id=216002e0-47e9-4d0c-8915-4dfcbabd2e56&state=677489c5597a8b3424329388296a723a&redirect_uri=https%3A%2F%2Fwww.embedded.com%2Fopenid-connect-authorize" class='register' style='font-weight: 400;'>Register</a>
                </div>

-->
	

    <div id="content" class="container">

    <!--    <div class="">-->
    <div id="wallpaper_image" class="wallpaper-image">
    <div class="af-skin-content">

    <div class="row">
        <div id="primary" class="content-area">
            <main id="main" class="site-main">

				                    <article id="post-4476093" class="post-4476093 post type-post status-publish format-standard hentry category-blog tag-design-methods tag-tools-software display_tag-posts-slider">
                        <div class="entry-content-wrap">
							<header class="entry-header">

    <div class="header-details-wrapper">
        <div class="entry-header-details">
                            <div class="figure-categories figure-categories-bg">
                                        <ul class="cat-links"><li class="meta-category">
                             <a class="covernews-categories category-color-1" href="https://www.embedded.com/category/blog/" alt="View all posts in Blog"> 
                                 Blog
                             </a>
                        </li></ul>                </div>
                        <h1 class="entry-title">5 embedded software architecture pitfalls</h1>
            
                
        <span class="author-links">
                            <span class="item-metadata posts-date">
                <i class="far fa-clock"></i>
                    August 31, 2022            </span>
            			
                <span class="item-metadata posts-author">

                    	                    <a href="https://www.embedded.com/author/evanczust01/" title="Posts by Jacob Beningo" class="author url fn" rel="author">Jacob Beningo</a>                            </span>
			        </span>
		                

                    </div>
    </div>
        <div class="aft-post-thumbnail-wrapper">    
            </div>
</header><!-- .entry-header -->							

    <div class="entry-content">
        <div class="ads">
	        <div class="htlad-Embedded_Top_Leaderboard"></div>
<p class="ad-caption">Advertisement</p>

        </div>

        <div class='code-block code-block-7' style='margin: 8px auto; text-align: center; display: block; clear: both;'>
<!-- InSkin -->
<div class='htlad-Embedded_Inskin'></div>
</div>
<div style="display:none;">Software architecture is a critical design element that guides developers in building an embedded application successfully. Here are five pitfalls that can get in the way of developing a good software architecture.</div>
<p>Software architecture is the fundamental organization of a system embodied in its components, their relationship to each other and the environment, and the principles guiding its design and evolution [1]. Every embedded system should have a software architecture that guides the developers on what they are building. Unfortunately, it’s not uncommon to run across several pitfalls that get in the way of successful software architecture. In this post, we will explore five embedded software architecture pitfalls and how you can avoid them.</p>
<p><strong>Pitfall #1 – Believing in evolutionary architectures</strong></p>
<p>There is an idea that I’ve seen floating around development teams that there is no need to consider your software architecture before starting to code. Instead, there is a belief that a systems software architecture will miraculously evolve from nothing to a scalable, reusable, high-quality architecture on its own. Unfortunately, the belief seems to stem from a misinterpretation of ideas that came from the Agile movement. So, let’s set the record straight.</p><div class='code-block code-block-1' style='margin: 8px 0; clear: both;'>
<!-- Parallaxer -->
<div class='htlad-Embedded_Parallaxer'></div></div>

<p>Software architecture is a road map, a blueprint, that tells coders how their code fits into the larger puzzle. A software architecture identifies the major components, their inputs, outputs, and interactions with each other. A characteristic of well-designed software architecture is that it is evolvable to meet the customer&#8217;s changing needs. However, in my experience, I’ve found that the most successful teams spend some time upfront working through their software architecture.</p>
<p>Spending some time upfront to figure out the pieces of the software architecture still fits with teams working within Agile methodologies. The architecture doesn’t need to be developed in a waterfall manner but can be designed and honed over several iterations as details and lessons are learned. A software architecture developed in this manner is generally more flexible and will be far more successful than a team hoping for architecture just to appear. Unfortunately, the only architecture that will appear for those teams is a big ball of mud. (Or, if you’re hungry, a big ball of spaghetti.)</p><div class='code-block code-block-8' style='margin: 8px 0; clear: both;'>
<!-- InRead -->
<div class='htlad-Embedded_InRead_Video'></div>
</div>

<p><strong>Pitfall #2 – Not following the data</strong></p>
<p>An excellent principle for designing a software architecture is to follow the data. My first modern embedded software principle is that data dictates design. Data is the real asset that every embedded system is designed to manage. Data comes into a system in various forms to create inputs. Those data inputs are then processed, stored, and/or used to produce outputs from the system.</p>
<p>When you design embedded software, you shouldn’t care what temperature sensor is used, what push button was designed into the system, or even what microcontroller is used. Instead, designers and developers should identify and follow the data assets in their system. So, for example, the architecture should identify the temperature data asset instead of worrying about the temperature sensor vendor. Likewise, in the software architecture, we don’t care about the hardware, just that there is an interface that will serve as the temperature data.</p>
<p>If you follow the data, the software architecture necessary to perform the desired system behaviors on that data will naturally fall into place. Strangely enough, it will create a hardware-independent and more easily tested software architecture. Avoid this pitfall by identifying and following the data through the software system.</p>
<p><strong>Pitfall #3 – Failing to consider response times</strong></p>
<p>Embedded systems often have real-time response requirements associated with them. For example, if a user presses an emergency stop button, the system shall halt within ten milliseconds. Occasionally, I’ve seen software architects get overly excited about creating an elegant, all-encompassing software architecture or attempt to adopt a more modern architecture that destroys real-time performance.</p>
<p>While aiming to create scalable and flexible architecture, software architects also need to consider the implementation impacts of their architectural decisions. At the architect stage, it may not be able to quantify the response times fully. However, high risk areas can be identified and tested as soon as possible.</p>
<p>I often see developers struggle with when creating a task-based architecture. If the architect is less experienced with task-based design patterns, it’s not uncommon to have far more latency in response than expected. Many timing problems stem from interactions between interrupts and periodic tasks. The issue can sometimes be resolved by changing the problem task&#8217;s architecture from time-based to event-driven.</p>
<p><strong>Pitfall #4 – No implementation / architecture feedback loop</strong></p>
<p>When a team puts together its software architecture, I often see teams act like the architecture is gospel and can’t be changed. It’s not uncommon for the developers writing the code to make architectural changes and never feed those changes back to the architects. The pitfall is that there needs to be a feedback loop between the implementation and the architecture.</p>
<p>The architects build their architecture based on what they perceive to be the optimal solution for the application. Unfortunately, the architects often don’t have all the information they need to build the architecture fully. Therefore, it’s up to the coders during implementation to update the architects on their findings, issues, and so forth to determine the best direction for the overall software architecture. If the coders make the changes themselves without feedback from the architects, they may move the system in a direction that is not optimal for the architecture. The result is that the code and the architecture slowly accumulate technical debt that gets in the way of success.</p>
<p><strong>Pitfall #5 – Picking the wrong architecture</strong></p>
<p>Several different types of software architectures can be applied to embedded applications. For example, there are unstructured monoliths, layered monoliths, event-driven, state-driven, and microservice architectures. If an architect chooses the wrong architecture for their system, they may discover that they have issues with scaling the application, issues with response times, or many other potential problems.</p>
<p>Several reasons a developer may select the wrong architecture for the job. First, they may just be interested in trying a new architecture they have never used before. While broadening one’s horizons can be good, designers must be careful to ensure that the architectural type they decide to use solves the problems at hand and doesn’t introduce complexity or other potential issues. For example, microservice architectures have become quite popular, but they can suffer from complexity and response time issues if one is not careful.</p>
<p>When architecting an embedded system, carefully look at the data and the domains in which that data operates to help identify the architectural model that will work best for the application. In some applications, you may discover that mixing architectural types is required to solve the problem.<strong>&nbsp;</strong></p>
<p><strong>Conclusions</strong></p>
<p>Software architecture is a critical design element that guides developers in building an embedded application successfully. Developers can leverage a wide range of software architectures and design patterns to solve common design problems. Before exploring those architectures and design patterns, we’ve first examined five software architecture pitfalls that can get in the way of good architecture. &nbsp;</p>
<p>What additional pitfalls have you seen teams fall into when developing their embedded software architectures?</p>
<p><strong>Reference</strong></p>
<p>[1] <a href="https://en.wikipedia.org/wiki/IEEE_1471" target="_blank" rel="noopener"><span style="color: blue;">https://en.wikipedia.org/wiki/IEEE_1471</span></a>. IEEE 1471 has been superseded by IEEE 42010. (I just like the IEEE 1471 definition).</p>
<hr style="margin: 10px auto; width: 80%; border: 0px none; height: 1px; background-image: linear-gradient(to right, transparent, rgba(0, 0, 0, 0.75), transparent);">
<table style="border: none;" border="0" cellspacing="0" cellpadding="0">
<tbody>
<tr style="border: none;">
<td style="border: none;"><img alt="" style="width: 110px; float: left; margin: 0px 4px 0px 0px;" src="https://www.embedded.com/wp-content/uploads/2022/05/EMB_Jacob_Beningo.jpg"><em><strong>Jacob Beningo</strong> is an embedded software consultant who specializes in real-time, microcontroller-based systems. He actively promotes software best practices through numerous articles, blogs, and webinars on topics from software architecture design, embedded DevOps, and implementation techniques. Jacob has 20 years of experience in the field and holds three degrees including a Masters of Engineering from the University of Michigan.</em></td>
</tr>
</tbody>
</table>
<hr style="margin: 10px auto; width: 80%; border: 0px none; height: 1px; background-image: linear-gradient(to right, transparent, rgba(0, 0, 0, 0.75), transparent);">
<p><strong>Related Contents:</strong></p>
<ul style="list-style-position: outside; padding-left: 20px;">
<li><a href="https://www.embedded.com/the-architecture-of-armv8-based-firmware-systems/" target="_blank" rel="noopener">The architecture of ARMv8-based firmware systems</a></li>
<li><a href="https://www.embedded.com/a-quick-introduction-to-instruction-set-architecture-and-extensibility/" target="_blank" rel="noopener">A quick introduction to instruction set architecture and extensibility</a></li>
<li><a href="https://www.embedded.com/high-performance-embedded-computing-target-architectures/" target="_blank" rel="noopener">High-performance embedded computing &#8211; Target architectures</a></li>
<li><a href="https://www.embedded.com/architectural-considerations-for-enabling-industrial-iot-devices/" target="_blank" rel="noopener">Architectural considerations for enabling industrial IoT devices</a></li>
<li><a href="https://www.embedded.com/soafee-architecture-for-embedded-edge-enables-software-defined-cars/" target="_blank" rel="noopener">SOAFEE architecture for embedded edge enables software defined cars</a></li>
</ul>
<p><em>For more Embedded, <a href="https://aspencore.dragonforms.com/loading.do?omedasite=EmbeddedSubscribe" target="_blank" rel="noopener">subscribe to Embedded&#8217;s weekly email newsletter</a>.</em></p>
<p><!-- newsletter blurb
Software architecture is a critical design element that guides developers in building an embedded application successfully. Here are five pitfalls that can get in the way of developing a good software architecture.  

--></p>
<!-- AI CONTENT END 1 -->
                    
<!--            <div id="div-gpt-ad-native">-->
<!--                <script type="text/javascript">-->
<!--                    googletag.cmd.push(function() { googletag.display('div-gpt-ad-native'); });-->
<!--                </script>-->
<!--            </div>-->
        <div class="carousel-container-single">
	        <div class="htlad-Embedded_Carousel"></div>
<p class="ad-caption">Advertisement</p>
        </div>

            <div class="post-item-metadata entry-meta">
                <span class="tags-links">Tags: <a href="https://www.embedded.com/tag/design-methods/" rel="tag">Design Methods</a>, <a href="https://www.embedded.com/tag/tools-software/" rel="tag">Tools &amp; Software</a></span>            </div>

            

            <!-- <div style="text-align: center">
                <div id='div-gpt-ad-942957474691236830-3'>
                    <script type='text/javascript'>
                        googletag.cmd.push(function() { googletag.display('div-gpt-ad-942957474691236830-3'); });
                    </script>
                </div>
            </div> -->

            <!-- <div class="partial">
                <div id='div-gpt-ad-942957474691236830-42'>
                    <script type='text/javascript'>
                        googletag.cmd.push(function() { googletag.display('div-gpt-ad-942957474691236830-42'); });
                    </script>
                </div>
            </div> -->

                
	<nav class="navigation post-navigation" aria-label="Continue Reading">
		<h2 class="screen-reader-text">Continue Reading</h2>
		<div class="nav-links"><div class="nav-previous"><a href="https://www.embedded.com/programming-embedded-systems-introduction/" rel="prev"><span class="em-post-navigation">Previous</span> Programming embedded systems: Introduction</a></div></div>
	</nav>            </div><!-- .entry-content -->


                        </div>
												
<div id="comments" class="comments-area">

		<div id="respond" class="comment-respond">
		<h3 id="reply-title" class="comment-reply-title">Leave a Reply <small><a rel="nofollow" id="cancel-comment-reply-link" href="/5-embedded-software-architecture-pitfalls/#respond" style="display:none;">Cancel reply</a></small></h3><p class="must-log-in">
			You must <a href="https://login.aspencore.com/d045a02d-767d-4f3f-80d7-695dce25d142/login/authorize?response_type=code&scope=profile%20email%20openid&client_id=216002e0-47e9-4d0c-8915-4dfcbabd2e56&state=337b2b0e7efa1324744cc3c7f80dfaf8&redirect_uri=https%3A%2F%2Fwww.embedded.com%2Fopenid-connect-authorize" class="openid_login">Sign in</a> or
			<a href="https://login.aspencore.com/d045a02d-767d-4f3f-80d7-695dce25d142/login/authorize?response_type=code&scope=profile%20email%20openid&client_id=216002e0-47e9-4d0c-8915-4dfcbabd2e56&state=fc2347ac8ebb06ad69273f3a644b408b&redirect_uri=https%3A%2F%2Fwww.embedded.com%2Fopenid-connect-authorize" class="openid_login">Register</a> to post a comment.</p>	</div><!-- #respond -->
	<p class="akismet_comment_form_privacy_notice">This site uses Akismet to reduce spam. <a href="https://akismet.com/privacy/" target="_blank" rel="nofollow noopener">Learn how your comment data is processed</a>.</p>
</div><!-- #comments -->
                    </article>
				
            </main><!-- #main -->
        </div><!-- #primary -->
				
<aside id="secondary" class="widget-area aft-sticky-sidebar">
    <div class="widget covernews-widget widget_block partner-content-widget">
        <iframe src="https://api.aspencore.com/syndication/v3/partnered-content/" width="300" scrolling="no" frameborder="0"></iframe>
    </div>

    <div class="widget covernews-widget widget_block">
        <div class="ads">
	        <div class="htlad-Embedded_Medium_Rectangle"></div>
<p class="ad-caption">Advertisement</p>
        </div>
    </div>

    <div class="widget covernews-widget widget_block">
        <div class="ads">
	        <div class='htlad-Embedded_Native'></div>
<p class="ad-caption">Advertisement</p>

        </div>
    </div>
	
    <div class="widget widget_ds_widget">            <style>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</style>
			        <div class="ds-widget" data-lang="en">
            <img class="mg" src="https://www.embedded.com/wp-content/plugins/ds-widget/img/back1.png">
            <div class="" id="search-box-home">
                <div class="">
                    <div class="row">
                        <div class="col text-right">
                            <a target="_blank" href="https://www.datasheets.com/en?utm_source=embedded.com&#038;utm_medium=DS_Widget">
                                <img loading="lazy"
                                     src="https://www.embedded.com/wp-content/plugins/ds-widget/img/logo.png"
                                     class="img-fluid logo" alt="datasheets.com logo">
                            </a>
                        </div>
                    </div>

                    <div class="row justify-content-center">
                        <div class="col">
                            <div class="search-container">
                                <div class="form-group position-relative">
                                    <h1 class="h2 text-white header-text text-uppercase">
                                        <span>Looking for</span><br>DataSheets                                        ?</h1>
                                    <input type="text" name="keyword" id="keyword" class="form-control my-0 py-1"
                                           placeholder="Enter Part Number" value=""
                                           aria-label="Search"
                                           autocomplete="off" required="">
                                    <div class="input-group-append">
                                        <button aria-label="Submit" id="dsWidgetFetch" class="input-group-text"
                                                type="submit">
                                            <img src="https://www.embedded.com/wp-content/plugins/ds-widget/img/search-solid.svg"
                                                 class="search-icon" width="24" height="24" alt="search icon">
                                        </button>
                                    </div>
                                </div>
                            </div>
                        </div>
                    </div>
                    <div class="row results">
                        <div id='loader' class="text-center m-3" style='display: none;'>
                            <img src="https://www.embedded.com/wp-content/plugins/ds-widget/img/loader.svg"
                                 width='40px'
                                 height='40px' alt="loader">
                        </div>
                        <div id="datafetch" class="col"></div>
                    </div>
                </div>
            </div>
        </div>

        <script>
            jQuery(document).ready(function ($) {
                jQuery('body').on('click', '#dsWidgetFetch', function (e) {
                    e.preventDefault();
                    console.log("xxx");
                    dsWidgetFetch();
                })
            });
        </script>

		</div>
    <div class="widget covernews-widget widget_block">
        <div class="ads">
	        <div class='htlad-Embedded_Filmstrip'></div>
<p class="ad-caption">Advertisement</p>
        </div>
    </div>

</aside><!-- #secondary -->
    </div>


    <!-- GPT AdSlot 1 for Ad unit 'emd' ### Size: [[3,3]] -->
    <!-- <div id='div-gpt-ad-3195781-1'>
        <script>
            googletag.cmd.push(function() { googletag.display('div-gpt-ad-3195781-1'); });
        </script>
    </div> -->
    <!-- End AdSlot 1 -->

    </div></div>
    <!--    </div>-->



</div>


<div class="af-main-banner-latest-posts grid-layout">
    <div class="container">
        <div class="row">

    <div class="widget-title-section">
                    <h4 class="widget-title header-after1">
                        <span class="header-after">

                            You may have missed                            </span>
            </h4>
        
    </div>
    <div class="row">
                <div class="col-sm-15 latest-posts-grid" data-mh="latest-posts-grid">
                <div class="spotlight-post">
                    <figure class="categorised-article inside-img">
                        <div class="categorised-article-wrapper">
                            <div class="data-bg data-bg-hover data-bg-categorised"
                                 data-background="https://www.embedded.com/wp-content/uploads/2022/08/Intel-Pathfinder-image_c.jpeg?w=675&#038;h=415&#038;crop=1">
                                <a href="https://www.embedded.com/intel-puts-more-weight-behind-risc-v-with-pathfinder-platform-and-ecosystem/"></a>
                            </div>
                        </div>
                                                <div class="figure-categories figure-categories-bg">
                            
                            <ul class="cat-links"><li class="meta-category">
                             <a class="covernews-categories category-color-1" href="https://www.embedded.com/category/news/" alt="View all posts in News"> 
                                 News
                             </a>
                        </li></ul>                        </div>
                    </figure>

                    <figcaption>
                        
                        <h3 class="article-title article-title-1">
                            <a href="https://www.embedded.com/intel-puts-more-weight-behind-risc-v-with-pathfinder-platform-and-ecosystem/">
                                Intel puts more weight behind RISC-V with Pathfinder platform                            </a>
                        </h3>
                        <div class="grid-item-metadata">
                            
        <span class="author-links">
                            <span class="item-metadata posts-date">
                <i class="far fa-clock"></i>
                    August 31, 2022            </span>
            			
                <span class="item-metadata posts-author">

                    	                    <a href="https://www.embedded.com/author/nitin-dahad/" title="Posts by Nitin Dahad" class="author url fn" rel="author">Nitin Dahad</a>                            </span>
			        </span>
		                        </div>
                    </figcaption>
                </div>
            </div>
                    <div class="col-sm-15 latest-posts-grid" data-mh="latest-posts-grid">
                <div class="spotlight-post">
                    <figure class="categorised-article inside-img">
                        <div class="categorised-article-wrapper">
                            <div class="data-bg data-bg-hover data-bg-categorised"
                                 data-background="https://www.embedded.com/wp-content/uploads/2022/08/Caryatids-Greece.jpeg?w=675&#038;h=450&#038;crop=1">
                                <a href="https://www.embedded.com/5-embedded-software-architecture-pitfalls/"></a>
                            </div>
                        </div>
                                                <div class="figure-categories figure-categories-bg">
                            
                            <ul class="cat-links"><li class="meta-category">
                             <a class="covernews-categories category-color-1" href="https://www.embedded.com/category/blog/" alt="View all posts in Blog"> 
                                 Blog
                             </a>
                        </li></ul>                        </div>
                    </figure>

                    <figcaption>
                        
                        <h3 class="article-title article-title-1">
                            <a href="https://www.embedded.com/5-embedded-software-architecture-pitfalls/">
                                5 embedded software architecture pitfalls                            </a>
                        </h3>
                        <div class="grid-item-metadata">
                            
        <span class="author-links">
                            <span class="item-metadata posts-date">
                <i class="far fa-clock"></i>
                    August 31, 2022            </span>
            			
                <span class="item-metadata posts-author">

                    	                    <a href="https://www.embedded.com/author/evanczust01/" title="Posts by Jacob Beningo" class="author url fn" rel="author">Jacob Beningo</a>                            </span>
			        </span>
		                        </div>
                    </figcaption>
                </div>
            </div>
                    <div class="col-sm-15 latest-posts-grid" data-mh="latest-posts-grid">
                <div class="spotlight-post">
                    <figure class="categorised-article inside-img">
                        <div class="categorised-article-wrapper">
                            <div class="data-bg data-bg-hover data-bg-categorised"
                                 data-background="https://www.embedded.com/wp-content/uploads/2022/08/08adi_bh-fig-01-1.jpg?w=675&#038;h=450&#038;crop=1">
                                <a href="https://www.embedded.com/accelerating-peripheral-monitoring-in-wearables-with-dma/"></a>
                            </div>
                        </div>
                                                <div class="figure-categories figure-categories-bg">
                            
                            <ul class="cat-links"><li class="meta-category">
                             <a class="covernews-categories category-color-1" href="https://www.embedded.com/category/technical-article/" alt="View all posts in Technical Article"> 
                                 Technical Article
                             </a>
                        </li></ul>                        </div>
                    </figure>

                    <figcaption>
                        
                        <h3 class="article-title article-title-1">
                            <a href="https://www.embedded.com/accelerating-peripheral-monitoring-in-wearables-with-dma/">
                                Accelerating peripheral monitoring in wearables with DMA                            </a>
                        </h3>
                        <div class="grid-item-metadata">
                            
        <span class="author-links">
                            <span class="item-metadata posts-date">
                <i class="far fa-clock"></i>
                    August 29, 2022            </span>
            			
                <span class="item-metadata posts-author">

                    	                    <a href="https://www.embedded.com/author/evanczust01/" title="Posts by Brandon Hurst" class="author url fn" rel="author">Brandon Hurst</a>                            </span>
			        </span>
		                        </div>
                    </figcaption>
                </div>
            </div>
                    <div class="col-sm-15 latest-posts-grid" data-mh="latest-posts-grid">
                <div class="spotlight-post">
                    <figure class="categorised-article inside-img">
                        <div class="categorised-article-wrapper">
                            <div class="data-bg data-bg-hover data-bg-categorised"
                                 data-background="https://www.embedded.com/wp-content/uploads/2022/08/programming_thumbnail.jpg?w=675&#038;h=450&#038;crop=1">
                                <a href="https://www.embedded.com/programming-embedded-systems-introduction/"></a>
                            </div>
                        </div>
                                                <div class="figure-categories figure-categories-bg">
                            
                            <ul class="cat-links"><li class="meta-category">
                             <a class="covernews-categories category-color-1" href="https://www.embedded.com/category/blog/" alt="View all posts in Blog"> 
                                 Blog
                             </a>
                        </li></ul>                        </div>
                    </figure>

                    <figcaption>
                        
                        <h3 class="article-title article-title-1">
                            <a href="https://www.embedded.com/programming-embedded-systems-introduction/">
                                Programming embedded systems: Introduction                            </a>
                        </h3>
                        <div class="grid-item-metadata">
                            
        <span class="author-links">
                            <span class="item-metadata posts-date">
                <i class="far fa-clock"></i>
                    August 29, 2022            </span>
            			
                <span class="item-metadata posts-author">

                    	                    <a href="https://www.embedded.com/author/evanczust01/" title="Posts by Miro Samek" class="author url fn" rel="author">Miro Samek</a>                            </span>
			        </span>
		                        </div>
                    </figcaption>
                </div>
            </div>
                    <div class="col-sm-15 latest-posts-grid" data-mh="latest-posts-grid">
                <div class="spotlight-post">
                    <figure class="categorised-article inside-img">
                        <div class="categorised-article-wrapper">
                            <div class="data-bg data-bg-hover data-bg-categorised"
                                 data-background="https://www.embedded.com/wp-content/uploads/2022/08/trinamix_istock-1249306758.jpg?w=675&#038;h=450&#038;crop=1">
                                <a href="https://www.embedded.com/embedded-news-hot-chips-face-authentication-at-ifa-and-more/"></a>
                            </div>
                        </div>
                                                <div class="figure-categories figure-categories-bg">
                            
                            <ul class="cat-links"><li class="meta-category">
                             <a class="covernews-categories category-color-1" href="https://www.embedded.com/category/news/" alt="View all posts in News"> 
                                 News
                             </a>
                        </li></ul>                        </div>
                    </figure>

                    <figcaption>
                        
                        <h3 class="article-title article-title-1">
                            <a href="https://www.embedded.com/embedded-news-hot-chips-face-authentication-at-ifa-and-more/">
                                embedded news: Hot Chips, face authentication at IFA, and more                            </a>
                        </h3>
                        <div class="grid-item-metadata">
                            
        <span class="author-links">
                            <span class="item-metadata posts-date">
                <i class="far fa-clock"></i>
                    August 26, 2022            </span>
            			
                <span class="item-metadata posts-author">

                    	                    <a href="https://www.embedded.com/author/nitin-dahad/" title="Posts by Nitin Dahad" class="author url fn" rel="author">Nitin Dahad</a>                            </span>
			        </span>
		                        </div>
                    </figcaption>
                </div>
            </div>
                </div>
    </div>
    </div>
</div>

<footer class="site-footer">
    
    <div class="primary-footer">
        

        <div class="container layout-footer">
            <!--                <div class="row">-->
            <!--                    <div class="col-sm-12">-->

            <div class="footerBlock-title">Aspencore Network</div>
            <div class="aspencoreNetwork-column segment-one">
                <!--PRODUCTS-->
                <div class="footerBlock-subtitle">Products:</div>
                <ul class="footerBlock-list">
                    <li class="footerBlock-item">
                        <a target="_blank" href="https://www.electronicproducts.com/"
                           class="footerblock-link">Electronic Products</a>
                    </li>
                    <li class="footerBlock-item">
                        <a target="_blank" href="https://www.datasheets.com/" class="footerblock-link">Datasheets.com</a>
                    </li>
                    <li class="footerBlock-item">
                        <a target="_blank" href="https://www.techonline.com/" class="footerblock-link">TechOnline</a>
                    </li>
                </ul>
            </div><!--end .aspencoreNetwork-column segment-one-->


            <!--NEWS & ANALYSIS-->
            <div class="aspencoreNetwork-column segment-two">
                <div class="footerBlock-subtitle">News &amp; Analysis:</div>
                <ul class="footerBlock-list">
                    <li class="footerBlock-item">
                        <a target="_blank" href="https://www.eetimes.com/" class="footerblock-link">EE
                            Times</a>
                    </li>
                    <li class="footerBlock-item">
                        <a target="_blank" href="https://www.eetimes.eu/" class="footerblock-link">EE Times
                            Europe</a>
                    </li>
                    <li class="footerBlock-item">
                        <a target="_blank" href="https://www.powerelectronicsnews.com/"
                           class="footerblock-link">Power Electronics News</a>
                    </li>
                    <li class="footerBlock-item">
    										<a target="_blank" href="https://epsnews.com/" class="footerblock-link">EPSNews</a>
    								</li>
                    <li class="footerBlock-item">
                        <a target="_blank" href="https://www.elektroda.pl/" class="footerblock-link">Elektroda.pl</a>
                    </li>
  									<li class="footerBlock-item">
  	                    <a target="_blank" href="https://thechannelist.com/" class="footerblock-link">The Channelist</a>
  	                </li>
                </ul>
            </div><!--end .aspencoreNetwork-column segment-two-->


            <!--DESIGN-->
            <div class="aspencoreNetwork-column segment-three">
                <div class="footerBlock-subtitle">Design:</div>
                <ul class="footerBlock-list">
                    <li class="footerBlock-item">
                        <a target="_blank" href="https://www.edn.com/" class="footerblock-link">EDN</a>
                    </li>
                    <li class="footerBlock-item">
                        <a target="_blank" href="https://www.electroschematics.com/"
                           class="footerblock-link">Electroschematics</a>
                    </li>
                    <li class="footerBlock-item">
                        <a target="_blank" href="https://www.electronics-tutorials.ws/"
                           class="footerblock-link">Electronics-Tutorials</a>
                    </li>
                    <li class="footerBlock-item">
                        <a target="_blank" href="https://www.planetanalog.com/" class="footerblock-link">Planet
                            Analog</a>
                    </li>
                    <li class="footerBlock-item">
                        <a target="_blank" href="https://embedded.com/" class="footerblock-link">Embedded</a>
                    </li>
                    <li class="footerBlock-item">
                        <a target="_blank" href="http://electronics-know-how.com/" class="footerblock-link">Electronics
                            Know How</a>
                    </li>
                    <li class="footerBlock-item">
                        <a target="_blank" href="http://iot-design-zone.com" class="footerblock-link">IOT Design Zone</a>
                    </li>
                </ul>
            </div><!--end .aspencoreNetwork-column segment-three-->


            <!--TOOLS-->
            <div class="aspencoreNetwork-column segment-four">
                <div class="footerBlock-subtitle">Tools:</div>
                <ul class="footerBlock-list">
                    <li class="footerBlock-item">
                        <a target="_blank" href="https://www.eeweb.com/" class="footerblock-link">EEWEB</a>
                    </li>
                    <li class="footerBlock-item">
                        <a target="_blank" href="https://www.partsim.com/"
                           class="footerblock-link">PartSim</a>
                    </li>
                    <li class="footerBlock-item">
                        <a target="_blank" href="https://www.transim.com/iot/" class="footerblock-link">Product
                            Advisor</a>
                    </li>
                    <li class="footerBlock-item">
                        <a target="_blank" href="https://schematics.com/" class="footerblock-link">Schematics.com</a>
                    </li>
                    <li class="footerBlock-item">
                        <a target="_blank" href="https://www.schematics.io/" class="footerblock-link">Schematics.io</a>
                    </li>
                    <li class="footerBlock-item">
                        <a target="_blank" href="https://www.transim.com/Products/Engage"
                           class="footerblock-link">Engage</a>
                    </li>
                </ul>
            </div><!--end .aspencoreNetwork-column segment-four-->


            <!--GLOBAL NETWORK-->
            <div class="globalNetwork segment-five">
                <div class="footerBlock-title">Global Network</div>
                <ul class="footerBlock-list">
                    <li class="footerBlock-item">
                        <a target="_blank" href="https://www.eetasia.com/" class="footerblock-link">EE Times
                            Asia</a>
                    </li>
                    <li class="footerBlock-item">
                        <a target="_blank" href="https://www.eet-china.com/" class="footerblock-link">EE
                            Times China</a>
                    </li>
                    <li class="footerBlock-item">
                        <a target="_blank" href="https://www.eetindia.co.in/" class="footerblock-link">EE
                            Times India</a>
                    </li>
                    <li class="footerBlock-item">
                        <a target="_blank" href="https://www.eettaiwan.com/" class="footerblock-link">EE
                            Times Taiwan</a>
                    </li>
                    <li class="footerBlock-item">
                        <a target="_blank" href="https://eetimes.jp/" class="footerblock-link">EE Times
                            Japan </a>
                    </li>
                    <li class="footerBlock-item">
                        <a target="_blank" href="https://www.ednasia.com/" class="footerblock-link">EDN
                            Asia</a>
                    </li>
                    <li class="footerBlock-item">
                        <a target="_blank" href="https://www.edntaiwan.com/" class="footerblock-link">EDN
                            Taiwan</a>
                    </li>
                    <li class="footerBlock-item">
                        <a target="_blank" href="https://www.esmchina.com/" class="footerblock-link">ESM
                            China</a>
                    </li>
                    <li class="footerBlock-item">
                        <a target="_blank" href="https://www.ednchina.com/" class="footerblock-link">EDN
                            China</a>
                    </li>
                    <li class="footerBlock-item">
                        <a target="_blank" href="https://ednjapan.com/" class="footerblock-link">EDN
                            Japan</a>
                    </li>
                </ul>
            </div><!--end .globalNetwork segment-five-->


            <!--FOR ADVERTISERS-->
            <div class="forAdvertisers segment-six">
                <div class="footerBlock-title">For Advertisers</div>
                <ul class="footerBlock-list">
                    <li class="footerBlock-item">
                        <a target="_blank" href="https://aspencore.com/contact"
                           class="footerblock-link">Contact Sales</a>
                    </li>
                    <li class="footerBlock-item">
                        <a target="_blank" href="https://aspencore.com/media-guide-request/"
                           class="footerblock-link">Media Guide Request</a>
                    </li>
                </ul>
            </div><!--end .forAdvertisers segment-six-->


            <!--CONNECT WITH US-->
            <div class="connectWithUs segment-seven">
                <div class="footerBlock-title">Connect with us</div>
                <ul class="footerBlock-list">


                    <!--FACEBOOK-->
                    <li class="footerBlock-item">
                      <div class="SocialIconFooterB">
                       <img src="/wp-content/themes/embedded/img/social/facebook-icon.png" alt="Facebook">
                      </div><!--end .SocialIconFooter-->

                    <a target="_blank" href="https://www.facebook.com/embeddedcom" class="footerblock-link"> Facebook</a>
                    </li>

                    <!--TWITTER-->
                    <li class="footerBlock-item">
                        <div class="SocialIconFooterB">
                            <img src="/wp-content/themes/embedded/img/social/twitter-icon.png" alt="Twitter">
                        </div><!--end .SocialIconFooter-->

                        <a target="_blank" href="https://twitter.com/embedded_online" class="footerblock-link"> Twitter</a>
                    </li>
                    <!--LINKEDIN-->
                    <li class="footerBlock-item">
                        <div class="SocialIconFooterB">
                            <img src="/wp-content/themes/embedded/img/social/linkedin-icon.png" alt="Linkedin">
                        </div><!-- end .SocialIconFooter-->

                        <a target="_blank" href="https://www.linkedin.com/company/embedded-com/" class="footerblock-link"> LinkedIn</a>
                    </li>

                    <!--YOUTUBE-->
                    <li class="footerBlock-item">
                        <div class="SocialIconFooterB">
                            <img src="/wp-content/themes/embedded/img/social/youtube-icons.png" alt="Youtube">
                        </div>

                        <a target="_blank" href="https://www.youtube.com/channel/UCET4UxEwQ2dZfZBSPMEJdhA" class="footerblock-link"> Youtube</a>
                    </li>

                    <!--GOOGLE NEWS-->
                    <li class="footerBlock-item">
                        <div class="SocialIconFooterB">
                            <img src="/wp-content/themes/embedded/img/social/google-icon.png" alt="Google News">
                        </div>

                        <a target="_blank" href="https://news.google.com/publications/CAAqBwgKMJONnAswq5e0Aw?ceid=US:en&oc=3" class="footerblock-link"> Google News</a>
                    </li>

                </ul><!--end ul.footerBlock-list-->
            </div><!--end .connectWithUs segment-seven-->


            <!--ASPENCORE LOGO-->
            <a href="http://www.aspencore.com/">
                <div class="aspencoreLogo">
                    <svg class="aspencoreLogo-svg" xmlns="http://www.w3.org/2000/svg" viewBox="0 0 282 28">
                        <path d="M203.92 2.36l.19-.1zM52 6.66a6 6 0 0 0-1.11-.91 11.11 11.11 0 0 0-1.7-.91 12.66 12.66 0 0 0-2.16-.7 11.76 11.76 0 0 0-2.51-.27 6.17 6.17 0 0 0-3.82 1 3.36 3.36 0 0 0-1 1.25 3.29 3.29 0 0 0-.31 1.58 2.88 2.88 0 0 0 .42 1.64 3.39 3.39 0 0 0 1.25 1.1 10 10 0 0 0 2.1.85c.83.25 1.82.52 2.93.8 1.32.36 2.54.73 3.64 1.12a10.38 10.38 0 0 1 2.83 1.45 6 6 0 0 1 1.82 2.15 6.94 6.94 0 0 1 .7 3.19 7.83 7.83 0 0 1-.8 3.69 7 7 0 0 1-2.16 2.45A9.44 9.44 0 0 1 49 27.53a15.33 15.33 0 0 1-3.82.42 18.87 18.87 0 0 1-6-.95 16.66 16.66 0 0 1-5.23-2.77l2-3.71a9 9 0 0 0 1.41 1.12 12.37 12.37 0 0 0 2.16 1.14 17.76 17.76 0 0 0 2.73.89 12.46 12.46 0 0 0 3.1.37 6.78 6.78 0 0 0 3.8-.91 2.93 2.93 0 0 0 1-1.14 3 3 0 0 0 .33-1.51 2.9 2.9 0 0 0-.5-1.74 4.12 4.12 0 0 0-1.43-1.23 12.4 12.4 0 0 0-2.34-.93c-.91-.28-2-.57-3.13-.87a31 31 0 0 1-3.53-1.15A8.7 8.7 0 0 1 37 13.11a5.66 5.66 0 0 1-1.5-2 6.57 6.57 0 0 1-.5-2.76 8.29 8.29 0 0 1 .74-3.57 7.56 7.56 0 0 1 2.06-2.63A9.27 9.27 0 0 1 40.92.54 13.22 13.22 0 0 1 44.77 0a14.34 14.34 0 0 1 5.14.89A16.7 16.7 0 0 1 54 3.09zm15.78 21V.19h11.43a7.47 7.47 0 0 1 3.38.81 8.64 8.64 0 0 1 2.65 2A9.8 9.8 0 0 1 87 5.86a8.73 8.73 0 0 1 .63 3.27 9.62 9.62 0 0 1-2.23 6.22 8 8 0 0 1-2.59 2 7.2 7.2 0 0 1-3.34.76H72.1v9.57zm4.28-13.4h7.07a3.48 3.48 0 0 0 1.67-.39 3.81 3.81 0 0 0 1.28-1.08 5.26 5.26 0 0 0 .92-1.6 6.75 6.75 0 0 0 .31-2 6 6 0 0 0-.35-2.09 5 5 0 0 0-1-1.61 4.45 4.45 0 0 0-1.4-1A3.8 3.8 0 0 0 79 4h-6.9zm45.7 9.58v3.82H99.19V.19h18.26V4h-14v7.84h12.11v3.6h-12.09v8.42zM134.3 8.32v19.37H130V.19h3.35L148.88 20V.23h4.32v27.46h-3.55zm30.23 5.46a14.37 14.37 0 0 1 .88-4.94A14 14 0 0 1 168 4.43a12.71 12.71 0 0 1 4-3.16 12.07 12.07 0 0 1 5.44-1.2 11.38 11.38 0 0 1 6.25 1.67 10.54 10.54 0 0 1 3.92 4.34l-3.35 2.28a7 7 0 0 0-3.08-3.45 6.88 6.88 0 0 0-1.93-.71 9.1 9.1 0 0 0-1.92-.2 7.33 7.33 0 0 0-3.64.84 8.19 8.19 0 0 0-2.69 2.3 10.3 10.3 0 0 0-1.61 3.21 12.35 12.35 0 0 0-.53 3.57 11.45 11.45 0 0 0 .63 3.81 10.54 10.54 0 0 0 1.8 3.27 9.13 9.13 0 0 0 2.71 2.18 7.36 7.36 0 0 0 3.44.85 8.44 8.44 0 0 0 2-.26 6.89 6.89 0 0 0 2-.81 8.15 8.15 0 0 0 1.74-1.41 7.33 7.33 0 0 0 1.34-2.05l3.55 2.05a8.39 8.39 0 0 1-1.81 2.74 11.37 11.37 0 0 1-2.62 2A13.15 13.15 0 0 1 177.3 28a10.93 10.93 0 0 1-5.16-1.23 13.87 13.87 0 0 1-4-3.24 15.13 15.13 0 0 1-3.57-9.7zm67.84 13.91V.19h11.81a7.47 7.47 0 0 1 3.38.77 8.8 8.8 0 0 1 2.66 2 9.77 9.77 0 0 1 1.78 2.9 8.94 8.94 0 0 1 .64 3.27 9.32 9.32 0 0 1-1.44 5 7.5 7.5 0 0 1-1.67 1.88 7 7 0 0 1-2.18 1.18l6.43 10.46h-4.85l-6-9.57h-6.28v9.57zm4.28-13.4h7.49a3.41 3.41 0 0 0 1.68-.42 4 4 0 0 0 1.25-1.13 5.54 5.54 0 0 0 .84-1.64 6.06 6.06 0 0 0 .3-2 5.13 5.13 0 0 0-.36-2 5.67 5.67 0 0 0-.95-1.63 4.6 4.6 0 0 0-1.38-1.1A3.4 3.4 0 0 0 243.9 4h-7.25zM282 23.87v3.82h-18.61V.19h18.26V4h-14v7.84h12.11v3.6h-12.09v8.42zM14.44.2h-3.51L0 27.69h4.58l8.1-20.88 8.1 20.88h4.55zM209.61 0a13.66 13.66 0 0 0-7.67 2.36 14 14 0 0 0-5.09 6.28 14.16 14.16 0 0 0-.78 8.09 14 14 0 0 0 3.78 7.17 13.72 13.72 0 0 0 21.25-2.12 14.14 14.14 0 0 0-1.72-17.68 13.7 13.7 0 0 0-9.77-4.1zm0 24a9.82 9.82 0 0 1-5.49-1.69 9.92 9.92 0 0 1-3.64-4.5 10.11 10.11 0 0 1 2.14-10.93 9.92 9.92 0 0 1 5.07-2.74 9.79 9.79 0 0 1 5.71.57 9.89 9.89 0 0 1 4.44 3.7 10.09 10.09 0 0 1 .91 9.4 9.89 9.89 0 0 1-5.35 5.43 9.86 9.86 0 0 1-3.79.76z"></path>
                    </svg>
                </div><!--end .aspencoreLogo-->
            </a>
        </div><!--end .container layout-footer-->


        <!--            </div>-->
        <!--        </div>-->
        <!--        </div>-->


    </div>

    

    <div class="site-info">
        <div class="container">
            <div class="legalFooter">
                <div class="legalFooter-copyright">
                                                                Copyright &copy; All rights reserved.                    
                                                                <span class="sep"> | </span>
                        <a href="https://www.embedded.com/">Embedded</a> by AspenCore.                                    </div>
                <div class="legalFooter-links">
                                            <!--                        <div class="--><!--">-->
                        <!--                            <div class="footer-nav-wrapper">-->
                        <div class="footer-navigation"><ul id="footer-menu" class="menu"><li id="menu-item-4462716" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-4462716"><a target="_blank" rel="noopener" href="https://aspencore.com/privacy-policy/">Privacy Policy</a></li>
<li id="menu-item-4462717" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-4462717"><a target="_blank" rel="noopener" href="https://aspencore.com/terms-of-use/">Terms of Use</a></li>
<li id="menu-item-4462720" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-4462720"><a href="https://www.embedded.com/contact-us/">Contact Us</a></li>
<li id="menu-item-4466570" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-4466570"><a href="https://aspencore.dragonforms.com/loading.do?omedasite=dns">California Do Not Sell</a></li>
<li class ="jan-button"><div class="openid-connect-login-button"><a href="https://login.aspencore.com/d045a02d-767d-4f3f-80d7-695dce25d142/login/authorize?response_type=code&scope=profile%20email%20openid&client_id=216002e0-47e9-4d0c-8915-4dfcbabd2e56&state=2e9926ae76aac83c1a2cad592141d18d&redirect_uri=https%3A%2F%2Fwww.embedded.com%2Fopenid-connect-authorize">Login/Register</a></div></li></ul></div>                        <!--                            </div>-->
                        <!--                        </div>-->
                                    </div>
            </div>
        </div>
    </div>
</footer>
</div>
<a id="scroll-up" class="secondary-color">
    <i class="fa fa-angle-up"></i>
</a>
<!--googleoff: all--><div id="cookie-law-info-bar" data-nosnippet="true"><span><div class="cli-bar-container cli-style-v2"><div class="cli-bar-message">We use cookies on our website to give you the most relevant experience by remembering your preferences and repeat visits. By clicking “Accept All”, you consent to the use of ALL the cookies. However, you may visit "Cookie Settings" to provide a controlled consent.</div><div class="cli-bar-btn_container"><a role='button' class="medium cli-plugin-button cli-plugin-main-button cli_settings_button" style="margin:0px 5px 0px 0px">Cookie Settings</a><a id="wt-cli-accept-all-btn" role='button' data-cli_action="accept_all" class="wt-cli-element medium cli-plugin-button wt-cli-accept-all-btn cookie_action_close_header cli_action_button">Accept All</a></div></div></span></div><div id="cookie-law-info-again" data-nosnippet="true"><span id="cookie_hdr_showagain">Manage consent</span></div><div class="cli-modal" data-nosnippet="true" id="cliSettingsPopup" tabindex="-1" role="dialog" aria-labelledby="cliSettingsPopup" aria-hidden="true">
  <div class="cli-modal-dialog" role="document">
	<div class="cli-modal-content cli-bar-popup">
		  <button type="button" class="cli-modal-close" id="cliModalClose">
			<svg class="" viewBox="0 0 24 24"><path d="M19 6.41l-1.41-1.41-5.59 5.59-5.59-5.59-1.41 1.41 5.59 5.59-5.59 5.59 1.41 1.41 5.59-5.59 5.59 5.59 1.41-1.41-5.59-5.59z"></path><path d="M0 0h24v24h-24z" fill="none"></path></svg>
			<span class="wt-cli-sr-only">Close</span>
		  </button>
		  <div class="cli-modal-body">
			<div class="cli-container-fluid cli-tab-container">
	<div class="cli-row">
		<div class="cli-col-12 cli-align-items-stretch cli-px-0">
			<div class="cli-privacy-overview">
				<h4>Privacy Overview</h4>				<div class="cli-privacy-content">
					<div class="cli-privacy-content-text">This website uses cookies to improve your experience while you navigate through the website. Out of these, the cookies that are categorized as necessary are stored on your browser as they are essential for the working of basic functionalities of the website. We also use third-party cookies that help us analyze and understand how you use this website. These cookies will be stored in your browser only with your consent. You also have the option to opt-out of these cookies. But opting out of some of these cookies may affect your browsing experience.</div>
				</div>
				<a class="cli-privacy-readmore" aria-label="Show more" role="button" data-readmore-text="Show more" data-readless-text="Show less"></a>			</div>
		</div>
		<div class="cli-col-12 cli-align-items-stretch cli-px-0 cli-tab-section-container">
												<div class="cli-tab-section">
						<div class="cli-tab-header">
							<a role="button" tabindex="0" class="cli-nav-link cli-settings-mobile" data-target="necessary" data-toggle="cli-toggle-tab">
								Necessary							</a>
															<div class="wt-cli-necessary-checkbox">
									<input type="checkbox" class="cli-user-preference-checkbox"  id="wt-cli-checkbox-necessary" data-id="checkbox-necessary" checked="checked"  />
									<label class="form-check-label" for="wt-cli-checkbox-necessary">Necessary</label>
								</div>
								<span class="cli-necessary-caption">Always Enabled</span>
													</div>
						<div class="cli-tab-content">
							<div class="cli-tab-pane cli-fade" data-id="necessary">
								<div class="wt-cli-cookie-description">
									Necessary cookies are absolutely essential for the website to function properly. These cookies ensure basic functionalities and security features of the website, anonymously.
<table class="cookielawinfo-row-cat-table cookielawinfo-winter"><thead><tr><th class="cookielawinfo-column-1">Cookie</th><th class="cookielawinfo-column-3">Duration</th><th class="cookielawinfo-column-4">Description</th></tr></thead><tbody><tr class="cookielawinfo-row"><td class="cookielawinfo-column-1">cookielawinfo-checkbox-analytics</td><td class="cookielawinfo-column-3">11 months</td><td class="cookielawinfo-column-4">This cookie is set by GDPR Cookie Consent plugin. The cookie is used to store the user consent for the cookies in the category "Analytics".</td></tr><tr class="cookielawinfo-row"><td class="cookielawinfo-column-1">cookielawinfo-checkbox-functional</td><td class="cookielawinfo-column-3">11 months</td><td class="cookielawinfo-column-4">The cookie is set by GDPR cookie consent to record the user consent for the cookies in the category "Functional".</td></tr><tr class="cookielawinfo-row"><td class="cookielawinfo-column-1">cookielawinfo-checkbox-necessary</td><td class="cookielawinfo-column-3">11 months</td><td class="cookielawinfo-column-4">This cookie is set by GDPR Cookie Consent plugin. The cookies is used to store the user consent for the cookies in the category "Necessary".</td></tr><tr class="cookielawinfo-row"><td class="cookielawinfo-column-1">cookielawinfo-checkbox-others</td><td class="cookielawinfo-column-3">11 months</td><td class="cookielawinfo-column-4">This cookie is set by GDPR Cookie Consent plugin. The cookie is used to store the user consent for the cookies in the category "Other.</td></tr><tr class="cookielawinfo-row"><td class="cookielawinfo-column-1">cookielawinfo-checkbox-performance</td><td class="cookielawinfo-column-3">11 months</td><td class="cookielawinfo-column-4">This cookie is set by GDPR Cookie Consent plugin. The cookie is used to store the user consent for the cookies in the category "Performance".</td></tr><tr class="cookielawinfo-row"><td class="cookielawinfo-column-1">viewed_cookie_policy</td><td class="cookielawinfo-column-3">11 months</td><td class="cookielawinfo-column-4">The cookie is set by the GDPR Cookie Consent plugin and is used to store whether or not user has consented to the use of cookies. It does not store any personal data.</td></tr></tbody></table>								</div>
							</div>
						</div>
					</div>
																	<div class="cli-tab-section">
						<div class="cli-tab-header">
							<a role="button" tabindex="0" class="cli-nav-link cli-settings-mobile" data-target="functional" data-toggle="cli-toggle-tab">
								Functional							</a>
															<div class="cli-switch">
									<input type="checkbox" id="wt-cli-checkbox-functional" class="cli-user-preference-checkbox"  data-id="checkbox-functional" />
									<label for="wt-cli-checkbox-functional" class="cli-slider" data-cli-enable="Enabled" data-cli-disable="Disabled"><span class="wt-cli-sr-only">Functional</span></label>
								</div>
													</div>
						<div class="cli-tab-content">
							<div class="cli-tab-pane cli-fade" data-id="functional">
								<div class="wt-cli-cookie-description">
									Functional cookies help to perform certain functionalities like sharing the content of the website on social media platforms, collect feedbacks, and other third-party features.
								</div>
							</div>
						</div>
					</div>
																	<div class="cli-tab-section">
						<div class="cli-tab-header">
							<a role="button" tabindex="0" class="cli-nav-link cli-settings-mobile" data-target="performance" data-toggle="cli-toggle-tab">
								Performance							</a>
															<div class="cli-switch">
									<input type="checkbox" id="wt-cli-checkbox-performance" class="cli-user-preference-checkbox"  data-id="checkbox-performance" />
									<label for="wt-cli-checkbox-performance" class="cli-slider" data-cli-enable="Enabled" data-cli-disable="Disabled"><span class="wt-cli-sr-only">Performance</span></label>
								</div>
													</div>
						<div class="cli-tab-content">
							<div class="cli-tab-pane cli-fade" data-id="performance">
								<div class="wt-cli-cookie-description">
									Performance cookies are used to understand and analyze the key performance indexes of the website which helps in delivering a better user experience for the visitors.
								</div>
							</div>
						</div>
					</div>
																	<div class="cli-tab-section">
						<div class="cli-tab-header">
							<a role="button" tabindex="0" class="cli-nav-link cli-settings-mobile" data-target="analytics" data-toggle="cli-toggle-tab">
								Analytics							</a>
															<div class="cli-switch">
									<input type="checkbox" id="wt-cli-checkbox-analytics" class="cli-user-preference-checkbox"  data-id="checkbox-analytics" />
									<label for="wt-cli-checkbox-analytics" class="cli-slider" data-cli-enable="Enabled" data-cli-disable="Disabled"><span class="wt-cli-sr-only">Analytics</span></label>
								</div>
													</div>
						<div class="cli-tab-content">
							<div class="cli-tab-pane cli-fade" data-id="analytics">
								<div class="wt-cli-cookie-description">
									Analytical cookies are used to understand how visitors interact with the website. These cookies help provide information on metrics the number of visitors, bounce rate, traffic source, etc.
								</div>
							</div>
						</div>
					</div>
																	<div class="cli-tab-section">
						<div class="cli-tab-header">
							<a role="button" tabindex="0" class="cli-nav-link cli-settings-mobile" data-target="advertisement" data-toggle="cli-toggle-tab">
								Advertisement							</a>
															<div class="cli-switch">
									<input type="checkbox" id="wt-cli-checkbox-advertisement" class="cli-user-preference-checkbox"  data-id="checkbox-advertisement" />
									<label for="wt-cli-checkbox-advertisement" class="cli-slider" data-cli-enable="Enabled" data-cli-disable="Disabled"><span class="wt-cli-sr-only">Advertisement</span></label>
								</div>
													</div>
						<div class="cli-tab-content">
							<div class="cli-tab-pane cli-fade" data-id="advertisement">
								<div class="wt-cli-cookie-description">
									Advertisement cookies are used to provide visitors with relevant ads and marketing campaigns. These cookies track visitors across websites and collect information to provide customized ads.
								</div>
							</div>
						</div>
					</div>
																	<div class="cli-tab-section">
						<div class="cli-tab-header">
							<a role="button" tabindex="0" class="cli-nav-link cli-settings-mobile" data-target="others" data-toggle="cli-toggle-tab">
								Others							</a>
															<div class="cli-switch">
									<input type="checkbox" id="wt-cli-checkbox-others" class="cli-user-preference-checkbox"  data-id="checkbox-others" />
									<label for="wt-cli-checkbox-others" class="cli-slider" data-cli-enable="Enabled" data-cli-disable="Disabled"><span class="wt-cli-sr-only">Others</span></label>
								</div>
													</div>
						<div class="cli-tab-content">
							<div class="cli-tab-pane cli-fade" data-id="others">
								<div class="wt-cli-cookie-description">
									Other uncategorized cookies are those that are being analyzed and have not been classified into a category as yet.
								</div>
							</div>
						</div>
					</div>
										</div>
	</div>
</div>
		  </div>
		  <div class="cli-modal-footer">
			<div class="wt-cli-element cli-container-fluid cli-tab-container">
				<div class="cli-row">
					<div class="cli-col-12 cli-align-items-stretch cli-px-0">
						<div class="cli-tab-footer wt-cli-privacy-overview-actions">
						
															<a id="wt-cli-privacy-save-btn" role="button" tabindex="0" data-cli-action="accept" class="wt-cli-privacy-btn cli_setting_save_button wt-cli-privacy-accept-btn cli-btn">SAVE &amp; ACCEPT</a>
													</div>
						
					</div>
				</div>
			</div>
		</div>
	</div>
  </div>
</div>
<div class="cli-modal-backdrop cli-fade cli-settings-overlay"></div>
<div class="cli-modal-backdrop cli-fade cli-popupbar-overlay"></div>
<!--googleon: all-->    <script type="text/javascript">
        function dsWidgetFetch() {
            if (jQuery('#keyword').val().length >= 3) {
                jQuery.ajax({
                    url: 'https://www.embedded.com/wp-admin/admin-ajax.php',
                    type: 'post',
                    data: {
                        action: 'data_fetch',
                        keyword: jQuery('#keyword').val(),
                        datasheetsSecurity: 'b3b31f5414',
                    },
                    beforeSend: function () {
                        jQuery("#loader").show();
                        jQuery('#datafetch').hide();
                    },
                    success: function (data) {
                        jQuery('#datafetch').empty();
                        jQuery('#datafetch').show();
                        jQuery('#datafetch').append(data);
                    },
                    complete: function (data) {
                        jQuery("#loader").hide();
                    }
                });

            } else {
                var lang = jQuery('.ds-widget').attr("data-lang");
                lang = 'en';
                switch (lang) {
                    case "en":
                        error = "Search keyword must be at least 3 characters.";
                        break;
                    default:
                        error = "Search keyword must be at least 3 characters.";
                }

                jQuery('#datafetch').html("<p class='text-white error '>" + error + "</p>");
            }
        }
    </script>

	<link rel='stylesheet' id='all-css-0' href='https://www.embedded.com/wp-content/plugins/cookie-law-info/public/css/cookie-law-info-table.css?m=1660286475g' type='text/css' media='all' />
<script type="text/javascript" src="https://www.embedded.com/_static/??-eJyVks9uwyAMh19oLqqmZb1Mu+44qU9AiZM4CX+GnXZ5+0HSrOot3PAPfR/GoG4BjHeCTpR0aJGV8VeMDm8MIXrVs3L6Sq0W8u7Q84vaQfBAAUZyAzTeTAwN/e5CNTNKwkcyw+LJi4OlfQff6Yv3whJ1yIb/otTCVMcs6H8mjPMhl6UKq1tHDRkIPkxhMz2nxW2NVGPc5rw1t4Tf0ZfaVh6sFtNBh9R28mgzZV9LVH7vmBz4MC1liSHtkT5Levz5nK520XGNgJcMeA2Lh2ciBSkh0sfFOk1G56E/4+TMONUJ7DNrbVJBxDDO964+7cexqo6nU/X6/tb/Abv1S7s=" ></script><script src='https://stats.wp.com/e-202235.js' defer></script>
<script>
	_stq = window._stq || [];
	_stq.push([ 'view', {v:'ext',j:'1:11.2',blog:'155001676',post:'4476093',tz:'0',srv:'www.embedded.com',hp:'vip'} ]);
	_stq.push([ 'clickTrackerInit', '155001676', '4476093' ]);
</script>

<script type="text/javascript">
    var _gaq = _gaq || [];
    _gaq.push(['_setAccount', 'UA-20164576-1']);
    _gaq.push(['_setDomainName', '.embedded.com']);
    _gaq.push(['_trackPageview']);
    _gaq.push(['_trackEvent']);
    (function() {
        var ga = document.createElement('script'); ga.type = 'text/javascript'; ga.async = true;
        ga.src = ('https:' == document.location.protocol ? 'https://ssl' : 'http://www') + '.google-analytics.com/ga.js';
        var s = document.getElementsByTagName('script')[0]; s.parentNode.insertBefore(ga, s);
    })();
</script>

<script>
    jQuery(document).ready(function () {
        $('.main-menu').css('display', 'block');

        //$('.main-menu').css('display', 'block');

        $(".af-main-banner").delay(1400).queue(function(next) {
            $('.af-main-banner').css('visibility', 'visible');
            next();
        });
    });
</script>

<!--<div id='div-gpt-ad-1640007641925-0'>-->
<!--    <script>-->
<!--        googletag.cmd.push(function() { googletag.display('div-gpt-ad-1640007641925-0'); });-->
<!--    </script>-->
<!--</div>-->

<script type="text/javascript">
    _linkedin_partner_id = "4158514";
    window._linkedin_data_partner_ids = window._linkedin_data_partner_ids || [];
    window._linkedin_data_partner_ids.push(_linkedin_partner_id);
</script><script type="text/javascript">
    (function(l) {
        if (!l){window.lintrk = function(a,b){window.lintrk.q.push([a,b])};
            window.lintrk.q=[]}
        var s = document.getElementsByTagName("script")[0];
        var b = document.createElement("script");
        b.type = "text/javascript";b.async = true;
        b.src = "https://snap.licdn.com/li.lms-analytics/insight.min.js";
        s.parentNode.insertBefore(b, s);})(window.lintrk);
</script>
<noscript>
    <img height="1" width="1" style="display:none;" alt="" src="https://px.ads.linkedin.com/collect/?pid=4158514&fmt=gif" />
</noscript>

</body>
</html>
