    <!doctype html>
<html lang="en-US">
    <head>
        <meta name="google-site-verification" content="g2ci_6qmcvh7_y2eKOdcJ_ofJilQcjlTT4FWnCkZZ34" />
        <meta name="google-site-verification" content="ZnIIIt2Q8G6ql3DVglEy1NEJbkGNLvbDKyOzR1_2KxE" />
        <meta charset="UTF-8"><script type="text/javascript">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</script>
        <meta name="viewport" content="width=device-width, initial-scale=1">
        <link rel="profile" href="http://gmpg.org/xfn/11">
        <!-- Google Tag Manager -->
        <script>(function(w,d,s,l,i){w[l]=w[l]||[];w[l].push({'gtm.start':
        new Date().getTime(),event:'gtm.js'});var f=d.getElementsByTagName(s)[0],
        j=d.createElement(s),dl=l!='dataLayer'?'&l='+l:'';j.async=true;j.src=
        'https://www.googletagmanager.com/gtm.js?id='+i+dl;f.parentNode.insertBefore(j,f);
        })(window,document,'script','dataLayer','GTM-NMNZ3NH');</script>
        <!-- End Google Tag Manager -->

        <!-- BEGIN Krux ControlTag for "AspenCore Generic" -->
        <script class="kxct" data-id="sbnf4txm4" data-timing="async" data-version="3.0" type="text/javascript">
            window.Krux||((Krux=function(){ Krux.q.push(arguments) }).q=[]);
            (function(){
                var k=document.createElement('script');k.type='text/javascript';k.async=true;
                k.src=(location.protocol==='https:'?'https:':'http:')+'//cdn.krxd.net/controltag/sbnf4txm4.js';
                var s=document.getElementsByTagName('script')[0];s.parentNode.insertBefore(k,s);
            }());
        </script>

        <!-- END Krux ControlTag -->
        <script class="kxint" data-namespace="aspencore" type="text/javascript">
            window.Krux||((Krux=function(){ Krux.q.push(arguments); }).q=[]);
            (function(){
                function retrieve(n){
                    var k= 'kx'+'aspencore_'+n, ls=(function(){
                        try {
                            return window.localStorage;
                        } catch(e) {
                            return null;
                        }
                    })();
                    if (ls) {
                        return ls[k] || '';
                    } else if (navigator.cookieEnabled) {
                        var m = document.cookie.match(k+'=([^;]*)');
                        return (m && unescape(m[1])) || '';
                    } else {
                        return '';
                    }
                }

                Krux.user = retrieve('user');
                Krux.segments = retrieve('segs') ? retrieve('segs').split(',') : [];
            })();
        </script>
        
                            <script>
            dmpDataLayer = [{"title":"Why automotive OTA update standards are essential","section":["Blog"],"pageType":"Blog","keywords":["Automotive","Design Methods","Integration"]}];
        </script>

                    
        <script>
            dataLayer = [{
                'Author': 'Stephen Evanczuk',
                'PubDate': '20201218'
            }];
        </script>

        <script async src="//js-sec.indexww.com/ht/p/191067-63147096656869.js"></script>

        <!-- Google Tag Manager -->
        <script>
            (function(w,d,s,l,i){w[l]=w[l]||[];w[l].push({'gtm.start':
                    new Date().getTime(),event:'gtm.js'});var f=d.getElementsByTagName(s)[0],
                j=d.createElement(s),dl=l!='dataLayer'?'&l='+l:'';j.async=true;j.src='https://www.googletagmanager.com/gtm.js?id='+i+dl;f.parentNode.insertBefore(j,f);
            })(window,document,'script','dataLayer','GTM-KV6L8V7');

            var gptadslots=[];
            (function(){
                var gads = document.createElement('script');
                gads.async = true;
                gads.type = 'text/javascript';
                var useSSL = 'https:' == document.location.protocol;

                gads.src = (useSSL ? 'https:' : 'http:') +
                    '//www.googletagservices.com/tag/js/gpt.js';
                var node = document.getElementsByTagName('script')[0];
                node.parentNode.insertBefore(gads, node);
            })();
        </script>
        <!-- End Google Tag Manager -->

        <!-- Start: GPT Sync -->
        <script>
            var googletag = googletag || {};
            googletag.cmd = googletag.cmd || [];
            //var gptAdSlots = [];

            googletag.cmd.push(function () {
                var billboardMapping = googletag.sizeMapping()
                    .addSize([800, 375], [970, 250])
                    .addSize([0, 0], [320, 50])
                    .build();

                var leaderMapping = googletag.sizeMapping()
                    .addSize([800, 300], [728, 90])
                    .addSize([0, 0], [320, 60])
                    .build();

                var filmstripMapping = googletag.sizeMapping()
                    .addSize([800, 600], [300, 600])
                    .addSize([0, 0], [300, 300])
                    .build();

                
                googletag.pubads().setTargeting('kw', ['Automotive', 'DesignMethods', 'Integration']);
                googletag.pubads().setTargeting('author', [' StephenEvanczuk']);
                googletag.pubads().setTargeting('aid', ['4468658']);

                
                gptadslots[1] = googletag.defineSlot('/74317539/emd', [[2, 2]], 'div-gpt-ad-942957474691236830-1')
                    .addService(googletag.pubads())
                    .setTargeting('pos', ['welcome']);

                gptadslots[3] = googletag.defineSlot('/74317539/emd', [[728, 90], [320, 60]], 'div-gpt-ad-942957474691236830-3')
                    .defineSizeMapping(leaderMapping)
                    .addService(googletag.pubads())
                    .setTargeting('pos', ['top']);

                gptadslots[4] = googletag.defineSlot('/74317539/emd', [[300, 250]], 'div-gpt-ad-942957474691236830-4')
                    .addService(googletag.pubads())
                    .setTargeting('pos', ['rec1']);

                gptadslots[5] = googletag.defineSlot('/74317539/emd', [[300, 600], [300, 300]], 'div-gpt-ad-942957474691236830-5')
                    .defineSizeMapping(filmstripMapping)
                    .addService(googletag.pubads())
                    .setTargeting('pos', ['rec2']);

                gptadslots[42] = googletag.defineSlot('/74317539/emd', [[4, 4]], 'div-gpt-ad-942957474691236830-42')
                    .addService(googletag.pubads())
                    .setTargeting('pos', ['video']);

                
                gptadslots[44] = googletag.defineSlot('/74317539/emd', ['fluid'], 'div-gpt-ad-native')
                    .setTargeting('type','native')
                    .addService(googletag.pubads());

                
                gptadslots[50] = googletag.defineSlot('/74317539/emd', [[970, 250], [320, 50]], 'div-gpt-ad-942957474691236830-50')
                    .defineSizeMapping(billboardMapping)
                    .addService(googletag.pubads())
                    .setTargeting('pos', ['topnew']);

                //Skin add slot
                googletag.defineSlot('/74317539/emd', [[3,3]], 'div-gpt-ad-3195781-1')
                    .addService(googletag.pubads());


                googletag.pubads().enableSingleRequest();

                googletag.pubads().setTargeting("ksg", Krux.segments);
                googletag.pubads().setTargeting("kuid", Krux.user);

                googletag.pubads().enableAsyncRendering();
                googletag.enableServices();
            });

        </script>

	    		                    <link rel="stylesheet" href="https://olytics.omeda.com/olytics/css/v3/p/olytics.css" />
                <script type="text/javascript">
                    // olytics 3.0
                    window.olytics||(window.olytics=[]),window.olytics.methods=["fire","confirm"],window.olytics.factory=function(i){return function(){var t=Array.prototype.slice.call(arguments);return t.unshift(i),window.olytics.push(t),window.olytics}};for(var i=0;i<window.olytics.methods.length;i++){var method=window.olytics.methods[i];window.olytics[method]=window.olytics.factory(method)}olytics.load=function(i){if(!document.getElementById("olyticsImport")){window.a=window.olytics;var t=document.createElement("script");t.async=!0,t.id="olyticsImport",t.type="text/javascript";var o="";void 0!==i&&void 0!==i.oid&&(o=i.oid),t.setAttribute("data-oid",o),t.src="https://olytics.omeda.com/olytics/js/v3/p/olytics.min.js",t.addEventListener("load",function(t){for(olytics.initialize({Olytics:i});window.a.length>0;){var o=window.a.shift(),s=o.shift();olytics[s]&&olytics[s].apply(olytics,o)}},!1);var s=document.getElementsByTagName("script")[0];s.parentNode.insertBefore(t,s)}},olytics.load({oid:"eeed6a1c8d2f4363a5a1204c00fbd258"});
                </script>
		    
		    
            <script>
                olytics.fire(
                    {
                        behaviorId: '3904C2457689A1C',
                        category: 'Why automotive OTA update standards are essential',
                        tag: 'Blog'
                    }
                );
            </script>
	    
        <!-- Facebook Pixel Code -->
        <script>
            !function(f,b,e,v,n,t,s)

            {if(f.fbq)return;n=f.fbq=function(){n.callMethod?
                n.callMethod.apply(n,arguments):n.queue.push(arguments)};
                if(!f._fbq)f._fbq=n;n.push=n;n.loaded=!0;n.version='2.0';
                n.queue=[];t=b.createElement(e);t.async=!0;
                t.src=v;s=b.getElementsByTagName(e)[0];
                s.parentNode.insertBefore(t,s)}(window, document,'script',
                'https://connect.facebook.net/en_US/fbevents.js');
            fbq('init', '619567575574828');
            fbq('track', 'PageView');
        </script>

        <noscript>
            <img height="1" width="1" style="display:none" src="https://www.facebook.com/tr?id=619567575574828&ev=PageView&noscript=1"/>
        </noscript>

        <!-- End Facebook Pixel Code -->
        
	<!-- This site is optimized with the Yoast SEO plugin v15.4 - https://yoast.com/wordpress/plugins/seo/ -->
	<title>Why automotive OTA update standards are essential - Embedded.com</title>
	<meta name="description" content="Today’s cars are essentially networks on wheels, with computers and sophisticated on-board electronic devices running complex software to keep their" />
	<meta name="robots" content="index, follow, max-snippet:-1, max-image-preview:large, max-video-preview:-1" />
	<link rel="canonical" href="https://www.embedded.com/why-automotive-ota-update-standards-are-essential/" />
	<meta property="og:locale" content="en_US" />
	<meta property="og:type" content="article" />
	<meta property="og:title" content="Why automotive OTA update standards are essential - Embedded.com" />
	<meta property="og:description" content="Today’s cars are essentially networks on wheels, with computers and sophisticated on-board electronic devices running complex software to keep their" />
	<meta property="og:url" content="https://www.embedded.com/why-automotive-ota-update-standards-are-essential/" />
	<meta property="og:site_name" content="Embedded.com" />
	<meta property="article:publisher" content="https://www.facebook.com/embeddedcom" />
	<meta property="article:published_time" content="2020-12-18T05:06:28+00:00" />
	<meta property="article:modified_time" content="2020-12-22T05:14:27+00:00" />
	<meta property="og:image" content="https://www.embedded.com/wp-content/uploads/2020/12/img20201222120007Automotive-OTA-Updates-Must-Be-S_0.jpg" />
	<meta property="og:image:width" content="1000" />
	<meta property="og:image:height" content="517" />
	<meta name="twitter:card" content="summary_large_image" />
	<meta name="twitter:creator" content="@embedded_com" />
	<meta name="twitter:site" content="@embedded_com" />
	<meta name="twitter:label1" content="Written by">
	<meta name="twitter:data1" content="Stephen Evanczuk">
	<meta name="twitter:label2" content="Est. reading time">
	<meta name="twitter:data2" content="4 minutes">
	<script type="application/ld+json" class="yoast-schema-graph">{"@context":"https://schema.org","@graph":[{"@type":"WebSite","@id":"https://www.embedded.com/#website","url":"https://www.embedded.com/","name":"Embedded.com","description":"cracking the code to system development","potentialAction":[{"@type":"SearchAction","target":"https://www.embedded.com/?s={search_term_string}","query-input":"required name=search_term_string"}],"inLanguage":"en-US"},{"@type":"ImageObject","@id":"https://www.embedded.com/why-automotive-ota-update-standards-are-essential/#primaryimage","inLanguage":"en-US","url":"https://www.embedded.com/wp-content/uploads/2020/12/img20201222120007Automotive-OTA-Updates-Must-Be-S_0.jpg","width":1000,"height":517},{"@type":"WebPage","@id":"https://www.embedded.com/why-automotive-ota-update-standards-are-essential/#webpage","url":"https://www.embedded.com/why-automotive-ota-update-standards-are-essential/","name":"Why automotive OTA update standards are essential - Embedded.com","isPartOf":{"@id":"https://www.embedded.com/#website"},"primaryImageOfPage":{"@id":"https://www.embedded.com/why-automotive-ota-update-standards-are-essential/#primaryimage"},"datePublished":"2020-12-18T05:06:28+00:00","dateModified":"2020-12-22T05:14:27+00:00","author":{"@id":"https://www.embedded.com/#/schema/person/03f73c2db7d5526dd9069ddcfbc2cf6c"},"description":"Today\u2019s cars are essentially networks on wheels, with computers and sophisticated on-board electronic devices running complex software to keep their","inLanguage":"en-US","potentialAction":[{"@type":"ReadAction","target":["https://www.embedded.com/why-automotive-ota-update-standards-are-essential/"]}]},{"@type":"Person","@id":"https://www.embedded.com/#/schema/person/03f73c2db7d5526dd9069ddcfbc2cf6c","name":"Stephen Evanczuk","image":{"@type":"ImageObject","@id":"https://www.embedded.com/#personlogo","inLanguage":"en-US","url":"https://secure.gravatar.com/avatar/fb7076c11b0227156c0c6c579ad597ab?s=96&d=mm&r=g","caption":"Stephen Evanczuk"},"sameAs":["Stephen"]}]}</script>
	<!-- / Yoast SEO plugin. -->


<link rel='dns-prefetch' href='//fonts.googleapis.com' />
<link rel='dns-prefetch' href='//s.w.org' />
<link rel="alternate" type="application/rss+xml" title="Embedded.com &raquo; Feed" href="https://www.embedded.com/feed/" />
<link rel="alternate" type="application/rss+xml" title="Embedded.com &raquo; Comments Feed" href="https://www.embedded.com/comments/feed/" />
        <meta name="created" content="December 18, 2020"/>
		            <meta name="author" content="Embedded Staff"/>
		        <meta name="featuredimage" content="https://www.embedded.com/wp-content/uploads/2020/12/img20201222120007Automotive-OTA-Updates-Must-Be-S_0.jpg?w=640"/>
		<link rel="alternate" type="application/rss+xml" title="Embedded.com &raquo; Why automotive OTA update standards are essential Comments Feed" href="https://www.embedded.com/why-automotive-ota-update-standards-are-essential/feed/" />
		<script type="text/javascript">
			window._wpemojiSettings = {"baseUrl":"https:\/\/s.w.org\/images\/core\/emoji\/13.0.1\/72x72\/","ext":".png","svgUrl":"https:\/\/s.w.org\/images\/core\/emoji\/13.0.1\/svg\/","svgExt":".svg","source":{"concatemoji":"https:\/\/www.embedded.com\/wp-includes\/js\/wp-emoji-release.min.js?ver=5.6"}};
			!function(e,a,t){var r,n,o,i,p=a.createElement("canvas"),s=p.getContext&&p.getContext("2d");function c(e,t){var a=String.fromCharCode;s.clearRect(0,0,p.width,p.height),s.fillText(a.apply(this,e),0,0);var r=p.toDataURL();return s.clearRect(0,0,p.width,p.height),s.fillText(a.apply(this,t),0,0),r===p.toDataURL()}function l(e){if(!s||!s.fillText)return!1;switch(s.textBaseline="top",s.font="600 32px Arial",e){case"flag":return!c([127987,65039,8205,9895,65039],[127987,65039,8203,9895,65039])&&(!c([55356,56826,55356,56819],[55356,56826,8203,55356,56819])&&!c([55356,57332,56128,56423,56128,56418,56128,56421,56128,56430,56128,56423,56128,56447],[55356,57332,8203,56128,56423,8203,56128,56418,8203,56128,56421,8203,56128,56430,8203,56128,56423,8203,56128,56447]));case"emoji":return!c([55357,56424,8205,55356,57212],[55357,56424,8203,55356,57212])}return!1}function d(e){var t=a.createElement("script");t.src=e,t.defer=t.type="text/javascript",a.getElementsByTagName("head")[0].appendChild(t)}for(i=Array("flag","emoji"),t.supports={everything:!0,everythingExceptFlag:!0},o=0;o<i.length;o++)t.supports[i[o]]=l(i[o]),t.supports.everything=t.supports.everything&&t.supports[i[o]],"flag"!==i[o]&&(t.supports.everythingExceptFlag=t.supports.everythingExceptFlag&&t.supports[i[o]]);t.supports.everythingExceptFlag=t.supports.everythingExceptFlag&&!t.supports.flag,t.DOMReady=!1,t.readyCallback=function(){t.DOMReady=!0},t.supports.everything||(n=function(){t.readyCallback()},a.addEventListener?(a.addEventListener("DOMContentLoaded",n,!1),e.addEventListener("load",n,!1)):(e.attachEvent("onload",n),a.attachEvent("onreadystatechange",function(){"complete"===a.readyState&&t.readyCallback()})),(r=t.source||{}).concatemoji?d(r.concatemoji):r.wpemoji&&r.twemoji&&(d(r.twemoji),d(r.wpemoji)))}(window,document,window._wpemojiSettings);
		</script>
		<style type="text/css">
img.wp-smiley,
img.emoji {
	display: inline !important;
	border: none !important;
	box-shadow: none !important;
	height: 1em !important;
	width: 1em !important;
	margin: 0 .07em !important;
	vertical-align: -0.1em !important;
	background: none !important;
	padding: 0 !important;
}
</style>
	<link rel='stylesheet' id='all-css-0' href='https://www.embedded.com/_static/??-eJyVj8sOgjAQRX/IMmoEVsZvKe2glb6cKRD+XmjAhbvu5tzMPcmFOQrjlR01Mihm0IYTdDaoQVjTkaQFOC0WK2d8tT6cYG2o4BP6BOmFbuuFCcnjzCJSAMmMiaFff4SckYNDMdVZvmVHJK0tdnYhJE4kY7b9qNjD1qghO/JV3jeacv39GZGWauNKSxqKLE4+vemNEjHEMf5h6R6NlJN91I7Hsoe7X5pze2uaa1t/AZ8HvQ8=' type='text/css' media='all' />
<style id='wp-block-library-inline-css'>
.has-text-align-justify{text-align:justify;}
</style>
<link rel='stylesheet' id='covernews-google-fonts-css'  href='https://fonts.googleapis.com/css?family=Source%20Sans%20Pro:400,400i,700,700i|Source%20Sans%20Pro:400,400i,700,700i&#038;subset=latin,latin-ext' media='all' />
<link rel='stylesheet' id='all-css-2' href='https://www.embedded.com/_static/??-eJyNjtsKwjAQRH/IdKtSLw/ip0jMLm002YRsYunfW68oIvRtBmYOB/qoTOBMnCF35EmA/JEQCUHy4KgyIjP4WEVXWssCJ81JW1ZGx1wSPdbSEeWfyxNswoUSUy8qpvCHPs3BF/XWoBy1OatttQAfsIwOIJ1OhBpxuEfL7VTCwbIBCcZqp1xog3yVylueShpnr3677P1uvqo39bJp1vUV/AKJyA==' type='text/css' media='all' />
<style id='covernews-style-inline-css'>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</style>
<script type='text/javascript' src='https://www.embedded.com/_static/??-eJx9js0OAiEMhF9IfiS6ezI+C0JdIaUglGz27eWwicZEk0nmMN+0o9YiAjnsHpqKQ88OddtNpkAytoP6B4kUlmoZfsItk/kMXSYGYlWwL4EGYKnaQMLZwr2CwuwsNs7VLiBKxu0eEL/L/IA07kO6gffg36uEkUae9n/XdDlOep60ns8mvgAGEFYV'></script>
<link rel="https://api.w.org/" href="https://www.embedded.com/wp-json/" /><link rel="alternate" type="application/json" href="https://www.embedded.com/wp-json/wp/v2/posts/4468658" /><link rel="EditURI" type="application/rsd+xml" title="RSD" href="https://www.embedded.com/xmlrpc.php?rsd" />
<link rel="wlwmanifest" type="application/wlwmanifest+xml" href="https://www.embedded.com/wp-includes/wlwmanifest.xml" /> 
<meta name="generator" content="WordPress 5.6" />
<link rel='shortlink' href='https://www.embedded.com/?p=4468658' />
<link rel="alternate" type="application/json+oembed" href="https://www.embedded.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fwww.embedded.com%2Fwhy-automotive-ota-update-standards-are-essential%2F" />
<link rel="alternate" type="text/xml+oembed" href="https://www.embedded.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fwww.embedded.com%2Fwhy-automotive-ota-update-standards-are-essential%2F&#038;format=xml" />
<style type='text/css'>img#wpstats{display:none}</style><script type="text/javascript">
function janrainSignOut(){
			janrain.capture.ui.endCaptureSession();
}
(function() {
		if (typeof window.janrain !== 'object') window.janrain = {};
		window.janrain.settings = {};
		window.janrain.settings.capture = {};

		// capture settings
		janrain.settings.capture.language = 'en-US';
		janrain.settings.capture.redirectUri = 'https://www.embedded.com/wp-admin/admin-ajax.php?action=janrain_capture_redirect_uri';
		janrain.settings.capture.appId= 'yrnwjjpufjjenx8n97kuadd73f';
		janrain.settings.capture.clientId = 'xpjt4frc5w2p8szh9dkum6ypas2fyzq3';
		janrain.settings.capture.responseType = 'code';
		janrain.settings.capture.captureServer = 'https://aspencore.us.janraincapture.com';
		janrain.settings.capture.registerFlow = 'socialRegistration';
		janrain.settings.packages = ['capture','login'];

		janrain.settings.capture.setProfileCookie = true;
		janrain.settings.capture.keepProfileCookieAfterLogout = true;
		janrain.settings.capture.setProfileData = true;

		// styles
		janrain.settings.capture.stylesheets = ['https://www.embedded.com/wp-content/plugins/janrain-capture-screens/stylesheets/janrain.css',];
janrain.settings.capture.recaptchaPublicKey = '6LeVKb4SAAAAAGv-hg5i6gtiOV4XrLuCDsJOnYoP'; //captcha			// engage settings
			janrain.settings.language = 'en-US';
			janrain.settings.appUrl = 'https://aspencore.rpxnow.com';
			janrain.settings.tokenAction = 'event';
						// federate settings
			janrain.settings.capture.federate = '1';
			janrain.settings.capture.federateServer = 'https://aspencore.us.janrainsso.com';
			janrain.settings.capture.federateXdReceiver = 'https://www.embedded.com/wp-content/plugins/janrain-capture/xdcomm.html';
			janrain.settings.capture.federateLogoutUri = 'https://www.embedded.com/wp-login.php?action=logout&redirect_to=https%3A%2F%2Fwww.embedded.com%3A443%2Fwhy-automotive-ota-update-standards-are-essential%2F&_wpnonce=57eb967eb8&_janrainsso=1';
					function isReady() { janrain.ready = true; };
		if (document.addEventListener) {
				document.addEventListener("DOMContentLoaded", isReady, false);
		} else {
				window.attachEvent('onload', isReady);
		}

		var e = document.createElement('script');
		e.type = 'text/javascript';
		e.id = 'janrainAuthWidget'
		var url = document.location.protocol === 'https:' ? 'https://' : 'http://';
		url += 'widget-cdn.rpxnow.com/load/aspencore';
		e.src = url;
		var s = document.getElementsByTagName('script')[0];
		s.parentNode.insertBefore(e, s);
})();
		</script><script type="text/javascript">// call our code/token exchanger, and use the token to set up a capture session
function getTokenForCode(code, redirect_uri) {
    var url = '/wp-admin/admin-ajax.php?action=janrain_capture_redirect_uri&code=';
    url += code;
    window.location.href = url;
}

function janrainReturnExperience() {
    var span = document.getElementById('traditionalWelcomeName');
    var name = janrain.capture.ui.getReturnExperienceData("displayName");
    if (span && name) {
        span.innerHTML = "Welcome back, " + name + "!";
    }
}

function janrainCaptureWidgetOnLoad() {
    //check for access token in localStorage and create session
    if(localStorage && localStorage.getItem("janrainCaptureTokenWP")) {
        janrain.capture.ui.createCaptureSession(localStorage.getItem("janrainCaptureTokenWP"));
        localStorage.removeItem("janrainCaptureTokenWP");
    }

    function handleCaptureLogin(result) {
        // console.log ("exchanging code for token...");
        getTokenForCode(result.authorizationCode, janrain.settings.capture.redirectUri);
    }

    janrain.events.onCaptureAccessDenied.addHandler(function(result){
        janrain.capture.ui.createCaptureSession(access_token);
    });

    janrain.events.onCaptureScreenShow.addHandler(function(result){
        if (result.screen == "returnTraditional") {
            janrainReturnExperience();
        }
    });

    janrain.events.onCaptureLoginSuccess.addHandler(handleCaptureLogin);
    janrain.events.onCaptureRegistrationSuccess.addHandler(handleCaptureLogin);

    janrain.capture.ui.start();
}</script>        <style type="text/css">
                        .site-title,
            .site-description {
                position: absolute;
                clip: rect(1px, 1px, 1px, 1px);
                display: none;
            }

            

        </style>
        			<style type="text/css">
				/* If html does not have either class, do not show lazy loaded images. */
				html:not( .jetpack-lazy-images-js-enabled ):not( .js ) .jetpack-lazy-image {
					display: none;
				}
			</style>
			<script>
				document.documentElement.classList.add(
					'jetpack-lazy-images-js-enabled'
				);
			</script>
		<link rel="icon" href="https://www.embedded.com/wp-content/uploads/2019/10/favicon1.ico?w=16" sizes="32x32" />
<link rel="icon" href="https://www.embedded.com/wp-content/uploads/2019/10/favicon1.ico?w=16" sizes="192x192" />
<link rel="apple-touch-icon" href="https://www.embedded.com/wp-content/uploads/2019/10/favicon1.ico?w=16" />
<meta name="msapplication-TileImage" content="https://www.embedded.com/wp-content/uploads/2019/10/favicon1.ico?w=16" />
<!-- Your Google Analytics Plugin is missing the tracking ID -->
    </head>

<body class="post-template-default single single-post postid-4468658 single-format-standard wp-custom-logo default-content-layout align-content-left">
    <!-- Google Tag Manager (noscript) -->
    <noscript><iframe src="https://www.googletagmanager.com/ns.html?id=GTM-NMNZ3NH"
    height="0" width="0" style="display:none;visibility:hidden"></iframe></noscript>
    <!-- End Google Tag Manager (noscript) -->
<!--    <div class="ads">-->
<!--      <div id='div-gpt-ad-942957474691236830-1'>-->
<!--        <script type='text/javascript'>-->
<!--            googletag.display('div-gpt-ad-942957474691236830-1');-->
<!--        </script>-->
<!--        </div>-->
<!--    </div>-->


<div id="page" class="site">
    <a class="skip-link screen-reader-text" href="#content">Skip to content</a>

    <div class="header-layout-2">

        
        <header id="masthead" class="site-header">
            
            <div class="masthead-banner " data-background="">
                <div class="container">
                    <div class="row">
                                             <div class="banner-promotions-wrapper">
                    <div class="promotion-section">
                        <div id="custom_html-6" class="widget_text widget covernews-widget widget_custom_html"><div class="textwidget custom-html-widget"><!--<img src="https://secure-ds.serving-sys.com/resources//PROD/asset/33458/IMAGE/20190319/edn-970x250_44156068647969232.jpg" width="970" height="250" data-lazy-src="https://secure-ds.serving-sys.com/resources//PROD/asset/33458/IMAGE/20190319/edn-970x250_44156068647969232.jpg?is-pending-load=1" srcset="data:image/gif;base64,R0lGODlhAQABAIAAAAAAAP///yH5BAEAAAAALAAAAAABAAEAAAIBRAA7" class=" jetpack-lazy-image"><noscript><img src="https://secure-ds.serving-sys.com/resources//PROD/asset/33458/IMAGE/20190319/edn-970x250_44156068647969232.jpg" width="970" height="250" /></noscript> -->
<div class="ads ads-top" style="padding-bottom:10px; max-width: 100%">
<div id='div-gpt-ad-942957474691236830-50'>
<script type='text/javascript'>
googletag.cmd.push(function() { googletag.display('div-gpt-ad-942957474691236830-50'); });
</script>
</div>
</div></div></div>                    </div>
                </div>
                                    </div>
                </div>
            </div>

            <nav id="site-navigation" class="main-navigation">
                <div class="container">
                    <div class="row">
                        <div class="navigation-container">
                            <div class="site-branding col-md-2 col-sm-2">
                                <a href="https://www.embedded.com/" class="custom-logo-link" rel="home"><img width="208" height="31" src="https://www.embedded.com/wp-content/uploads/2019/10/embedded-white-1.png" class="custom-logo jetpack-lazy-image" alt="Embedded.com" data-lazy-src="https://www.embedded.com/wp-content/uploads/2019/10/embedded-white-1.png?is-pending-load=1" srcset="data:image/gif;base64,R0lGODlhAQABAIAAAAAAAP///yH5BAEAAAAALAAAAAABAAEAAAIBRAA7" /></a>                                    <p class="site-title font-family-1">
                                        <a href="https://www.embedded.com/"
                                           rel="home">Embedded.com</a>
                                    </p>
                                                            </div>
                            <!-- </div> -->
                            <span class="toggle-menu" aria-controls="primary-menu" aria-expanded="false">
                                <span class="screen-reader-text">Primary Menu</span>
                                 <i class="ham"></i>
                            </span>
                            <div class="menu main-menu"><ul id="primary-menu" class="menu"><li id="menu-item-4462429" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children menu-item-4462429"><a href="#">Embedded Focus</a>
<ul class="sub-menu">
	<li id="menu-item-4462430" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children menu-item-4462430"><a href="#">Hardware</a>
	<ul class="sub-menu">
		<li id="menu-item-4462431" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-4462431"><a href="/tag/boards-modules/">Boards &#038; Modules</a></li>
		<li id="menu-item-4462432" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-4462432"><a href="/tag/chips-components/">Chips &#038; Components</a></li>
		<li id="menu-item-4462433" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-4462433"><a href="/tag/components/">Components</a></li>
		<li id="menu-item-4462434" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-4462434"><a href="/tag/connectivity/">Connectivity</a></li>
		<li id="menu-item-4462435" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-4462435"><a href="/tag/coprocessors/">Coprocessors</a></li>
		<li id="menu-item-4462436" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-4462436"><a href="/tag/displays/">Displays</a></li>
		<li id="menu-item-4462437" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-4462437"><a href="/tag/electromechanical/">Electromechanical</a></li>
		<li id="menu-item-4462438" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-4462438"><a href="/tag/memory-storage/">Memory / Storage</a></li>
		<li id="menu-item-4462439" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-4462439"><a href="/tag/motors/">Motors</a></li>
		<li id="menu-item-4462440" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-4462440"><a href="/tag/optoelectronics/">Optoelectronics</a></li>
		<li id="menu-item-4462441" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-4462441"><a href="/tag/sensors/">Sensors</a></li>
	</ul>
</li>
	<li id="menu-item-4462446" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children menu-item-4462446"><a href="#">Software</a>
	<ul class="sub-menu">
		<li id="menu-item-4462447" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-4462447"><a href="/tag/eda/">EDA</a></li>
		<li id="menu-item-4462448" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-4462448"><a href="/tag/operating-systems/">Operating Systems</a></li>
		<li id="menu-item-4462450" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-4462450"><a href="/tag/source-code/">Source Code</a></li>
	</ul>
</li>
	<li id="menu-item-4462411" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children menu-item-4462411"><a href="#">Design</a>
	<ul class="sub-menu">
		<li id="menu-item-4462412" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-4462412"><a href="/tag/integration/">Integration</a></li>
		<li id="menu-item-4462413" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-4462413"><a href="/tag/iot/">IoT</a></li>
		<li id="menu-item-4462414" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-4462414"><a href="/tag/performance/">Performance</a></li>
		<li id="menu-item-4462415" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-4462415"><a href="/tag/security/">Security</a></li>
	</ul>
</li>
	<li id="menu-item-4462418" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children menu-item-4462418"><a href="#">Development</a>
	<ul class="sub-menu">
		<li id="menu-item-4462420" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-4462420"><a href="/tag/design-methods/">Design Methods</a></li>
		<li id="menu-item-4462421" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-4462421"><a href="/tag/solutions/">Solutions</a></li>
		<li id="menu-item-4462423" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-4462423"><a href="/tag/manufacturing/">Manufacturing</a></li>
		<li id="menu-item-4462424" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-4462424"><a href="/tag/supply-chain/">Supply Chain</a></li>
		<li id="menu-item-4462425" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-4462425"><a href="/tag/test-measurement/">Test &#038; Measurement</a></li>
		<li id="menu-item-4462427" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-4462427"><a href="/tag/tools/">Tools</a></li>
		<li id="menu-item-4462428" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-4462428"><a href="/tag/tools-software/">Tools &#038; Software</a></li>
	</ul>
</li>
	<li id="menu-item-4462442" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children menu-item-4462442"><a href="#">Industry</a>
	<ul class="sub-menu">
		<li id="menu-item-4462443" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-4462443"><a href="/tag/automotive/">Automotive</a></li>
		<li id="menu-item-4462444" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-4462444"><a href="/tag/Consumer/">Consumer</a></li>
		<li id="menu-item-4462445" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-4462445"><a href="/tag/medical/">Medical</a></li>
	</ul>
</li>
	<li id="menu-item-4462801" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children menu-item-4462801"><a href="#">Trends</a>
	<ul class="sub-menu">
		<li id="menu-item-4462802" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-4462802"><a href="/tag/advanced-technology/">Advanced Technology</a></li>
		<li id="menu-item-4462803" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-4462803"><a href="/tag/applications/">Applications</a></li>
		<li id="menu-item-4462804" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-4462804"><a href="/tag/industry/">Industry</a></li>
		<li id="menu-item-4462805" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-4462805"><a href="/tag/profession/">Profession</a></li>
	</ul>
</li>
	<li id="menu-item-4462970" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-4462970"><a href="/tag/communications/">Communications</a></li>
</ul>
</li>
<li id="menu-item-4462385" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-4462385"><a href="https://www.embedded.com/category/news/">News</a></li>
<li id="menu-item-4462455" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-has-children menu-item-4462455"><a href="https://www.embedded.com/about-us/">About Us</a>
<ul class="sub-menu">
	<li id="menu-item-4462721" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-4462721"><a href="https://www.embedded.com/contact-us/">Contact Us</a></li>
	<li id="menu-item-4462456" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-4462456"><a href="https://www.embedded.com/editorial-contributions/">Editorial Contributions</a></li>
</ul>
</li>
<li class ="jan-button"><div class="openid-connect-login-button"><a href="https://login.aspencore.com/d045a02d-767d-4f3f-80d7-695dce25d142/login/authorize?response_type=code&scope=profile%20email%20openid&client_id=216002e0-47e9-4d0c-8915-4dfcbabd2e56&state=579177fc187c78a3a61f14919f7b88b3&redirect_uri=https%3A%2F%2Fwww.embedded.com%2Fopenid-connect-authorize">Login</a></div></li></ul></div>                            <div class="cart-search">

                                <span class="af-search-click icon-search">
                                <i class="fa fa-search"></i>
                            </span>
                            </div>
                        </div>
                    </div>
                </div>
            </nav>
        </header>

        <div id="af-search-wrap">
            <div class="af-search-box table-block">
                <div class="table-block-child v-center text-center">
                    <form role="search" method="get" class="search-form" action="https://www.embedded.com/">
				<label>
					<span class="screen-reader-text">Search for:</span>
					<input type="search" class="search-field" placeholder="Search &hellip;" value="" name="s" />
				</label>
				<input type="submit" class="search-submit" value="Search" />
			</form>                </div>
            </div>
            <div class="af-search-close af-search-click">
                <span></span>
                <span></span>
            </div>
        </div>
    </div>








<!-- Login Button -->

<!--
                <div class='loginlinks'>
				
                    <a href="https://login.aspencore.com/d045a02d-767d-4f3f-80d7-695dce25d142/login/authorize?response_type=code&scope=profile%20email%20openid&client_id=216002e0-47e9-4d0c-8915-4dfcbabd2e56&state=19b20907e3d0180a6738c4298d257ec9&redirect_uri=https%3A%2F%2Fwww.embedded.com%2Fopenid-connect-authorize" class='login' style='font-weight: 600;'>Sign in</a>
					
					or
					
                    <a href="https://login.aspencore.com/d045a02d-767d-4f3f-80d7-695dce25d142/login/authorize?response_type=code&scope=profile%20email%20openid&client_id=216002e0-47e9-4d0c-8915-4dfcbabd2e56&state=ab956ddee8d09cf1671626e0a1215bcc&redirect_uri=https%3A%2F%2Fwww.embedded.com%2Fopenid-connect-authorize" class='register' style='font-weight: 400;'>Register</a>
                </div>
				
-->
                
















    <div id="content" class="container">


        <div class="em-breadcrumbs font-family-1">
                <div class="row">
                        <div role="navigation" aria-label="Breadcrumbs" class="breadcrumb-trail breadcrumbs" itemprop="breadcrumb"><ul class="trail-items" itemscope itemtype="http://schema.org/BreadcrumbList"><meta name="numberOfItems" content="3" /><meta name="itemListOrder" content="Ascending" /><li itemprop="itemListElement" itemscope itemtype="http://schema.org/ListItem" class="trail-item trail-begin"><a href="https://www.embedded.com" rel="home" itemprop="item"><span itemprop="name">Home</span></a><meta itemprop="position" content="1" /></li><li itemprop="itemListElement" itemscope itemtype="http://schema.org/ListItem" class="trail-item"><a href="https://www.embedded.com/category/blog/" itemprop="item"><span itemprop="name">Blog</span></a><meta itemprop="position" content="2" /></li><li itemprop="itemListElement" itemscope itemtype="http://schema.org/ListItem" class="trail-item trail-end"><span itemprop="item"><span itemprop="name">Why automotive OTA update standards are essential</span></span><meta itemprop="position" content="3" /></li></ul></div>                </div>
        </div>


    
    <!--    <div class="">-->
    <div id="wallpaper_image">
    <div class="af-skin-content">

    <div class="row">
        <div id="primary" class="content-area">
            <main id="main" class="site-main">

				                    <article id="post-4468658" class="post-4468658 post type-post status-publish format-standard hentry category-blog tag-automotive tag-design-methods tag-integration display_tag-posts-slider">
                        <div class="entry-content-wrap">
							<header class="entry-header">

    <div class="header-details-wrapper">
        <div class="entry-header-details">
                            <div class="figure-categories figure-categories-bg">
                                        <ul class="cat-links"><li class="meta-category">
                             <a class="covernews-categories category-color-1" href="https://www.embedded.com/category/blog/" alt="View all posts in Blog"> 
                                 Blog
                             </a>
                        </li></ul>                </div>
                        <h1 class="entry-title">Why automotive OTA update standards are essential</h1>
            
                
        <span class="author-links">
                            <span class="item-metadata posts-date">
                <i class="far fa-clock"></i>
                    December 18, 2020            </span>
            			
                <span class="item-metadata posts-author">

                    	                    <a href="https://www.embedded.com/author/embedded-staff/" title="Posts by Mike Gardner" class="author url fn" rel="author">Mike Gardner</a>                            </span>
			        </span>
		                

                    </div>
    </div>
        <div class="aft-post-thumbnail-wrapper">    
            </div>
</header><!-- .entry-header -->							

    <div class="entry-content">
        <p>Today’s cars are essentially networks on wheels, with computers and sophisticated on-board electronic devices running complex software to keep their occupants safe, comfortable, and entertained. Present-day cars each contain more than 50 electronic devices, from multiple vendors, running a mix of operating systems and using several network protocols.</p>
<p style="text-align: center;"><img src="https://www.eetimes.eu/wp-content/uploads/2020/11/eSyncAlliance_Over_the_Air_EE-Times.jpg" data-lazy-src="https://www.eetimes.eu/wp-content/uploads/2020/11/eSyncAlliance_Over_the_Air_EE-Times.jpg?is-pending-load=1" srcset="data:image/gif;base64,R0lGODlhAQABAIAAAAAAAP///yH5BAEAAAAALAAAAAABAAEAAAIBRAA7" class=" jetpack-lazy-image"><noscript><img src="https://www.eetimes.eu/wp-content/uploads/2020/11/eSyncAlliance_Over_the_Air_EE-Times.jpg" /></noscript></p>
<p>The resulting complexity has an unfortunate downside: Software-related recalls are becoming increasingly problematic, costing the auto industry billions.</p>
<p>For instance, in August, Honda had to recall 608,000 vans and SUVs in the U.S. market in order to update faulty software that was causing instrument panels not to show speed and other important information, including the rear-view camera image. There are many more similar examples of software issues requiring expensive and inconvenient recalls.</p>
<p>To mitigate these costs, automakers are increasingly turning to over-the-air (OTA) updates as the primary solution. OTA updates enable a vehicle’s software to be remotely updated, without requiring the vehicle to be physically present at the dealer’s garage. In theory, the practice solves the software recall issue, but it creates a new dilemma: Tier 1 suppliers and carmakers need a way to manage the complexity of multiple in-vehicle devices remotely.</p>
<p>Adding to the complexity, though, is the fragmented nature of the auto industry. Several <a href="https://www.eetimes.eu/tag/automotive/" target="_blank" rel="noreferrer noopener"> automotive</a> software vendors are pushing their own proprietary OTA-update technologies, as are several Tier 1 suppliers and a number of major automakers. Indeed, there are now more than 30 different solutions for OTA updates and remote data gathering among the top 50 Tier 1 suppliers and 30 major OEMs.</p>
<p>Not surprisingly, this has caused severe headaches for designers trying to ensure compatibility as they integrate their devices and software into a working whole. Development costs, time to market, and the risk of errors have all risen in unison.</p>
<p>This situation is unsustainable, and a standardized approach for OTA updates is gaining urgency. What is needed is a single industry-wide platform that defines the OTA-related behavior of each device, together with standardized message formats and response protocols.</p>
<p>Today, Tier 1 vendors that sell to multiple OEMs are forced to reengineer their products for different OTA technologies — a slow and expensive proposition. A standardized platform would greatly simplify development by eliminating this complex and onerous task, saving time and costs. The time saved could then be redirected toward creating new features they could offer to their automaker customers, enabling such as better efficiency, custom lighting, or entertainment or convenience features.</p>
<p>Furthermore, standardization would allow all stakeholders to benefit from common development and test tools.</p>
<p><strong>Ensuring safety</strong></p>
<p>While cars have been outfitted with many new features for comfort and infotainment, the most important role of in-vehicle software is safety. ABS braking, lane departure, and other driver assistance systems are helping to make driving safer — with the caveat that they are vitally dependent on up-to-date, error-free software.</p>
<p>The current state of the technology is such that software in the safety domain is often unable to be updated over the air. To ensure reliable operation, OEMs spend a lot of time and effort on quality assurance and testing — primarily to ensure that their particular combination of devices in the car is compatible, reliable and safe.</p>
<p>Updating safety-related software requires the ability to move from a verified, fully tested combination of software across multiple devices to the next fully tested combination, with confidence that all devices will update successfully. Ensuring against an incomplete update requires additional OTA-update safeguards and policies that can manage the entire process from start to finish, including rolling back to a known-good combination if any one device does not update properly. Safety also demands control and management of when updates occur — for example, allowing braking-system updates to take place only when the car is stationary and its engine is turned off.</p>
<p>With zero room for error in an environment requiring the management of multiple devices from many suppliers, standardization can play a critical role in ensuring car safety.</p>
<p><strong><strong>A single OTA pipeline</strong></strong></p>
<p>This article has focused first and foremost on the important role of OTA software updates, but there is also substantial secondary value to be gained from building a secure bidirectional pipeline: real-time, real-world data gathering from the vehicle. With a continuous stream of detailed information flowing from devices in each vehicle, automakers have the opportunity to manage the mechanical health of a vehicle throughout its life cycle and to apply predictive analytics for spotting faults before they happen. A bidirectional pipeline also enables the collection of data from entire fleets of vehicles, ensuring the anonymity of individual drivers while still providing real-world insight into driving behavior and car usage patterns.</p>
<p>There are strong arguments in favor of OTA updates and data gathering sharing a single pipeline, avoiding a second, separate connection for data collection purposes. Cost savings are but one factor. Perhaps more important is that each additional access point to a vehicle represents an additional security weak point for potential hackers. Fewer connections simply mean fewer potential problems.</p>
<p><strong><strong>Standardization: The way forward</strong></strong></p>
<p>The arguments presented here make it clear that the automotive industry would greatly benefit from a single standard for OTA updates and data collection running on a single, bidirectional data pipeline for all the various devices in the vehicle.</p>
<p>The <a href="https://esyncalliance.org/" target="_blank" rel="noreferrer noopener">eSync Alliance</a> has been formed to meet this important objective and is working on developing and promoting a standardized data pipeline. With big-player members such as Alps Alpine, Faurecia, HELLA, Molex, and ZF, the alliance has the scale and resources to deliver the standardization that the industry needs.</p>
<p><em>Mike Gardner is Executive Director at eSync Alliance.</em></p>
<p><!-- GPT AdSlot 4 for Ad unit 'eetimes-eu' ### Size: [[728,90],[320,60]] --></p>
<p><!-- End AdSlot 4 --></p>
<p style="text-indent: -20px; margin-left: 60px !important; font-size: 16px!important; text-align: left;"><em><strong>&gt;&gt; This article was originally published on our sister site, <a href="https://www.eetimes.eu/automotive-ota-updates-must-be-standardized/" target="_blank" rel="noopener">EE Times Europe</a>.</strong></em></p>
<h2 id="kt-adv-heading_b9849c-87"><!-- 
Automotive OTA Updates Must Be Standardized 
12/08/2020 
--></h2>
<hr style="margin: 10px auto; width: 80%; border: 0px none; height: 1px; background-image: linear-gradient(to right, transparent, rgba(0, 0, 0, 0.75), transparent);" />
<p><strong>Related Contents:</strong></p>
<ul style="list-style-position: outside; padding-left: 20px;">
<li><a href="https://www.embedded.com/addressing-the-challenge-of-automotive-ota-update/" target="_blank" rel="noopener">Addressing the challenge of automotive OTA update</a></li>
<li><a href="https://www.embedded.com/the-changing-face-of-automotive-software/" target="_blank" rel="noopener">The changing face of automotive software</a></li>
<li><a href="https://www.embedded.com/anticipating-need-for-automotive-grade-linux-expertise/" target="_blank" rel="noopener">Anticipating need for Automotive Grade Linux expertise</a></li>
<li><a href="https://www.embedded.com/a-diff-approach-for-automotive-ota-updates/" target="_blank" rel="noopener">A &#8216;diff&#8217; approach for automotive OTA updates</a></li>
<li><a href="https://www.embedded.com/enhancing-security-in-automotive-systems/" target="_blank" rel="noopener">Enhancing security in automotive systems</a></li>
</ul>
<p><em>For more Embedded, <a href="https://aspencore.dragonforms.com/loading.do?omedasite=EmbeddedSubscribe" target="_blank" rel="noopener">subscribe to Embedded&#8217;s weekly email newsletter</a>.</em></p>
<p>&nbsp;</p>
<p><!-- newsletter blurb
The automotive industry would greatly benefit from a single standard for OTA updates and data collection running on a single, bidirectional data pipeline for all the various devices in the vehicle.
--></p>
<div class="sharedaddy sd-sharing-enabled"><div class="robots-nocontent sd-block sd-social sd-social-icon-text sd-sharing"><h3 class="sd-title">Share this:</h3><div class="sd-content"><ul><li class="share-twitter"><a rel="nofollow noopener noreferrer" data-shared="sharing-twitter-4468658" class="share-twitter sd-button share-icon" href="https://www.embedded.com/why-automotive-ota-update-standards-are-essential/?share=twitter" target="_blank" title="Click to share on Twitter"><span>Twitter</span></a></li><li class="share-facebook"><a rel="nofollow noopener noreferrer" data-shared="sharing-facebook-4468658" class="share-facebook sd-button share-icon" href="https://www.embedded.com/why-automotive-ota-update-standards-are-essential/?share=facebook" target="_blank" title="Click to share on Facebook"><span>Facebook</span></a></li><li class="share-linkedin"><a rel="nofollow noopener noreferrer" data-shared="sharing-linkedin-4468658" class="share-linkedin sd-button share-icon" href="https://www.embedded.com/why-automotive-ota-update-standards-are-essential/?share=linkedin" target="_blank" title="Click to share on LinkedIn"><span>LinkedIn</span></a></li><li><a href="#" class="sharing-anchor sd-button share-more"><span>More</span></a></li><li class="share-end"></li></ul><div class="sharing-hidden"><div class="inner" style="display: none;"><ul><li class="share-reddit"><a rel="nofollow noopener noreferrer" data-shared="" class="share-reddit sd-button share-icon" href="https://www.embedded.com/why-automotive-ota-update-standards-are-essential/?share=reddit" target="_blank" title="Click to share on Reddit"><span>Reddit</span></a></li><li class="share-tumblr"><a rel="nofollow noopener noreferrer" data-shared="" class="share-tumblr sd-button share-icon" href="https://www.embedded.com/why-automotive-ota-update-standards-are-essential/?share=tumblr" target="_blank" title="Click to share on Tumblr"><span>Tumblr</span></a></li><li class="share-end"></li><li class="share-pinterest"><a rel="nofollow noopener noreferrer" data-shared="sharing-pinterest-4468658" class="share-pinterest sd-button share-icon" href="https://www.embedded.com/why-automotive-ota-update-standards-are-essential/?share=pinterest" target="_blank" title="Click to share on Pinterest"><span>Pinterest</span></a></li><li class="share-jetpack-whatsapp"><a rel="nofollow noopener noreferrer" data-shared="" class="share-jetpack-whatsapp sd-button share-icon" href="https://www.embedded.com/why-automotive-ota-update-standards-are-essential/?share=jetpack-whatsapp" target="_blank" title="Click to share on WhatsApp"><span>WhatsApp</span></a></li><li class="share-end"></li><li class="share-skype"><a rel="nofollow noopener noreferrer" data-shared="sharing-skype-4468658" class="share-skype sd-button share-icon" href="https://www.embedded.com/why-automotive-ota-update-standards-are-essential/?share=skype" target="_blank" title="Click to share on Skype"><span>Skype</span></a></li><li class="share-pocket"><a rel="nofollow noopener noreferrer" data-shared="" class="share-pocket sd-button share-icon" href="https://www.embedded.com/why-automotive-ota-update-standards-are-essential/?share=pocket" target="_blank" title="Click to share on Pocket"><span>Pocket</span></a></li><li class="share-end"></li><li class="share-telegram"><a rel="nofollow noopener noreferrer" data-shared="" class="share-telegram sd-button share-icon" href="https://www.embedded.com/why-automotive-ota-update-standards-are-essential/?share=telegram" target="_blank" title="Click to share on Telegram"><span>Telegram</span></a></li><li class="share-end"></li></ul></div></div></div></div></div>                    
            <div id="div-gpt-ad-native">
                <script type="text/javascript">
                    googletag.cmd.push(function() { googletag.display('div-gpt-ad-native'); });
                </script>
            </div>

            <div class="post-item-metadata entry-meta">
                <span class="tags-links">Tags: <a href="https://www.embedded.com/tag/automotive/" rel="tag">Automotive</a>, <a href="https://www.embedded.com/tag/design-methods/" rel="tag">Design Methods</a>, <a href="https://www.embedded.com/tag/integration/" rel="tag">Integration</a></span>            </div>

            

            <div style="text-align: center">
                <div id='div-gpt-ad-942957474691236830-3'>
                    <script type='text/javascript'>
                        googletag.cmd.push(function() { googletag.display('div-gpt-ad-942957474691236830-3'); });
                    </script>
                </div>
            </div>

            <div class="partial">
                <div id='div-gpt-ad-942957474691236830-42'>
                    <script type='text/javascript'>
                        googletag.cmd.push(function() { googletag.display('div-gpt-ad-942957474691236830-42'); });
                    </script>
                </div>
            </div>

                
	<nav class="navigation post-navigation" role="navigation" aria-label="Continue Reading">
		<h2 class="screen-reader-text">Continue Reading</h2>
		<div class="nav-links"><div class="nav-previous"><a href="https://www.embedded.com/software-testing-is-crucial-for-embedded-system-safety-and-security/" rel="prev"><span class="em-post-navigation">Previous</span> Software testing is crucial for embedded system safety and security</a></div><div class="nav-next"><a href="https://www.embedded.com/satellite-navigation-and-software-defined-radio/" rel="next"><span class="em-post-navigation">Next</span> Satellite navigation and Software Defined Radio</a></div></div>
	</nav>            </div><!-- .entry-content -->


                        </div>
												
<div id="comments" class="comments-area">

		<div id="respond" class="comment-respond">
		<h3 id="reply-title" class="comment-reply-title">Leave a Reply <small><a rel="nofollow" id="cancel-comment-reply-link" href="/why-automotive-ota-update-standards-are-essential/#respond" style="display:none;">Cancel reply</a></small></h3><p class="must-log-in">
			You must <a href="https://login.aspencore.com/d045a02d-767d-4f3f-80d7-695dce25d142/login/authorize?response_type=code&scope=profile%20email%20openid&client_id=216002e0-47e9-4d0c-8915-4dfcbabd2e56&state=02132b07edfb123d965e3ae90b944ef1&redirect_uri=https%3A%2F%2Fwww.embedded.com%2Fopenid-connect-authorize" class="openid_login">Sign in</a> or
			<a href="https://login.aspencore.com/d045a02d-767d-4f3f-80d7-695dce25d142/login/authorize?response_type=code&scope=profile%20email%20openid&client_id=216002e0-47e9-4d0c-8915-4dfcbabd2e56&state=4c0a1fe90deb641ed3c3f9801cf17bcc&redirect_uri=https%3A%2F%2Fwww.embedded.com%2Fopenid-connect-authorize" class="openid_login">Register</a> to post a comment.</p>	</div><!-- #respond -->
	<p class="akismet_comment_form_privacy_notice">This site uses Akismet to reduce spam. <a href="https://akismet.com/privacy/" target="_blank" rel="nofollow noopener">Learn how your comment data is processed</a>.</p>
</div><!-- #comments -->
                    </article>
				
            </main><!-- #main -->
        </div><!-- #primary -->
				
<aside id="secondary" class="widget-area aft-sticky-sidebar">
	<div id="custom_html-4" class="widget_text widget covernews-widget widget_custom_html"><div class="textwidget custom-html-widget"><div class="ads" style="text-align: center">
<div id='div-gpt-ad-942957474691236830-4'>
	
<script type='text/javascript'>
googletag.cmd.push(function() { 		  googletag.display('div-gpt-ad-942957474691236830-4'); });
</script>
</div>
</div>
</div></div><div id="custom_html-5" class="widget_text widget covernews-widget widget_custom_html"><div class="textwidget custom-html-widget"><div class="ads" style="text-align: center"><div id='div-gpt-ad-942957474691236830-5'>
		 <script type='text/javascript'>
			 googletag.cmd.push(function() { 
		  googletag.display('div-gpt-ad-942957474691236830-5'); });
		 </script>
	</div></div></div></div></aside><!-- #secondary -->
    </div>


    <!-- GPT AdSlot 1 for Ad unit 'emd' ### Size: [[3,3]] -->
    <div id='div-gpt-ad-3195781-1'>
        <script>
            googletag.cmd.push(function() { googletag.display('div-gpt-ad-3195781-1'); });
        </script>
    </div>
    <!-- End AdSlot 1 -->

    </div></div>
    <!--    </div>-->



</div>


<div class="af-main-banner-latest-posts grid-layout">
    <div class="container">
        <div class="row">

    <div class="widget-title-section">
                    <h4 class="widget-title header-after1">
                        <span class="header-after">

                            You may have missed                            </span>
            </h4>
        
    </div>
    <div class="row">
                <div class="col-sm-15 latest-posts-grid" data-mh="latest-posts-grid">
                <div class="spotlight-post">
                    <figure class="categorised-article inside-img">
                        <div class="categorised-article-wrapper">
                            <div class="data-bg data-bg-hover data-bg-categorised"
                                 data-background="https://www.embedded.com/wp-content/uploads/2020/12/12adi_sync_fig-11-7.jpg?w=675&#038;h=450&#038;crop=1">
                                <a href="https://www.embedded.com/power-up-phase-determinism-pll-synthesizer-and-system-level-calibration/"></a>
                            </div>
                        </div>
                                                <div class="figure-categories figure-categories-bg">
                            
                            <ul class="cat-links"><li class="meta-category">
                             <a class="covernews-categories category-color-1" href="https://www.embedded.com/category/technical-article/" alt="View all posts in Technical Article"> 
                                 Technical Article
                             </a>
                        </li></ul>                        </div>
                    </figure>

                    <figcaption>
                        
                        <h3 class="article-title article-title-1">
                            <a href="https://www.embedded.com/power-up-phase-determinism-pll-synthesizer-and-system-level-calibration/">
                                Power-up phase determinism: PLL synthesizer and system-level calibration                            </a>
                        </h3>
                        <div class="grid-item-metadata">
                            
        <span class="author-links">
                            <span class="item-metadata posts-date">
                <i class="far fa-clock"></i>
                    December 22, 2020            </span>
            			
                <span class="item-metadata posts-author">

                    	                    <a href="https://www.embedded.com/author/embedded-staff/" title="Posts by Mike Jones, Michael Hennerich, and Pete Delos" class="author url fn" rel="author">Mike Jones, Michael Hennerich, and Pete Delos</a>                            </span>
			        </span>
		                        </div>
                    </figcaption>
                </div>
            </div>
                    <div class="col-sm-15 latest-posts-grid" data-mh="latest-posts-grid">
                <div class="spotlight-post">
                    <figure class="categorised-article inside-img">
                        <div class="categorised-article-wrapper">
                            <div class="data-bg data-bg-hover data-bg-categorised"
                                 data-background="https://www.embedded.com/wp-content/uploads/2020/12/pv-gnss-graphic.png?w=675&#038;h=450&#038;crop=1">
                                <a href="https://www.embedded.com/satellite-navigation-and-software-defined-radio/"></a>
                            </div>
                        </div>
                                                <div class="figure-categories figure-categories-bg">
                            
                            <ul class="cat-links"><li class="meta-category">
                             <a class="covernews-categories category-color-1" href="https://www.embedded.com/category/blog/" alt="View all posts in Blog"> 
                                 Blog
                             </a>
                        </li></ul>                        </div>
                    </figure>

                    <figcaption>
                        
                        <h3 class="article-title article-title-1">
                            <a href="https://www.embedded.com/satellite-navigation-and-software-defined-radio/">
                                Satellite navigation and Software Defined Radio                            </a>
                        </h3>
                        <div class="grid-item-metadata">
                            
        <span class="author-links">
                            <span class="item-metadata posts-date">
                <i class="far fa-clock"></i>
                    December 21, 2020            </span>
            			
                <span class="item-metadata posts-author">

                    	                    <a href="https://www.embedded.com/author/embedded-staff/" title="Posts by Victor Wollesen" class="author url fn" rel="author">Victor Wollesen</a>                            </span>
			        </span>
		                        </div>
                    </figcaption>
                </div>
            </div>
                    <div class="col-sm-15 latest-posts-grid" data-mh="latest-posts-grid">
                <div class="spotlight-post">
                    <figure class="categorised-article inside-img">
                        <div class="categorised-article-wrapper">
                            <div class="data-bg data-bg-hover data-bg-categorised"
                                 data-background="https://www.embedded.com/wp-content/uploads/2020/12/img20201221113924NXP-s-4D-Imaging-Radars-Offer-_1.jpg?w=675&#038;h=450&#038;crop=1">
                                <a href="https://www.embedded.com/4d-imaging-radar-chipsets-enhance-object-identification/"></a>
                            </div>
                        </div>
                                                <div class="figure-categories figure-categories-bg">
                            
                            <ul class="cat-links"><li class="meta-category">
                             <a class="covernews-categories category-color-1" href="https://www.embedded.com/category/news/" alt="View all posts in News"> 
                                 News
                             </a>
                        </li></ul>                        </div>
                    </figure>

                    <figcaption>
                        
                        <h3 class="article-title article-title-1">
                            <a href="https://www.embedded.com/4d-imaging-radar-chipsets-enhance-object-identification/">
                                4D imaging radar chipsets enhance object identification                            </a>
                        </h3>
                        <div class="grid-item-metadata">
                            
        <span class="author-links">
                            <span class="item-metadata posts-date">
                <i class="far fa-clock"></i>
                    December 19, 2020            </span>
            			
                <span class="item-metadata posts-author">

                    	                    <a href="https://www.embedded.com/author/junko-yoshida/" title="Posts by Junko Yoshida" class="author url fn" rel="author">Junko Yoshida</a>                            </span>
			        </span>
		                        </div>
                    </figcaption>
                </div>
            </div>
                    <div class="col-sm-15 latest-posts-grid" data-mh="latest-posts-grid">
                <div class="spotlight-post">
                    <figure class="categorised-article inside-img">
                        <div class="categorised-article-wrapper">
                            <div class="data-bg data-bg-hover data-bg-categorised"
                                 data-background="https://www.embedded.com/wp-content/uploads/2020/12/img20201222120007Automotive-OTA-Updates-Must-Be-S_0.jpg?w=675&#038;h=450&#038;crop=1">
                                <a href="https://www.embedded.com/why-automotive-ota-update-standards-are-essential/"></a>
                            </div>
                        </div>
                                                <div class="figure-categories figure-categories-bg">
                            
                            <ul class="cat-links"><li class="meta-category">
                             <a class="covernews-categories category-color-1" href="https://www.embedded.com/category/blog/" alt="View all posts in Blog"> 
                                 Blog
                             </a>
                        </li></ul>                        </div>
                    </figure>

                    <figcaption>
                        
                        <h3 class="article-title article-title-1">
                            <a href="https://www.embedded.com/why-automotive-ota-update-standards-are-essential/">
                                Why automotive OTA update standards are essential                            </a>
                        </h3>
                        <div class="grid-item-metadata">
                            
        <span class="author-links">
                            <span class="item-metadata posts-date">
                <i class="far fa-clock"></i>
                    December 18, 2020            </span>
            			
                <span class="item-metadata posts-author">

                    	                    <a href="https://www.embedded.com/author/embedded-staff/" title="Posts by Mike Gardner" class="author url fn" rel="author">Mike Gardner</a>                            </span>
			        </span>
		                        </div>
                    </figcaption>
                </div>
            </div>
                    <div class="col-sm-15 latest-posts-grid" data-mh="latest-posts-grid">
                <div class="spotlight-post">
                    <figure class="categorised-article inside-img">
                        <div class="categorised-article-wrapper">
                            <div class="data-bg data-bg-hover data-bg-categorised"
                                 data-background="https://www.embedded.com/wp-content/uploads/2020/12/img20201221115038Why-and-when-software-testing-ma_1.jpg?w=675&#038;h=450&#038;crop=1">
                                <a href="https://www.embedded.com/software-testing-is-crucial-for-embedded-system-safety-and-security/"></a>
                            </div>
                        </div>
                                                <div class="figure-categories figure-categories-bg">
                            
                            <ul class="cat-links"><li class="meta-category">
                             <a class="covernews-categories category-color-1" href="https://www.embedded.com/category/blog/" alt="View all posts in Blog"> 
                                 Blog
                             </a>
                        </li></ul>                        </div>
                    </figure>

                    <figcaption>
                        
                        <h3 class="article-title article-title-1">
                            <a href="https://www.embedded.com/software-testing-is-crucial-for-embedded-system-safety-and-security/">
                                Software testing is crucial for embedded system safety and security                            </a>
                        </h3>
                        <div class="grid-item-metadata">
                            
        <span class="author-links">
                            <span class="item-metadata posts-date">
                <i class="far fa-clock"></i>
                    December 17, 2020            </span>
            			
                <span class="item-metadata posts-author">

                    	                    <a href="https://www.embedded.com/author/mark-pitchford/" title="Posts by Mark Pitchford" class="author url fn" rel="author">Mark Pitchford</a>                            </span>
			        </span>
		                        </div>
                    </figcaption>
                </div>
            </div>
                </div>
    </div>
    </div>
</div>

<footer class="site-footer">
    
    <div class="primary-footer">
        

        <div class="container layout-footer">
            <!--                <div class="row">-->
            <!--                    <div class="col-sm-12">-->

            <div class="footerBlock-title">Aspencore Network</div>
            <div class="aspencoreNetwork-column segment-one">
                <!--PRODUCTS-->
                <div class="footerBlock-subtitle">Products:</div>
                <ul class="footerBlock-list">
                    <li class="footerBlock-item">
                        <a target="_blank" href="https://www.electronicproducts.com/"
                           class="footerblock-link">Electronic Products</a>
                    </li>
                    <li class="footerBlock-item">
                        <a target="_blank" href="https://www.datasheets.com/" class="footerblock-link">Datasheets.com</a>
                    </li>
                    <li class="footerBlock-item">
                        <a target="_blank" href="https://www.eem.com/" class="footerblock-link">EEM.com</a>
                    </li>
                    <li class="footerBlock-item">
                        <a target="_blank" href="https://www.techonline.com/" class="footerblock-link">TechOnline</a>
                    </li>
                </ul>
            </div><!--end .aspencoreNetwork-column segment-one-->


            <!--NEWS & ANALYSIS-->
            <div class="aspencoreNetwork-column segment-two">
                <div class="footerBlock-subtitle">News &amp; Analysis:</div>
                <ul class="footerBlock-list">
                    <li class="footerBlock-item">
                        <a target="_blank" href="https://www.eetimes.com/" class="footerblock-link">EE
                            Times</a>
                    </li>
                    <li class="footerBlock-item">
                        <a target="_blank" href="https://www.eetimes.eu/" class="footerblock-link">EE Times
                            Europe</a>
                    </li>
                    <li class="footerBlock-item">
                        <a target="_blank" href="https://www.powerelectronicsnews.com/"
                           class="footerblock-link">Power Electronics News</a>
                    </li>
                    <li class="footerBlock-item">
                        <a target="_blank" href="https://www.ebnonline.com/"
                           class="footerblock-link">EBN</a>
                    </li>
                    <li class="footerBlock-item">
                        <a target="_blank" href="https://www.elektroda.pl/" class="footerblock-link">Elektroda.pl</a>
                    </li>
                </ul>
            </div><!--end .aspencoreNetwork-column segment-two-->


            <!--DESIGN-->
            <div class="aspencoreNetwork-column segment-three">
                <div class="footerBlock-subtitle">Design:</div>
                <ul class="footerBlock-list">
                    <li class="footerBlock-item">
                        <a target="_blank" href="https://www.edn.com/" class="footerblock-link">EDN</a>
                    </li>
                    <li class="footerBlock-item">
                        <a target="_blank" href="https://www.electroschematics.com/"
                           class="footerblock-link">Electroschematics</a>
                    </li>
                    <li class="footerBlock-item">
                        <a target="_blank" href="https://www.electronics-tutorials.ws/"
                           class="footerblock-link">Electronics-Tutorials</a>
                    </li>
                    <li class="footerBlock-item">
                        <a target="_blank" href="https://www.planetanalog.com/" class="footerblock-link">Planet
                            Analog</a>
                    </li>
                    <li class="footerBlock-item">
                        <a target="_blank" href="https://embedded.com/" class="footerblock-link">Embedded</a>
                    </li>
                    <li class="footerBlock-item">
                        <a target="_blank" href="http://electronics-know-how.com/" class="footerblock-link">Electronics
                            Know How</a>
                    </li>
                </ul>
            </div><!--end .aspencoreNetwork-column segment-three-->


            <!--TOOLS-->
            <div class="aspencoreNetwork-column segment-four">
                <div class="footerBlock-subtitle">Tools:</div>
                <ul class="footerBlock-list">
                    <li class="footerBlock-item">
                        <a target="_blank" href="https://www.eeweb.com/" class="footerblock-link">EEWEB</a>
                    </li>
                    <li class="footerBlock-item">
                        <a target="_blank" href="https://www.partsim.com/"
                           class="footerblock-link">PartSim</a>
                    </li>
                    <!--<li class="footerBlock-item"><a target="_blank"  href="https://www.orderpcbs.com/" class="footerblock-link">OrderPCBs</a> </li>-->
                    <li class="footerBlock-item">
                        <a target="_blank" href="https://www.pcbweb.com/" class="footerblock-link">PCBWeb</a>
                    </li>
                    <li class="footerBlock-item">
                        <a target="_blank" href="https://www.transim.com/iot/" class="footerblock-link">Product
                            Advisor</a>
                    </li>
                    <li class="footerBlock-item">
                        <a target="_blank" href="https://schematics.com/" class="footerblock-link">Schematics.com</a>
                    </li>
                    <li class="footerBlock-item">
                        <a target="_blank" href="https://www.schematics.io/" class="footerblock-link">Schematics.io</a>
                    </li>
                    <li class="footerBlock-item">
                        <a target="_blank" href="https://www.transim.com/Products/Engage"
                           class="footerblock-link">Engage</a>
                    </li>
                </ul>
            </div><!--end .aspencoreNetwork-column segment-four-->


            <!--GLOBAL NETWORK-->
            <div class="globalNetwork segment-five">
                <div class="footerBlock-title">Global Network</div>
                <ul class="footerBlock-list">
                    <li class="footerBlock-item">
                        <a target="_blank" href="https://www.eetasia.com/" class="footerblock-link">EE Times
                            Asia</a>
                    </li>
                    <li class="footerBlock-item">
                        <a target="_blank" href="https://www.eet-china.com/" class="footerblock-link">EE
                            Times China</a>
                    </li>
                    <li class="footerBlock-item">
                        <a target="_blank" href="https://www.eetindia.co.in/" class="footerblock-link">EE
                            Times India</a>
                    </li>
                    <li class="footerBlock-item">
                        <a target="_blank" href="https://www.eettaiwan.com/" class="footerblock-link">EE
                            Times Taiwan</a>
                    </li>
                    <li class="footerBlock-item">
                        <a target="_blank" href="https://eetimes.jp/" class="footerblock-link">EE Times
                            Japan </a>
                    </li>
                    <li class="footerBlock-item">
                        <a target="_blank" href="https://www.ednasia.com/" class="footerblock-link">EDN
                            Asia</a>
                    </li>
                    <li class="footerBlock-item">
                        <a target="_blank" href="https://www.edntaiwan.com/" class="footerblock-link">EDN
                            Taiwan</a>
                    </li>
                    <li class="footerBlock-item">
                        <a target="_blank" href="https://www.esmchina.com/" class="footerblock-link">ESM
                            China</a>
                    </li>
                    <li class="footerBlock-item">
                        <a target="_blank" href="https://www.ednchina.com/" class="footerblock-link">EDN
                            China</a>
                    </li>
                    <li class="footerBlock-item">
                        <a target="_blank" href="https://ednjapan.com/" class="footerblock-link">EDN
                            Japan</a>
                    </li>
                </ul>
            </div><!--end .globalNetwork segment-five-->


            <!--FOR ADVERTISERS-->
            <div class="forAdvertisers segment-six">
                <div class="footerBlock-title">For Advertisers</div>
                <ul class="footerBlock-list">
                    <li class="footerBlock-item">
                        <a target="_blank" href="https://aspencore.com/contact-us/"
                           class="footerblock-link">Contact Sales</a>
                    </li>
                    <li class="footerBlock-item">
                        <a target="_blank" href="https://aspencore.com/media-guide-request/"
                           class="footerblock-link">Media Guide Request</a>
                    </li>
                </ul>
            </div><!--end .forAdvertisers segment-six-->


            <!--CONNECT WITH US-->
            <div class="connectWithUs segment-seven">
                <div class="footerBlock-title">Connect with us</div>
                <ul class="footerBlock-list">


                    <!--FACEBOOK-->
                    <!--<li class="footerBlock-item">
                      <div class="SocialIconFooterA">
                       <img src="/wp-content/uploads/facebook-footer-icon.png">
                      </div>--><!--end .SocialIconFooter-->

                    <!--<a target="_blank" href="https://www.facebook.com/pages/Planet-Analog/183866588420815" class="footerblock-link">
                    Facebook</a>
            </li>-->

                    <!--TWITTER-->
                    <li class="footerBlock-item">
                        <div class="SocialIconFooterB">
                            <img src="/wp-content/themes/embedded/img/twitter-footer-icon.png">
                        </div><!--end .SocialIconFooter-->

                        <a target="_blank" href="https://twitter.com/embedded_com"
                           class="footerblock-link"> Twitter </a>
                    </li>


                </ul><!--end ul.footerBlock-list-->
            </div><!--end .connectWithUs segment-seven-->


            <!--ASPENCORE LOGO-->
            <a href="http://www.aspencore.com/">
                <div class="aspencoreLogo">
                    <svg class="aspencoreLogo-svg" xmlns="http://www.w3.org/2000/svg" viewBox="0 0 282 28">
                        <path d="M203.92 2.36l.19-.1zM52 6.66a6 6 0 0 0-1.11-.91 11.11 11.11 0 0 0-1.7-.91 12.66 12.66 0 0 0-2.16-.7 11.76 11.76 0 0 0-2.51-.27 6.17 6.17 0 0 0-3.82 1 3.36 3.36 0 0 0-1 1.25 3.29 3.29 0 0 0-.31 1.58 2.88 2.88 0 0 0 .42 1.64 3.39 3.39 0 0 0 1.25 1.1 10 10 0 0 0 2.1.85c.83.25 1.82.52 2.93.8 1.32.36 2.54.73 3.64 1.12a10.38 10.38 0 0 1 2.83 1.45 6 6 0 0 1 1.82 2.15 6.94 6.94 0 0 1 .7 3.19 7.83 7.83 0 0 1-.8 3.69 7 7 0 0 1-2.16 2.45A9.44 9.44 0 0 1 49 27.53a15.33 15.33 0 0 1-3.82.42 18.87 18.87 0 0 1-6-.95 16.66 16.66 0 0 1-5.23-2.77l2-3.71a9 9 0 0 0 1.41 1.12 12.37 12.37 0 0 0 2.16 1.14 17.76 17.76 0 0 0 2.73.89 12.46 12.46 0 0 0 3.1.37 6.78 6.78 0 0 0 3.8-.91 2.93 2.93 0 0 0 1-1.14 3 3 0 0 0 .33-1.51 2.9 2.9 0 0 0-.5-1.74 4.12 4.12 0 0 0-1.43-1.23 12.4 12.4 0 0 0-2.34-.93c-.91-.28-2-.57-3.13-.87a31 31 0 0 1-3.53-1.15A8.7 8.7 0 0 1 37 13.11a5.66 5.66 0 0 1-1.5-2 6.57 6.57 0 0 1-.5-2.76 8.29 8.29 0 0 1 .74-3.57 7.56 7.56 0 0 1 2.06-2.63A9.27 9.27 0 0 1 40.92.54 13.22 13.22 0 0 1 44.77 0a14.34 14.34 0 0 1 5.14.89A16.7 16.7 0 0 1 54 3.09zm15.78 21V.19h11.43a7.47 7.47 0 0 1 3.38.81 8.64 8.64 0 0 1 2.65 2A9.8 9.8 0 0 1 87 5.86a8.73 8.73 0 0 1 .63 3.27 9.62 9.62 0 0 1-2.23 6.22 8 8 0 0 1-2.59 2 7.2 7.2 0 0 1-3.34.76H72.1v9.57zm4.28-13.4h7.07a3.48 3.48 0 0 0 1.67-.39 3.81 3.81 0 0 0 1.28-1.08 5.26 5.26 0 0 0 .92-1.6 6.75 6.75 0 0 0 .31-2 6 6 0 0 0-.35-2.09 5 5 0 0 0-1-1.61 4.45 4.45 0 0 0-1.4-1A3.8 3.8 0 0 0 79 4h-6.9zm45.7 9.58v3.82H99.19V.19h18.26V4h-14v7.84h12.11v3.6h-12.09v8.42zM134.3 8.32v19.37H130V.19h3.35L148.88 20V.23h4.32v27.46h-3.55zm30.23 5.46a14.37 14.37 0 0 1 .88-4.94A14 14 0 0 1 168 4.43a12.71 12.71 0 0 1 4-3.16 12.07 12.07 0 0 1 5.44-1.2 11.38 11.38 0 0 1 6.25 1.67 10.54 10.54 0 0 1 3.92 4.34l-3.35 2.28a7 7 0 0 0-3.08-3.45 6.88 6.88 0 0 0-1.93-.71 9.1 9.1 0 0 0-1.92-.2 7.33 7.33 0 0 0-3.64.84 8.19 8.19 0 0 0-2.69 2.3 10.3 10.3 0 0 0-1.61 3.21 12.35 12.35 0 0 0-.53 3.57 11.45 11.45 0 0 0 .63 3.81 10.54 10.54 0 0 0 1.8 3.27 9.13 9.13 0 0 0 2.71 2.18 7.36 7.36 0 0 0 3.44.85 8.44 8.44 0 0 0 2-.26 6.89 6.89 0 0 0 2-.81 8.15 8.15 0 0 0 1.74-1.41 7.33 7.33 0 0 0 1.34-2.05l3.55 2.05a8.39 8.39 0 0 1-1.81 2.74 11.37 11.37 0 0 1-2.62 2A13.15 13.15 0 0 1 177.3 28a10.93 10.93 0 0 1-5.16-1.23 13.87 13.87 0 0 1-4-3.24 15.13 15.13 0 0 1-3.57-9.7zm67.84 13.91V.19h11.81a7.47 7.47 0 0 1 3.38.77 8.8 8.8 0 0 1 2.66 2 9.77 9.77 0 0 1 1.78 2.9 8.94 8.94 0 0 1 .64 3.27 9.32 9.32 0 0 1-1.44 5 7.5 7.5 0 0 1-1.67 1.88 7 7 0 0 1-2.18 1.18l6.43 10.46h-4.85l-6-9.57h-6.28v9.57zm4.28-13.4h7.49a3.41 3.41 0 0 0 1.68-.42 4 4 0 0 0 1.25-1.13 5.54 5.54 0 0 0 .84-1.64 6.06 6.06 0 0 0 .3-2 5.13 5.13 0 0 0-.36-2 5.67 5.67 0 0 0-.95-1.63 4.6 4.6 0 0 0-1.38-1.1A3.4 3.4 0 0 0 243.9 4h-7.25zM282 23.87v3.82h-18.61V.19h18.26V4h-14v7.84h12.11v3.6h-12.09v8.42zM14.44.2h-3.51L0 27.69h4.58l8.1-20.88 8.1 20.88h4.55zM209.61 0a13.66 13.66 0 0 0-7.67 2.36 14 14 0 0 0-5.09 6.28 14.16 14.16 0 0 0-.78 8.09 14 14 0 0 0 3.78 7.17 13.72 13.72 0 0 0 21.25-2.12 14.14 14.14 0 0 0-1.72-17.68 13.7 13.7 0 0 0-9.77-4.1zm0 24a9.82 9.82 0 0 1-5.49-1.69 9.92 9.92 0 0 1-3.64-4.5 10.11 10.11 0 0 1 2.14-10.93 9.92 9.92 0 0 1 5.07-2.74 9.79 9.79 0 0 1 5.71.57 9.89 9.89 0 0 1 4.44 3.7 10.09 10.09 0 0 1 .91 9.4 9.89 9.89 0 0 1-5.35 5.43 9.86 9.86 0 0 1-3.79.76z"></path>
                    </svg>
                </div><!--end .aspencoreLogo-->
            </a>
        </div><!--end .container layout-footer-->


        <!--            </div>-->
        <!--        </div>-->
        <!--        </div>-->


    </div>

    

    <div class="site-info">
        <div class="container">
            <div class="legalFooter">
                <div class="legalFooter-copyright">
                                                                Copyright &copy; All rights reserved.                    
                                                                <span class="sep"> | </span>
                        <a href="https://www.embedded.com/">Embedded</a> by AspenCore.                                    </div>
                <div class="legalFooter-links">
                                            <!--                        <div class="--><!--">-->
                        <!--                            <div class="footer-nav-wrapper">-->
                        <div class="footer-navigation"><ul id="footer-menu" class="menu"><li id="menu-item-4462716" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-4462716"><a target="_blank" rel="noopener" href="https://aspencore.com/privacy-policy/">Privacy Policy</a></li>
<li id="menu-item-4462717" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-4462717"><a target="_blank" rel="noopener" href="https://aspencore.com/terms-of-use/">Terms of Use</a></li>
<li id="menu-item-4462720" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-4462720"><a href="https://www.embedded.com/contact-us/">Contact Us</a></li>
<li id="menu-item-4466570" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-4466570"><a href="https://aspencore.dragonforms.com/loading.do?omedasite=dns">California Do Not Sell</a></li>
<li class ="jan-button"><div class="openid-connect-login-button"><a href="https://login.aspencore.com/d045a02d-767d-4f3f-80d7-695dce25d142/login/authorize?response_type=code&scope=profile%20email%20openid&client_id=216002e0-47e9-4d0c-8915-4dfcbabd2e56&state=5c5014ddcecbae0237318fba6909d975&redirect_uri=https%3A%2F%2Fwww.embedded.com%2Fopenid-connect-authorize">Login</a></div></li></ul></div>                        <!--                            </div>-->
                        <!--                        </div>-->
                                    </div>
            </div>
        </div>
    </div>
</footer>
</div>
<a id="scroll-up" class="secondary-color">
    <i class="fa fa-angle-up"></i>
</a>
<script type='text/javascript'>
janrain.settings.borderColor = '#ffffff';
janrain.settings.fontFamily = 'Helvetica, Lucida Grande, Verdana, sans-serif';
janrain.settings.width = 300;
janrain.settings.actionText = ' ';
janrain.settings.capture.modalCloseHtml = 'X';
janrain.settings.capture.noModalBorderInlineCss = true;

janrain.settings.capture.flowName = 'aspencore';
</script>
  <!--
    ============================================================================
        A NOTE ON NAVIGATION:
        These links are not needed for integration into your site. These links
        are only used for navigating the reference implementation that exists on
        our servers for testing/demo/sample purposes. It is not required for
        your implementation.

        Here you can see an example of using janrain.capture.ui.renderScreen in
        conjunction with HTML elements to simplify user navigation.
    ============================================================================
    -->




    <!--
    ============================================================================
        A NOTE ON NAVIGATION:
        These links are not needed for integration into your site. These links
        are only used for navigating the reference implementation that exists on
        our servers for testing/demo/sample purposes. It is not required for
        your implementation.

        Here you can see an example of using janrain.capture.ui.renderScreen in
        conjunction with HTML elements to simplify user navigation.
    ============================================================================
    
    <a href="#" id="captureSignInLink" onclick="janrain.capture.ui.renderScreen('signIn')">Sign In / Sign Up</a>
    <a href="edit-profile.html?screenToRender=editProfile" id="captureProfileLink" style="display:none">Edit Profile</a>
    <a href="#" id="captureSignOutLink" style="display:none" onclick="janrain.capture.ui.endCaptureSession()">Sign Out</a>
-->



    <!--
    ============================================================================
        SIGNIN SCREENS:
        The following screens are part of the sign in user workflow. For a
        complete out-of-the-box sign in experience, these screens must be
        included on the page where you are implementing sign in and registration.
    ============================================================================
    -->

    <!-- signIn:
    This is the starting point for sign in and registration. This screen is
    rendered by default. In order to change this behavior, the Flow must be
    edited.
    -->
    <div style="display:none;" id="signIn">
        <div class="capture_header">
            <h1>Sign Up / Sign In</h1>
        </div>
       
        <div class="capture_backgroundColor">
            <div class="capture_signin">
                <h2>With a traditional account...</h2>
                {* #signInForm *}
                    {* signInEmailAddress *}
                    {* currentPassword *}
                    <div class="capture_form_item">
                        <a href="#" data-capturescreen="forgotPassword">Forgot your password?</a>
                    </div>
                    <div class="capture_rightText">
                        <button class="capture_secondary capture_btn capture_primary" type="submit"><span class="janrain-icon-16 janrain-icon-key"></span> Sign In</button>
                        <a href="#" id="capture_signIn_createAccountButton" data-capturescreen="traditionalRegistration" class="capture_secondary capture_createAccountButton capture_btn capture_primary">Create Account</a>
                        <div class="serviceMarks">
                            {* poweredByJanrain *}
                            <div id="adfdcb81-3fcc-4e89-807b-a54a89fab74d">
                                <script type="text/javascript" src="//privacy-policy.truste.com/privacy-seal/Janrain,-Inc-/asc?rid=adfdcb81-3fcc-4e89-807b-a54a89fab74d"></script>
                                <a href="//privacy.truste.com/privacy-seal/Janrain,-Inc-/validation?rid=1b233149-fc3b-4e69-957a-ca7677ee4787" title="TRUSTe Privacy, Trusted Cloud, European Safe Harbor certification" target="_blank"><img style="border: none" src="//privacy-policy.truste.com/privacy-seal/Janrain,-Inc-/seal?rid=7bc0f34d-9cf2-427d-af9e-15e2fc354825" alt="TRUSTe European Safe Harbor certification"/></a>
                            </div>
                        </div>
                    </div>
                {* /signInForm *}
            </div>
        </div>
    </div>

    <!-- returnSocial:
    This is the screen the user sees in place of the signIn screen if they've
    already signed in with a social account on this site. Rendering of this
    screen is defined in the Flow only when the 'janrainLastAuthMethod' cookie
    is set to'socialSignin'.
    -->
    <div style="display:none;" id="returnSocial">
        <div class="capture_header">
            <h1>Sign In</h1>
        </div>
        <div class="capture_signin">
            <h2>Welcome back, {* welcomeName *}!</h2>
            {* loginWidget *}
            <div class="capture_centerText switchLink"><a href="#" data-cancelcapturereturnexperience="true">Use another account</a></div>
        </div>
    </div>

    <!-- returnTraditional:
    This is the screen the user sees in place of the signIn screen if they've
    already signed in with a traditional account on this site. Rendering of this
    screen is defined in the Flow only when the 'janrainLastAuthMethod' cookie
    is set to'traditionalSignin'.
    -->
    <div style="display:none;" id="returnTraditional">
        <div class="capture_header">
            <h1>Sign In</h1>
        </div>
        <h2 class="capture_centerText"><span id="traditionalWelcomeName">Welcome Back</span></h2>
        <div class="capture_backgroundColor">
            {* #signInForm *}
                {* signInEmailAddress *}
                {* currentPassword *}
                <div class="capture_form_item capture_rightText">
                    <button class="capture_secondary capture_btn capture_primary" type="submit"><span class="janrain-icon-16 janrain-icon-key"></span> Sign In</button>
                </div>
            {* /signInForm *}
            <div class="capture_centerText switchLink"><a href="#" data-cancelcapturereturnexperience="true">Use another account</a></div>
        </div>
    </div>

    <!-- accountDeactivated:
        This screen is rendered if the user's account is deactivated. Screen
        rendering is handled in janrain-init.js.
    -->
    <div style="display:none;" id="accountDeactivated">
        <div class="capture_header">
            <h1>Account Deactivated</h1>
        </div>
        <div class="content_wrapper">
            <p>Your account has been deactivated.</p>
        </div>
    </div>

    <div style="display:none;" id="reactivateAccount">    
        <h2>Account Reactivation Failed</h2> 
        <p>Sorry, we could not verify that email address.</p>   
    </div>

    <div style="display: none;" id="reactivateAccountSuccess">    
        <h2>Account Activated</h2>    
        <p>Your account has been reactivated.</p>
        <div class="capture_footer">
            <a href="index.html" class="capture_btn capture_primary">Sign in</a>
        </div>       
    </div>


    <!-- emailVerificationRequired:
        This screen is rendered if you have enabled the requirement for verified emails and the user's email has not yet been verified. This screen may appear immediately after registration and also on subsequent logins until the email is verified. Screen rendering is handled in the postLoginScreens Capture settings per API client. A value of "emailVerificationRequired" will enable the requirement of having a verified email. A value of "false" will disable the requirement of having a verified email.
    -->
    <div style="display:none;" id="emailVerificationRequired">
        <div class="capture_header">
            <h1>Email Verification Required</h1>
        </div>
        <p>You must verify your email address before signing in. Check your email for your verification email, or enter your email address in the form below to resend the email.</p>

        {* #resendVerificationForm *}
            {* signInEmailAddress *}
            <div class="capture_footer">
                <input value="Submit" type="submit" class="capture_btn capture_primary">
            </div>
        {* /resendVerificationForm *}
    </div>


    <!--
    ============================================================================
        REGISTRATION SCREENS:
        The following screens are part of the registration user workflow. For a
        complete out-of-the-box registration experience, these screens must be
        included on the page where you are implementing sign in and
        registration.
    ============================================================================
    -->

    <!-- socialRegistration:
        When a user clicks an IDP and does not already have an account in your
        capture application, this screen is rendered. This behavior is defined
        in the Flow.
    -->
    <div style="display:none;" id="socialRegistration">
        <div class="capture_header">
            <h1>Almost Done</h1>
        </div>
        <h2>Please confirm the information below before signing in.</h2>
        {* #socialRegistrationForm *}
            <!-- The following fields are required by default and must be included in the socialRegistrationForm. In order to change any of these fields to optional, the Flow must be edited. -->
            {* firstName *}
            {* lastName *}
            {* displayName *}
            {* emailAddress *}
            <!-- The following fields are optional and may be uncommented if you wish to collect any of these fields via the socialRegistrationForm. In order to change any of these fields to required, the Flow must be edited. 
            {* middleName *}
            {* gender *}
            {* birthdate *}
            {* phone *}
            {* mobile *}
            {* addressStreetAddress1 *}
            {* addressStreetAddress2 *}
            {* addressCity *}
            {* addressPostalCode *}
            {* addressState *}
            {* addressCountry *}
            {* optInRegistration *}
            -->
            By clicking "Sign In", you confirm that you accept our <a href="#">terms of service</a> and have read and understand <a href="#">privacy policy</a>.
            <div class="capture_footer">
                <div class="capture_left">
                    {* backButton *}
                </div>
                <div class="capture_right">
                    <input value="Create Account" type="submit" class="capture_btn capture_primary">
                </div>
            </div>
        {* /socialRegistrationForm *}
    </div>

    <!-- traditionalRegistration:
        When a user clicks the 'Create Account' button this screen is rendered.
    -->
    <div style="display:none;" id="traditionalRegistration">
        <div class="capture_header">
            <h1>Almost Done</h1>
        </div>
        <p>Please confirm the information below before signing in. Already have an account? <a id="capture_traditionalRegistration_navSignIn" href="#" data-capturescreen="signIn">Sign In.</a></p>
        {* #registrationForm *}
            <!-- The following fields are required by default and must be included in the registrationForm. In order to change any of these fields to optional, the Flow must be edited. -->
            {* emailAddress *}
            {* newPassword *}
            {* newPasswordConfirm *}
            {* displayName *}
            {* jobTitle *}
            {* firstName *}
            {* lastName *}
            {* ednembJobfunction  *}
            {* jobFunctionOther *}
            {* ednembIndustry  *}
            {* industryOther *} 
            {* linkedinProfileName *}
            {* twitterProfileName *}
            {* companyName *}
            {* addressStreetAddress1 *}
            {* addressStreetAddress2 *}
            {* addressCountry *}
            {* addressState *}
            {* addressStateText *}
            {* addressCity *}
            {* addressPostalCode *}
            {* phone *}
            {* optInRegistration *}
            {* optAgree *}
            {* optShare *}
            {* applicationAndTech_analog *}
            {* applicationAndTech_power *}
            {* applicationAndTech_memory *}
            {* applicationAndTech_programmableLogic *}
            {* applicationAndTech_computingGraphics *}
            {* applicationAndTech_entertainment *}
            {* applicationAndTech_networking *}
            {* applicationAndTech_testAndMeasurement *}
            {* applicationAndTech_electromechanicalComponents *}
            {* applicationAndTech_connectorsInterconnects *}
            {* applicationAndTech_rfOrMicrowave *}
            {* applicationAndTech_microprocessorsMicrocontrollersSignal *}
            {* applicationAndTech_icDesignTools *}
            {* applicationAndTech_embeddedDevelopmentTools *}
            {* applicationAndTech_controlSystems *}
            {* applicationAndTech_mobileDevices *}
            {* applicationAndTech_safetySecurity *}
            {* applicationAndTech_passiveComponents *} 
            By clicking "Create Account", you confirm that you accept our <a href="#">terms of service</a> and have read and understand <a href="#">privacy policy</a>.
            <div class="capture_footer">
                <div class="capture_left">
                    {* backButton *}
                </div>
                <div class="capture_right">
                    <input value="Create Account" type="submit" class="capture_btn capture_primary">
                </div>
            </div>
        {* /registrationForm *}
    </div>

    <!-- emailVerificationNotification:
        This screen is rendered after a user has registered. In the case of
        traditional registration, this screen is always rendered after the user
        completes registration on the traditionalRegistration screen. In the
        case of social registration, this screen is only rendered if the data
        returned from the IDP does not contain a verified email address.
        Twitter is an example of an IDP that does not return a verified email.
    -->
    <div style="display:none;" id="emailVerificationNotification">
        <div class="capture_header">
            <h1>Thank You for Registering</h1>
        </div>
        <p>We have sent a confirmation email to {* emailAddressData *}. Please check your email and click on the link to verify your email address.</p>
        <div class="capture_footer">
            <a href="#" onclick="janrain.capture.ui.modal.close()" class="capture_btn capture_primary">Close</a>
        </div>
    </div>




    <!--
    ============================================================================
        FORGOT PASSWORD SCREENS:
        The following screens are part of the forgot password user workflow. For
        a complete out-of-the-box registration experience, these screens must be
        included on the page where you are implementing forgot password
        functionality.
    ============================================================================
    -->

    <!-- forgotPassword:
        Entry point into the forgot password user workflow. This screen is
        rendered when the user clicks on the 'Forgot your password?' link on the
        signIn screen.
    -->
    <div style="display:none;" id="forgotPassword">
        <div class="capture_header">
            <h1>Create New Password</h1>
        </div>
        <h2>We'll send you a link to create a new password.</h2>
        {* #forgotPasswordForm *}
            {* signInEmailAddress *}
            <div class="capture_footer">
                <div class="capture_left">
                    {* backButton *}
                </div>
                <div class="capture_right">
                    <input value="Send" type="submit" class="capture_btn capture_primary">
                </div>
            </div>
        {* /forgotPasswordForm *}
    </div>

    <!-- forgotPasswordSuccess:
        When the user submits an email address on the forgotPassword screen,
        this screen is rendered.
    -->
    <div style="display:none;" id="forgotPasswordSuccess">
        <div class="capture_header">
            <h1>Create New Password</h1>
        </div>
            <p>We've sent an email with instructions to create a new password. Your existing password has not been changed.</p>
        <div class="capture_footer">
            <a href="#" onclick="janrain.capture.ui.modal.close()" class="capture_btn capture_primary">Close</a>
        </div>
    </div>




    <!--
    ============================================================================
        MERGE ACCOUNT SCREENS:
        The following screens are part of the account merging user workflow. For
        a complete out-of-the-box account merging experience, these screens must
        be included on the page where you are implementing account merging
        functionality.
    ============================================================================
    -->

    <!-- mergeAccounts:
        This screen is rendered if the user created their account through
        traditional registration and then tries to sign in with an IDP that
        shares the same email address that exists in their user record.

        NOTE! You will notice special tags you see on this screen. These tags,
        such as '{| current_displayName |}' are rendered by the Janrain Capture
        Widget in a way similar to JTL tags, but are more limited. We currently
        only support modifying the text in this screen through the Flow. You
        can, however, add your own markup and text throughout this screen as you
        see fit.
    -->
    <div style="display:none;" id="mergeAccounts">
        {* mergeAccounts {"custom": true} *}
        <div id="capture_mergeAccounts_mergeAccounts_mergeOptionsContainer" class="capture_mergeAccounts_mergeOptionsContainer">
            <div class="capture_header">
                <div class="capture_icon_col">
                    {| rendered_current_photo |}
                </div>
                <div class="capture_displayName_col">
                    {| current_displayName |}<br />
                    {| current_emailAddress |}
                </div>
                <span class="capture_mergeProvider janrain-provider-icon-24 janrain-provider-icon-{| current_provider_lowerCase |}"></span>
            </div>
            <div class="capture_dashed">
                <div class="capture_mergeCol capture_centerText capture_left">
                    <p class="capture_bigText">{| foundExistingAccountText |} <b>{| current_emailAddress |}</b>.</p>
                    <div class="capture_hover">
                        <div class="capture_popup_container">
                            <span class="capture_popup-arrow"></span>{| moreInfoHoverText |}<br />
                            {| existing_displayName |} - {| existing_provider |} : {| existing_siteName |} {| existing_createdDate |}
                        </div>
                        {| moreInfoText |}
                    </div>
                </div>
                <div class="capture_mergeCol capture_mergeExisting_col capture_right">
                    <div class="capture_shadow capture_backgroundColor capture_border">
                        {| rendered_existing_provider_photo |}
                        <div class="capture_displayName_col">
                            {| existing_displayName |}<br />
                            {| existing_provider_emailAddress |}
                        </div>
                        <span class="capture_mergeProvider janrain-provider-icon-16 janrain-provider-icon-{| existing_provider_lowerCase |} "></span>
                        <div class="capture_centerText capture_smallText">Created {| existing_createdDate |} at {| existing_siteName |}</div>
                    </div>
                </div>
            </div>
            <div id="capture_mergeAccounts_form_collection_mergeAccounts_mergeRadio" class="capture_form_collection_merge_radioButtonCollection capture_form_collection capture_elementCollection capture_form_collection_mergeAccounts_mergeRadio" data-capturefield="undefined">
                <div id="capture_mergeAccounts_form_item_mergeAccounts_mergeRadio_1_0" class="capture_form_item capture_form_item_mergeAccounts_mergeRadio capture_form_item_mergeAccounts_mergeRadio_1_0 capture_toggled" data-capturefield="undefined">
                    <label for="capture_mergeAccounts_mergeAccounts_mergeRadio_1_0">
                        <input id="capture_mergeAccounts_mergeAccounts_mergeRadio_1_0" data-capturefield="undefined" data-capturecollection="true" value="1" type="radio" class="capture_mergeAccounts_mergeRadio_1_0 capture_input_radio" checked="checked" name="mergeAccounts_mergeRadio">
                            {| connectLegacyRadioText |}
                    </label>
                </div>
                <div id="capture_mergeAccounts_form_item_mergeAccounts_mergeRadio_2_1" class="capture_form_item capture_form_item_mergeAccounts_mergeRadio capture_form_item_mergeAccounts_mergeRadio_2_1" data-capturefield="undefined">
                    <label for="capture_mergeAccounts_mergeAccounts_mergeRadio_2_1">
                        <input id="capture_mergeAccounts_mergeAccounts_mergeRadio_2_1" data-capturefield="undefined" data-capturecollection="true" value="2" type="radio" class="capture_mergeAccounts_mergeRadio_2_1 capture_input_radio" name="mergeAccounts_mergeRadio">
                            {| createRadioText |} {| current_provider |}
                    </label>
                </div>
                <div class="capture_tip" style="display:none;">
                </div>
                <div class="capture_tip_validating" data-elementname="mergeAccounts_mergeRadio">Validating</div>
                <div class="capture_tip_error" data-elementname="mergeAccounts_mergeRadio"></div>
            </div>
            <div class="capture_footer">
                {| connect_button |}
                {| create_button |}
            </div>
        </div>
    </div>

    <!-- traditionalAuthenticateMerge:
        When the user elects to merge their traditional and social account, the
        user will see this screen. They will then enter their current sign in
        credentials and, upon successful authorization, the accounts will be
        merged.
    -->
    <div style="display:none;" id="traditionalAuthenticateMerge">
        <div class="capture_header">
            <h1>Sign In to Complete Account Merge</h1>
        </div>
        <div class="capture_signin">
            {* #signInForm *}
                {* signInEmailAddress *}
                {* currentPassword *}
                <div class="capture_footer">
                    <div class="capture_left">
                        {* backButton *}
                    </div>
                    <div class="capture_right">
                        <button class="capture_secondary capture_btn capture_primary" type="submit"><span class="janrain-icon-16 janrain-icon-key"></span> Sign In</button>
                    </div>
                </div>
             {* /signInForm *}
        </div>
    </div>




    <!--
    ============================================================================
        EMAIL VERIFICATION SCREENS:
        The following screens are part of the email verification user workflow.
        For a complete out-of-the-box email verification experience, these
        screens must be included on page where you are implementing email
        verification.
    ============================================================================
    -->

    <!-- verifyEmail:
        This is the landing screen after a user clicks on the link in the
        verification email sent to the user when they've registered with a
        non-verified email address.

        HOW IT WORKS: The code that is generated by Capture and included in the
        link sent in the verification email is sent to the server and, if valid,
        the user's email will be marked as valid and the verifyEmailSuccess
        screen will be rendered. If the code is not accepted for any reason,
        the verifyEmail screen is shown and the user has another opportunity
        to have the verification email sent to them.

        NOTE: The links generated in the emails sent to users are based on
        Capture settings found in Janrain's Capture Dashboard. In addition to
        entering the URL of your email verification page, you will need to add
        'screenToRender' as a parameter in the URL with a value of 'verifyEmail'
        which is this screen.
    -->
    <div style="display:none;" id="verifyEmail">
        <div class="capture_header">
            <h1>Resend Verification Email</h1>
        </div>
        <p>Sorry, we could not verify that email address. Enter your email below, and we'll send you another email.</p>
        {* #resendVerificationForm *}
            {* signInEmailAddress *}
            <div class="capture_footer">
                <input value="Submit" type="submit" class="capture_btn capture_primary">
            </div>
         {* /resendVerificationForm *}
    </div>

    <!-- resendVerificationSuccess:
        This screen is rendered when a user enters an email address from the
        verifyEmail screen.
    -->
    <div style="display:none;" id="resendVerificationSuccess">
        <div class="capture_header">
            <h1>Verification Email Sent</h1>
        </div>
        <div class="hr"></div>
        <p>Check your email for a link to verify your email address.</p>
        <div class="capture_footer">
            <a href="index.html" class="capture_btn capture_primary">Sign in</a>
        </div>
    </div>

    <!-- verifyEmailSuccess:
        This screen is rendered if the verification code provided in the link
        sent to the user in the verification email is accepted and the user's
        email address has been verified.
    -->
    <div style="display:none;" id="verifyEmailSuccess">
        <div class="capture_header">
            <h1>Email Verified</h1>
        </div>
        <p>Thank you for verifiying your email address.
        <div class="capture_footer">
            <a href="index.html" class="capture_btn capture_primary">Sign in</a>
        </div>
    </div>




    <!--
    ============================================================================
        RESET PASSWORD SCREENS:
        The following screens are part of the password reset user workflow.
        For a complete out-of-the-box password reset experience, these screens
        must be included on the page where you are implementing password reset
        functionality.

        NOTE: The order in which these screens are rendered is as follows:
        resetPasswordRequestCode
        resetPasswordRequestCodeSuccess
        resetPassword
        resetPasswordSuccess
    ============================================================================
    -->

    <!-- resetPassword:
        This screen is rendered when the user clicks the link in provided in the
        password reset email and the code in the link is valid.
    -->
    <div style="display:none;" id="resetPassword">
        <div class="capture_header">
            <h1>Change Password</h1>
        </div>
        {* #changePasswordFormNoAuth *}
            {* newPassword *}
            {* newPasswordConfirm *}
            <div class="capture_footer">
                <input value="Submit" type="submit" class="capture_btn capture_primary">
            </div>
        {* /changePasswordFormNoAuth *}
    </div>
    <!-- resetPasswordSuccess:
        This screen is rendered when the user successfully changes their
        password from the resetPassword screen.
    -->
    <div style="display:none;" id="resetPasswordSuccess">
        <div class="capture_header">
            <h1>Password Changed</h1>
        </div>
        <p>Your password has been successfully updated.</p>
        <div class="capture_footer">
            <a href="index.html" class="capture_btn capture_primary">Sign in</a>
        </div>
    </div>
    <!-- resetPasswordRequestCode:
        This is the landing screen for the password reset workflow. When the
        user clicks the link provided in the reset password email, a code is
        supplied and is passed to Capture for verification. If the code is valid
        the resetPassword screen is rendered immediately and the content of
        this screen is not presented. If the code is not accepted for any reason
        this screen is then presented, allowing the user to re-enter their
        email address.
    -->
    <div style="display:none;" id="resetPasswordRequestCode">
        <div class="capture_header">
            <h1>Create New Password</h1>
        </div>
        <p>We didn't recognize that password reset code. Enter your email below, and we'll send you another email.</p>
        {* #resetPasswordForm *}
            {* signInEmailAddress *}
            <div class="capture_footer">
                <input value="Send" type="submit" class="capture_btn capture_primary">
            </div>
        {* /resetPasswordForm *}
    </div>

    <!-- resetPasswordRequestCodeSuccess:
        This screen is rendered if the user submitted an email address on the
        resetPasswordRequestCode screen.
    -->
    <div style="display:none;" id="resetPasswordRequestCodeSuccess">
        <div class="capture_header">
            <h1>Create New Password</h1>
        </div>
            <p>We've sent you an email with instructions to create a new password. Your existing password has not been changed.</p>
        <div class="capture_footer">
            <a href="#" onclick="janrain.capture.ui.modal.close()" class="capture_btn capture_primary">Close</a>
        </div>
    </div>


    <!-- Flow version:
        This is a container for a debugging utility.  See showFlowVersion() and
        the onCaptureRenderStart event handler in janrain-init.js.
    -->
    <div id="flow-version"></div>
<style>#janrain-share { z-index: 99999 !important; }</style>
<script type="text/javascript">
(function() {
	if (typeof window.janrain !== 'object') window.janrain = {};
	if (typeof window.janrain.settings !== 'object') window.janrain.settings = {};
	if (typeof window.janrain.settings.share !== 'object') window.janrain.settings.share = {};
	if (typeof window.janrain.settings.packages !== 'object') janrain.settings.packages = ['share'];
	else janrain.settings.packages.push('share');

	janrain.settings.share.message = '';
	janrain.settings.share.providers = ['email', 'facebook', 'linkedin', 'twitter'];

})();
function setShare(url, title, desc, img, provider) {
	janrain.engage.share.setUrl(url);
	janrain.engage.share.setTitle(title);
	janrain.engage.share.setMessage(title);
	janrain.engage.share.setDescription(desc);
	janrain.engage.share.setImage(img);
	janrain.engage.share.showProvider(provider);
	janrain.engage.share.show();
}
</script>
	<script type="text/javascript">
		window.WPCOM_sharing_counts = {"https:\/\/www.embedded.com\/why-automotive-ota-update-standards-are-essential\/":4468658};
	</script>
						<script type='text/javascript' src='https://www.embedded.com/_static/??-eJyVkslOwzAQhl+IiaFCqTggrhyR+gSuM00m8YaXlvD0jNNd4lDfPP/4/2axxcGDcjahTSINaDAK5fYYLB4i+ODEGIWVe+plImebMT6JBxxxIg+a7AQ7p3KEHf08ZJUxYmK7JjUtnHJoDD1W+OTeOpdiCtIXwiWopUTqQgGM3xnD3JSwFmFkb2lHCrzz2Z9J92p1W5o6DOc9n5tbxK/gamlHPxiZ1AADUj+ka5usfS5S/dyBGXglLWENgXMkN4kff97waFsZjhLERYN4FKuXpwL5VOPgj4sdb0aWpd/bySqdOzaOxWsMoyCg1/N/XZkMXueeLF/H5KWa4K1ZiT3azgUhc3K8b57tktXydwbiv8IFYlClyI10W+K2Dw7RbLE75T/M+0v7vH5t29W6Hf8A4yJ8Hw=='></script>
<script id='sharing-js-js-extra'>
var sharing_js_options = {"lang":"en","counts":"1","is_stats_active":"1"};
</script>
<script src='https://www.embedded.com/wp-content/mu-plugins/jetpack-9.2/_inc/build/sharedaddy/sharing.min.js?ver=9.2.1' id='sharing-js-js'></script>
<script id='sharing-js-js-after'>
var windowOpen;
			jQuery( document.body ).on( 'click', 'a.share-twitter', function() {
				// If there's another sharing window open, close it.
				if ( 'undefined' !== typeof windowOpen ) {
					windowOpen.close();
				}
				windowOpen = window.open( jQuery( this ).attr( 'href' ), 'wpcomtwitter', 'menubar=1,resizable=1,width=600,height=350' );
				return false;
			});
var windowOpen;
			jQuery( document.body ).on( 'click', 'a.share-facebook', function() {
				// If there's another sharing window open, close it.
				if ( 'undefined' !== typeof windowOpen ) {
					windowOpen.close();
				}
				windowOpen = window.open( jQuery( this ).attr( 'href' ), 'wpcomfacebook', 'menubar=1,resizable=1,width=600,height=400' );
				return false;
			});
var windowOpen;
			jQuery( document.body ).on( 'click', 'a.share-linkedin', function() {
				// If there's another sharing window open, close it.
				if ( 'undefined' !== typeof windowOpen ) {
					windowOpen.close();
				}
				windowOpen = window.open( jQuery( this ).attr( 'href' ), 'wpcomlinkedin', 'menubar=1,resizable=1,width=580,height=450' );
				return false;
			});
var windowOpen;
			jQuery( document.body ).on( 'click', 'a.share-tumblr', function() {
				// If there's another sharing window open, close it.
				if ( 'undefined' !== typeof windowOpen ) {
					windowOpen.close();
				}
				windowOpen = window.open( jQuery( this ).attr( 'href' ), 'wpcomtumblr', 'menubar=1,resizable=1,width=450,height=450' );
				return false;
			});
var windowOpen;
			jQuery( document.body ).on( 'click', 'a.share-skype', function() {
				// If there's another sharing window open, close it.
				if ( 'undefined' !== typeof windowOpen ) {
					windowOpen.close();
				}
				windowOpen = window.open( jQuery( this ).attr( 'href' ), 'wpcomskype', 'menubar=1,resizable=1,width=305,height=665' );
				return false;
			});
var windowOpen;
			jQuery( document.body ).on( 'click', 'a.share-pocket', function() {
				// If there's another sharing window open, close it.
				if ( 'undefined' !== typeof windowOpen ) {
					windowOpen.close();
				}
				windowOpen = window.open( jQuery( this ).attr( 'href' ), 'wpcompocket', 'menubar=1,resizable=1,width=450,height=450' );
				return false;
			});
var windowOpen;
			jQuery( document.body ).on( 'click', 'a.share-telegram', function() {
				// If there's another sharing window open, close it.
				if ( 'undefined' !== typeof windowOpen ) {
					windowOpen.close();
				}
				windowOpen = window.open( jQuery( this ).attr( 'href' ), 'wpcomtelegram', 'menubar=1,resizable=1,width=450,height=450' );
				return false;
			});
</script>
<script type='text/javascript' src='https://stats.wp.com/e-202052.js' async='async' defer='defer'></script>
<script type='text/javascript'>
	_stq = window._stq || [];
	_stq.push([ 'view', {v:'ext',j:'1:9.2.1',blog:'155001676',post:'4468658',tz:'0',srv:'www.embedded.com'} ]);
	_stq.push([ 'clickTrackerInit', '155001676', '4468658' ]);
</script>

<script type="text/javascript">
    var _gaq = _gaq || [];
    _gaq.push(['_setAccount', 'UA-20164576-1']);
    _gaq.push(['_setDomainName', '.embedded.com']);
    _gaq.push(['_trackPageview']);
    _gaq.push(['_trackEvent']);
    (function() {
        var ga = document.createElement('script'); ga.type = 'text/javascript'; ga.async = true;
        ga.src = ('https:' == document.location.protocol ? 'https://ssl' : 'http://www') + '.google-analytics.com/ga.js';
        var s = document.getElementsByTagName('script')[0]; s.parentNode.insertBefore(ga, s);
    })();
</script>
<script type="text/javascript">window.NREUM||(NREUM={});NREUM.info={"beacon":"bam.nr-data.net","licenseKey":"80caaa83e0","applicationID":"197311801","transactionName":"NgMGZREHV0JUAkEMDQ9JMUMKSVBfUQRNSxIJFg==","queueTime":0,"applicationTime":310,"atts":"GkQRE1kdRB0XABdfGRwb","errorBeacon":"bam.nr-data.net","agent":""}</script></body>
</html>